]> git.donarmstrong.com Git - lilypond.git/blob - make/out/redhat.spec
release: 1.3.152
[lilypond.git] / make / out / redhat.spec
1 %define info yes
2
3 Name: lilypond
4 Version: 1.3.152
5 Release: 1
6 License: GPL
7 Group: Applications/Publishing
8 Source0: ftp.cs.uu.nl:/pub/GNU/LilyPond/development/lilypond-1.3.152.tar.gz
9 Summary: Create and print music notation 
10 URL: http://www.cs.uu.nl/~hanwen/lilypond
11 BuildRoot: /tmp/lilypond-install
12 # add lots of Buildreq: flex, bison, tetex, tetex-devel, tetex-latex, texinfo
13 # better prereqs: tetex-latex, python, (mpost?) etc.
14 Prereq: tetex
15
16
17 %description
18 LilyPond lets you create music notation.  It produces
19 beautiful sheet music from  a high-level description file.
20
21 %package documentation
22 Summary: Prebuilt website containing all LilyPond documentation.
23 Group: Applications/Publishing
24 # BuildArchitectures: noarch
25
26 %description documentation
27
28 The documentation of LilyPond, both in HTML and PostScript.
29
30 %prep
31 %setup
32
33 %build
34
35 # DO NOT use % { configure } , it hardcodes all paths, runs libtool,
36 # so we can't do make prefix=/tmp/ install.
37
38 # In fact, do not take out the spaces between % and { in the above comment,
39 # because RPM will gladly do a substitution anyway.
40
41 ./configure --disable-checking --disable-debugging --enable-printing --prefix=%{_prefix} --disable-optimise --enable-shared
42
43 make all
44
45 # ok, now make sure that lilypond package will succeed,
46 # even if documentation fails to build
47 make -C Documentation  || true
48 make web || true
49
50 %install
51
52
53 rm -rf $RPM_BUILD_ROOT
54 mkdir -p $RPM_BUILD_ROOT/tmp/lilypond-rpm-doc
55
56 strip lily/out/lilypond midi2ly/out/midi2ly
57 make prefix="$RPM_BUILD_ROOT%{_prefix}" install
58
59 %if info=="yes"
60 gzip -9fn $RPM_BUILD_ROOT%{_prefix}/info/* || true
61 %endif
62
63 mkdir -p $RPM_BUILD_ROOT/usr/share/emacs/site-lisp/site-start.d
64 install -m 644 lilypond-mode.el lilypond-font-lock.el $RPM_BUILD_ROOT/usr/share/emacs/site-lisp/
65 install -m 644 lilypond-init.el $RPM_BUILD_ROOT/usr/share/emacs/site-lisp/site-start.d
66
67 gzip -9fn $RPM_BUILD_ROOT%{_prefix}/man/man1/* || true
68
69 mkdir -p $RPM_BUILD_ROOT%{_prefix}/../etc/profile.d
70 cp buildscripts/out/lilypond-profile $RPM_BUILD_ROOT%{_prefix}/../etc/profile.d/lilypond.sh
71 cp buildscripts/out/lilypond-login $RPM_BUILD_ROOT%{_prefix}/../etc/profile.d/lilypond.csh
72
73
74 # again, make sure that main package installs even if doco fails
75 mkdir -p web/out
76 tar -C web -xzf out/web.tar.gz || true
77
78
79 %post
80
81 touch /tmp/.lilypond-install
82 rm `find /var/lib/texmf -name 'feta*pk -print' -or -name 'feta*tfm -print'` /tmp/.lilypond-install
83
84 %if info=="yes"
85 /sbin/install-info %{_prefix}/info/lilypond.info.gz %{_prefix}/info/dir || true
86 %endif
87
88 %preun
89
90 %if info=="yes"
91 if [ $1 = 0 ]; then
92     /sbin/install-info --delete %{_prefix}/info/lilypond.info.gz %{_prefix}/info/dir || true
93 fi
94 %endif
95
96
97 %files
98
99 %{_datadir}/emacs/site-lisp/*
100 %{_datadir}/emacs/site-lisp/site-start.d/*
101
102 %{_prefix}/bin/abc2ly
103 %{_prefix}/bin/as2text
104 %{_prefix}/bin/convert-ly
105 %{_prefix}/bin/etf2ly
106 %{_prefix}/bin/lilypond
107 %{_prefix}/bin/ly2dvi
108 %{_prefix}/bin/midi2ly
109 %{_prefix}/bin/lilypond-book
110 %{_prefix}/bin/mup2ly
111 %{_prefix}/bin/musedata2ly
112 %{_prefix}/bin/pmx2ly
113
114 %if info=="yes"
115 %{_prefix}/info/lilypond.info.gz
116 %{_prefix}/info/lilypond-internals.info.gz
117 %endif
118
119 %{_prefix}/man/man1/abc2ly.1.gz
120 %{_prefix}/man/man1/as2text.1.gz
121 %{_prefix}/man/man1/convert-ly.1.gz
122 %{_prefix}/man/man1/etf2ly.1.gz
123 %{_prefix}/man/man1/lilypond.1.gz
124 %{_prefix}/man/man1/ly2dvi.1.gz
125 %{_prefix}/man/man1/midi2ly.1.gz
126 %{_prefix}/man/man1/lilypond-book.1.gz
127 %{_prefix}/man/man1/musedata2ly.1.gz
128 %{_prefix}/man/man1/mup2ly.1.gz
129 %{_prefix}/man/man1/pmx2ly.1.gz
130
131 %{_prefix}/share/lilypond/
132 %{_prefix}/share/locale/*/LC_MESSAGES/lilypond.mo
133 %{_prefix}/../etc/profile.d/lilypond.*
134
135 %files documentation
136 %doc web/