]> git.donarmstrong.com Git - deb_pkgs/scowl.git/blobdiff - speller/Makefile
distribute all scowl files as utf-8
[deb_pkgs/scowl.git] / speller / Makefile
index b70ed2dc34b8af9652eecc6aff6be43203204283..cf51c14e5e9cec675486161087118e30e69f75b1 100644 (file)
@@ -8,11 +8,14 @@ all:
        touch .aspell
 aspell: .aspell
 
-.hunspell: .aspell make-hunspell-dict add-no-suggest en.aff en.dic.supp
-       ./make-hunspell-dict
+.hunspell: make-hunspell-dict add-no-suggest en.aff en.dic.supp README_en.txt.sh
+       ./make-hunspell-dict -all
        touch .hunspell
 hunspell: .hunspell
 
 clean:
-       rm -f .aspell .hunspell
-       rm -f *.wl en_*.dic en_*.aff *.zip *.tocheck README_en_??.txt
+       rm -rf hunspell/ *.zip
+       cat to-clean | xargs rm -f
+
+to-clean: .gitignore
+       echo `cat .gitignore | grep -v '^#'` | tr ' ' '\n' | grep -v hunspell/ | grep -v \.zip > to-clean