]> git.donarmstrong.com Git - deb_pkgs/scowl.git/commitdiff
distribute all scowl files as utf-8
authorDon Armstrong <don@donarmstrong.com>
Sun, 29 Mar 2020 23:17:37 +0000 (16:17 -0700)
committerDon Armstrong <don@donarmstrong.com>
Sun, 29 Mar 2020 23:26:19 +0000 (16:26 -0700)
debian/NEWS [new file with mode: 0644]
debian/changelog
debian/rules

diff --git a/debian/NEWS b/debian/NEWS
new file mode 100644 (file)
index 0000000..125396d
--- /dev/null
@@ -0,0 +1,8 @@
+scowl (2019.10.06-1) unstable; urgency=medium
+
+  * The scowl binary package now distributes all of its wordlists in UTF-8
+    rather than iso8859-1. This is different than the upstream default of
+    iso8859-1.
+
+ -- Don Armstrong <don@debian.org>  Sun, 29 Mar 2020 16:12:29 -0700
+
index ed138cc0fb7d1c09cf46d3a9f26608a82f09ca64..4877384b574d01024c67360a2bce37a95e514e37 100644 (file)
@@ -3,6 +3,7 @@ scowl (2019.10.06-1) unstable; urgency=medium
   * New upstream release (Closes: #952736)
   * Deprecate reprized for reprised (Closes: #952653)
   * Use up to 70 wordlists for hunspell (Closes: #933544)
+  * Distribute all scowl files as utf-8 (Closes: #775480)
 
  -- Don Armstrong <don@debian.org>  Sat, 29 Feb 2020 20:07:46 -0800
 
index 3e0aa21e088f0ec2ac6fd7870ec941048aa00544..13ac6a9cd20932d69a8f5675c4fe0711f2906b99 100755 (executable)
@@ -41,6 +41,11 @@ include /usr/share/dpkg/pkg-info.mk
        dh $@
 
 override_dh_auto_build:
+       set -e; \
+       mkdir -p final_utf8;\
+       for file in final/*.[0-9][0-9]; do\
+               iconv -f 'iso8859-1' -t 'utf-8' < $${file} > final_utf8/$$(basename $${file}); \
+       done;
        set -e;\
        for SPELLING in $(SPELLINGS); do\
          for SIZE in $(SIZES); do\
@@ -100,6 +105,7 @@ override_dh_auto_build:
        cd speller && $(MAKE) hunspell
 
 override_dh_auto_clean:
+       rm -rf final_utf8;
        set -e;\
        for SIZE in $(SIZES); do\
          if [ -n "$$SIZE" ]; then SIZE="-$$SIZE"; fi; \
@@ -119,7 +125,7 @@ override_dh_auto_install: install-scowl install-hunspell $(INSTALL_WORDLISTS)
 install-scowl:
        dh_installdirs --package=scowl
 
-       dh_install --package=scowl final/*.[0-9][0-9] usr/share/dict/scowl
+       dh_install --package=scowl final_utf8/*.[0-9][0-9] usr/share/dict/scowl
        dh_installdocs --package=scowl README debian/README.Debian
 
 install-hunspell: