]> git.donarmstrong.com Git - lilypond.git/blobdiff - debian/rules
mutopia move
[lilypond.git] / debian / rules
old mode 100755 (executable)
new mode 100644 (file)
index 15dbc65..6c09045
@@ -42,7 +42,7 @@ build-stamp:
                --prefix=/usr --enable-optimise \
                --infodir='$${prefix}/share/info' \
                --mandir='$${prefix}/share/man'
-       $(MAKE)
+       $(MAKE) MAKE_PFA_FILES=1
 
        touch build-stamp
 
@@ -64,7 +64,6 @@ clean:
 
        # Still not clean enough?  Let's use... BRUTE STRENGTH!  :-)
        find . -type d -name 'out' -o -name 'out-www' | xargs rm -rf
-       rm -f debian/doc-base debian/TODO
 
        dh_clean
 
@@ -76,7 +75,7 @@ install: build
 
        # Add here commands to install the package into debian/tmp.
        dh_installdirs
-       $(MAKE) prefix=$(PWD)/$(r)/usr install
+       $(MAKE) prefix=$(PWD)/$(r)/usr  MAKE_PFA_FILES=1 install
 
        # Change from an absolute symlink to a relative symlink (Lintian)
        if [ -L $(r)/usr/share/lilypond/cmtfm ]; then \
@@ -112,7 +111,7 @@ binary-arch: DH_OPTIONS=-a
 binary-arch: build install
        dh_testdir
        dh_testroot
-       cp -av lilypond-mode.el lilypond-font-lock.el \
+       cp -av lilypond-mode.el lilypond-font-lock.el lilypond-indent.el \
                $(r)/usr/share/emacs/site-lisp/
        dh_installdocs DEDICATION NEWS ROADMAP *.txt
 
@@ -125,7 +124,7 @@ binary-arch: build install
 #      cp -a Documentation/misc/[ACN]* $(r)/$(d)/misc/
 
 #      dh_installexamples input
-       cp -aP `find input mutopia \( -name '*.*ly' -o -name '*.abc' -o -name '*.tex' -o -name 'TODO' \)` \
+       cp -aP `find input  \( -name '*.*ly' -o -name '*.abc' -o -name '*.tex' -o -name 'TODO' \)` \
                $(r)/$(d)/examples
        for i in `find $(r)/$(d)/examples/ -type d -name out`; do \
                mv -fv $$i/* $$i/..; rmdir $$i; done