]> git.donarmstrong.com Git - lilypond.git/blobdiff - debian/rules
* Apply patch from 77c34ddc (Werner Lemberg <wl@gnu.org>)
[lilypond.git] / debian / rules
index ac50d8b899cca72ac29b52150cafd620897f08e5..e1c28bc912d1a677711e98704504a72e2086ad9e 100755 (executable)
@@ -58,8 +58,8 @@ build-stamp:
                --prefix=/usr --enable-optimising \
                --infodir='$${prefix}/share/info' \
                --mandir='$${prefix}/share/man'
-       $(MAKE)
-       $(MAKE) test;
+       ulimit -c unlimited && $(MAKE)
+       ulimit -c unlimited && $(MAKE) test;
 
        touch build-stamp
 
@@ -69,9 +69,9 @@ build-doc-stamp:
 
        # make html
        # unfortunatly, this does not work well with multiple processors
-       $(MAKE) -j1 doc WEB_TARGETS="offline"
+       ulimit -c unlimited && $(MAKE) -j1 doc WEB_TARGETS="offline"
        # make info
-       $(MAKE) info
+       ulimit -c unlimited && $(MAKE) info
 
        touch build-doc-stamp
 
@@ -131,14 +131,8 @@ binary-indep: build-doc install
                        usr/share/texmf/tex/lilypond \
                usr/share/lilypond/$(VERSION)/fonts/source \
                        usr/share/texmf/fonts/source/public/lilypond \
-               usr/share/lilypond/$(VERSION)/fonts/afm \
-                       usr/share/texmf/fonts/afm/public/lilypond \
-               usr/share/lilypond/$(VERSION)/fonts/tfm \
-                       usr/share/texmf/fonts/tfm/public/lilypond \
                usr/share/lilypond/$(VERSION)/fonts/type1 \
                        usr/share/texmf/fonts/type1/public/lilypond \
-               etc/texmf/dvips/lilypond.map \
-                       usr/share/lilypond/$(VERSION)/dvips/lilypond.map
 
        dh_pysupport /usr/share/lilypond/${VERSION}/python