]> git.donarmstrong.com Git - lilypond.git/blobdiff - debian/rules
* Apply patch from 77c34ddc (Werner Lemberg <wl@gnu.org>)
[lilypond.git] / debian / rules
index 569569fc3f56b787ca0dc7ff9c7a687262453a29..e1c28bc912d1a677711e98704504a72e2086ad9e 100755 (executable)
@@ -58,8 +58,8 @@ build-stamp:
                --prefix=/usr --enable-optimising \
                --infodir='$${prefix}/share/info' \
                --mandir='$${prefix}/share/man'
-       $(MAKE)
-       $(MAKE) test
+       ulimit -c unlimited && $(MAKE)
+       ulimit -c unlimited && $(MAKE) test;
 
        touch build-stamp
 
@@ -68,9 +68,10 @@ build-doc-stamp:
        dh_testdir
 
        # make html
-       $(MAKE) doc WEB_TARGETS="offline"
+       # unfortunatly, this does not work well with multiple processors
+       ulimit -c unlimited && $(MAKE) -j1 doc WEB_TARGETS="offline"
        # make info
-       $(MAKE) info
+       ulimit -c unlimited && $(MAKE) info
 
        touch build-doc-stamp
 
@@ -81,7 +82,7 @@ clean:
        [ ! -f Makefile ] || $(MAKE) web-clean
        [ ! -f Makefile ] || $(MAKE) distclean
        rm -f lib/python
-       rm -f ./stepmake/bin/config.guess ./stepmake/bin/config.guess.sub
+       rm -f ./stepmake/bin/config.guess ./stepmake/bin/config.guess.sub ./stepmake/bin/config.sub
 
        # Still not clean enough?  Let's use... BRUTE STRENGTH!  :-)
        find . -type d -name 'out' -o -name 'out-www' | xargs rm -rf
@@ -122,27 +123,16 @@ binary-indep: build-doc install
                -type d -empty -delete
        dh_installemacsen
 
-       #find input \( -name '*.*ly' -o -name '*.abc' -o -name '*.tex' -o -name 'TODO' \) ! -regex '.*/out-www/.*' \
-       #       -exec cp -a --parents '{}' $(r_data)/$(d)/examples ';'
        install -m 644 debian/xiao-haizi-guai-guai.ly debian/sakura-sakura.ly \
                $(r_data)/$(d)/examples
        dh_installchangelogs
 
-#      mv $(r_data)/usr/share/lilypond/$(VERSION)/fonts/map/lilypond.map \
-#         $(r_data)/etc/texmf/dvips/lilypond.map
-
        dh_link usr/share/lilypond/$(VERSION)/tex \
                        usr/share/texmf/tex/lilypond \
                usr/share/lilypond/$(VERSION)/fonts/source \
                        usr/share/texmf/fonts/source/public/lilypond \
-               usr/share/lilypond/$(VERSION)/fonts/afm \
-                       usr/share/texmf/fonts/afm/public/lilypond \
-               usr/share/lilypond/$(VERSION)/fonts/tfm \
-                       usr/share/texmf/fonts/tfm/public/lilypond \
                usr/share/lilypond/$(VERSION)/fonts/type1 \
                        usr/share/texmf/fonts/type1/public/lilypond \
-               etc/texmf/dvips/lilypond.map \
-                       usr/share/lilypond/$(VERSION)/dvips/lilypond.map
 
        dh_pysupport /usr/share/lilypond/${VERSION}/python
 
@@ -165,6 +155,7 @@ binary-arch: build install
        dh_installchangelogs Documentation/misc/CHANGES* Documentation/misc/ChangeLog*
 
        dh_strip
+       dh_pysupport /usr/share/lilypond/${VERSION}/python
        dh_compress
        dh_fixperms
        dh_installdeb