]> git.donarmstrong.com Git - lilypond.git/blobdiff - debian/rules
remove useless clean rules
[lilypond.git] / debian / rules
index ac50d8b899cca72ac29b52150cafd620897f08e5..ddc6ce5df401f42f50780f1e11da0fc478b73a2d 100755 (executable)
@@ -58,8 +58,8 @@ build-stamp:
                --prefix=/usr --enable-optimising \
                --infodir='$${prefix}/share/info' \
                --mandir='$${prefix}/share/man'
-       $(MAKE)
-       $(MAKE) test;
+       ulimit -c unlimited && $(MAKE)
+       ulimit -c unlimited && $(MAKE) test;
 
        touch build-stamp
 
@@ -69,9 +69,9 @@ build-doc-stamp:
 
        # make html
        # unfortunatly, this does not work well with multiple processors
-       $(MAKE) -j1 doc WEB_TARGETS="offline"
+       ulimit -c unlimited && $(MAKE) -j1 doc WEB_TARGETS="offline"
        # make info
-       $(MAKE) info
+       ulimit -c unlimited && $(MAKE) info
 
        touch build-doc-stamp
 
@@ -82,10 +82,7 @@ clean:
        [ ! -f Makefile ] || $(MAKE) web-clean
        [ ! -f Makefile ] || $(MAKE) distclean
        rm -f lib/python
-       rm -f ./stepmake/bin/config.guess ./stepmake/bin/config.guess.sub ./stepmake/bin/config.sub
 
-       # Still not clean enough?  Let's use... BRUTE STRENGTH!  :-)
-       find . -type d -name 'out' -o -name 'out-www' | xargs rm -rf
        rm -f buildscripts/*.pyc
        rm -f lib/lilypond/python examples.html
        rm -f debian/emacsen-startup
@@ -131,14 +128,8 @@ binary-indep: build-doc install
                        usr/share/texmf/tex/lilypond \
                usr/share/lilypond/$(VERSION)/fonts/source \
                        usr/share/texmf/fonts/source/public/lilypond \
-               usr/share/lilypond/$(VERSION)/fonts/afm \
-                       usr/share/texmf/fonts/afm/public/lilypond \
-               usr/share/lilypond/$(VERSION)/fonts/tfm \
-                       usr/share/texmf/fonts/tfm/public/lilypond \
                usr/share/lilypond/$(VERSION)/fonts/type1 \
                        usr/share/texmf/fonts/type1/public/lilypond \
-               etc/texmf/dvips/lilypond.map \
-                       usr/share/lilypond/$(VERSION)/dvips/lilypond.map
 
        dh_pysupport /usr/share/lilypond/${VERSION}/python