]> git.donarmstrong.com Git - lilypond.git/blobdiff - debian/rules
Run tests only when documentation has been built
[lilypond.git] / debian / rules
index 48ceeb322117c06c00d8907ea6db3a5dbb1f6aab..cb8223a4c7202a9ed7fdf29e1461d6a90652833b 100755 (executable)
@@ -182,8 +182,12 @@ override_dh_shlibdeps-arch:
        $(eval unexport LD_LIBRARY_PATH)
        dh_shlibdeps -a -O--parallel -lusr/lib/$(DEB_HOST_MULTIARCH)/lilypond/$(LILYPOND_VERSION)/guile
 
-override_dh_auto_test:
-ifneq (,$(filter $(DEB_BUILD_OPTIONS),nocheck))
+# Skip tests for architecture-dependent-only build because
+# the test would fail without built documentation.
+override_dh_auto_test-arch:
+
+override_dh_auto_test-indep:
+ifeq (,$(filter $(DEB_BUILD_OPTIONS),nocheck))
        $(MAKE) test-baseline
        $(MAKE) test
 endif