]> git.donarmstrong.com Git - lilypond.git/blobdiff - debian/rules
update changelog and tweak dh2 python override to not require changing each new version
[lilypond.git] / debian / rules
index 1768d6d3b962815cf8b08626cff1d36d3443127c..c8b3684da189b385f4174a148a168c52595683fc 100755 (executable)
@@ -24,7 +24,7 @@ endif
 
 DOC_OPTIONS := WEB_TARGETS="offline"
 ifneq (,$(filter parallel=%,$(DEB_BUILD_OPTIONS)))
-       DOC_OPTIONS := $(DOC_OPTIONS) $(DEB_BUILD_OPTIONS) CPU_COUNT=$(firstword $(patsubst parallel=%,%,$(filter parallel=%,$(DEB_BUILD_OPTIONS))))
+       DOC_OPTIONS := $(DOC_OPTIONS) CPU_COUNT=$(firstword $(patsubst parallel=%,%,$(filter parallel=%,$(DEB_BUILD_OPTIONS))))
 endif
 
 %:
@@ -36,13 +36,25 @@ override_dh_auto_configure:
 
 override_dh_auto_build-indep:
        dh_auto_build
-       $(MAKE) $(DOC_OPTIONS) doc
+       $(MAKE) doc $(DOC_OPTIONS)
 
 override_dh_auto_install-indep:
-       $(MAKE) install-doc prefix=$(CURDIR)/debian/tmp/usr/
+       $(MAKE) install-doc $(DOC_OPTIONS) prefix=$(CURDIR)/debian/tmp/usr/
+       $(MAKE) install-info $(DOC_OPTIONS) prefix=$(CURDIR)/debian/tmp/usr
        rm -rf $(CURDIR)/debian/tmp/usr/share/omf
        rm -rf $(CURDIR)/debian/tmp/usr/share/doc/lilypond/html/input
 
+## Unfortunately, lilypond is kind of broken, and installs the wrong
+## info documentation (missing images) if we call their makefile
+## directly. They also don't provide an install rule which doesn't
+## install the documentation, which we don't care about for the
+## architecture dependent build
+override_dh_auto_install-arch:
+       for dir in `echo */*makefile|xargs -n 1 dirname|grep -v Documentation`; do \
+               $(MAKE) --no-builtin-rules PACKAGE=LILYPOND package=lilypond -C $$dir install $(DOC_OPTIONS) prefix=$(CURDIR)/debian/tmp/usr/; \
+       done;
+
+
 ## we need to install only the png, jpg, css, ly and english html
 ## files into the doc-html package, and only the english pdfs into the
 ## doc-pdf package. Because dh_install doesn't support regexes, we'll
@@ -65,6 +77,20 @@ override_dh_install:
                -printf '%P\n' >> $(CURDIR)/debian/lilypond-doc-pdf.install
        dh_install --list-missing
 
+override_dh_python2:
+       dh_python2
+       dh_python2 usr/share/lilypond/*/python/
+
+override_dh_compress:
+       dh_compress -X.ly
+
+override_dh_installdocs:
+       dh_installdocs
+       for a in $(wildcard $(CURDIR)/debian/*.doc-base-special); do \
+               package=`basename $$a .doc-base-special`; \
+               install -d debian/$$package/usr/share/doc-base; \
+               install -m0644 $$a debian/$$package/usr/share/doc-base/$$package; \
+       done;
 
 ## this rule will update debian/control and the per-language install
 ## files; all of the files it generates/modifies should be included in