]> git.donarmstrong.com Git - lilypond.git/blobdiff - debian/rules
Properly remove empty /usr/share/info/lilypond directory and replace with symlink
[lilypond.git] / debian / rules
old mode 100644 (file)
new mode 100755 (executable)
index e9e88ae..ac50d8b
@@ -13,10 +13,15 @@ SHELL = /bin/sh
 r = debian/$(package)
 r_data = debian/$(package)-data
 r_doc = debian/$(package)-doc
-
-# FIXME: /usr
 d = usr/share/doc/$(package)
-info = /usr/share/info/$(package)
+
+# since I'm building this a few times on my 8-way machine, try to
+# build it faster
+ifneq (,$(filter parallel=%,$(DEB_BUILD_OPTIONS)))
+    NUMJOBS = $(patsubst parallel=%,%,$(filter parallel=%,$(DEB_BUILD_OPTIONS)))
+    MAKEFLAGS += -j$(NUMJOBS) CPU_COUNT=$(NUMJOBS)
+endif
+
 
 include VERSION
 VERSION = $(MAJOR_VERSION).$(MINOR_VERSION).$(PATCH_LEVEL)
@@ -34,6 +39,10 @@ export USER_CFLAGS = -DDEBIAN
 export DEB_BUILD = yes
 export MAILADDRESS = lilypond@packages.debian.org
 
+# fontconfig blows chunks if it can't write $HOME; and some buildd's
+# set it to a bogus value.
+export HOME = /tmp
+
 # Uncomment this to turn on verbose mode.
 #export DH_VERBOSE=1
 
@@ -44,11 +53,13 @@ build: build-stamp
 build-stamp:
        dh_testdir
 
+       cp -f /usr/share/misc/config.guess /usr/share/misc/config.sub ./stepmake/bin/
        ./configure --disable-checking --enable-debugging \
                --prefix=/usr --enable-optimising \
                --infodir='$${prefix}/share/info' \
                --mandir='$${prefix}/share/man'
        $(MAKE)
+       $(MAKE) test;
 
        touch build-stamp
 
@@ -56,12 +67,11 @@ build-doc: build build-doc-stamp
 build-doc-stamp:
        dh_testdir
 
-       # make info
-       $(MAKE) -C Documentation
        # make html
-       $(MAKE) web
-       $(MAKE) -C Documentation/user omf
-#      find . -type d -name 'out-www' | xargs rm -rf
+       # unfortunatly, this does not work well with multiple processors
+       $(MAKE) -j1 doc WEB_TARGETS="offline"
+       # make info
+       $(MAKE) info
 
        touch build-doc-stamp
 
@@ -69,16 +79,20 @@ clean:
        dh_testdir
        dh_testroot
        rm -f build-stamp build-doc-stamp
-       -$(MAKE) WWW-clean top-WWW-clean
-       -$(MAKE) distclean
+       [ ! -f Makefile ] || $(MAKE) web-clean
+       [ ! -f Makefile ] || $(MAKE) distclean
+       rm -f lib/python
+       rm -f ./stepmake/bin/config.guess ./stepmake/bin/config.guess.sub ./stepmake/bin/config.sub
 
        # Still not clean enough?  Let's use... BRUTE STRENGTH!  :-)
        find . -type d -name 'out' -o -name 'out-www' | xargs rm -rf
+       rm -f buildscripts/*.pyc
        rm -f lib/lilypond/python examples.html
        rm -f debian/emacsen-startup
        rm -f debian/lilypond1.7*.dirs debian/lilypond.dirs
        rm -f debian/postinst debian/prerm debian/postrm
        rm -f debian/lilypond-data.doc-base debian/lilypond.doc-base
+       rm -f GNUmakefile config.log config.make config.status config.hh
 
        dh_clean
 
@@ -94,40 +108,25 @@ install: build
 
        dh_install --sourcedir=debian/tmp --list-missing
 
-#      # Change from an absolute symlink to a relative symlink (Lintian)
-#      if [ -L $(r)/usr/share/lilypond/cmtfm ]; then \
-#              rm -f $(r)/usr/share/lilypond/cmtfm; \
-#              ln -s ../texmf/fonts/tfm/public/cm $(r)/usr/share/lilypond/cmtfm; \
-#      fi
-
 # Build architecture-independent files here.
 binary-indep: DH_OPTIONS=-i
 binary-indep: build-doc install
        dh_testdir
        dh_testroot
        # Install LilyPond web documentation...
-       $(MAKE) prefix=$(PWD)/$(r_doc)/usr webdir=$(PWD)/$(r_doc)/$(d)/html out=www web-install
-       # Add symlinks to the PostScript docs and LilyPond logo PNGs for HTML...
-       cd $(r_doc)/$(d) \
-           && cp -s `find html/Documentation -name '*.ps.gz'` . \
-           && cp -s html/Documentation/pictures/out-www/*.png .
-       # Add symlinks to the documentation PNGs for info...
-       cd $(r_doc)/$(info) \
-           && cp -s ../../doc/$(package)/html/Documentation/user/out-www/*.png .
-#      # Copy the DVI docs too ...
-#      cp -a `find Documentation -name '*.dvi' ! -name 'lily-[0-9]*.dvi'` \
-#              $(r_doc)/$(d)/
+       $(MAKE) install-doc prefix=$(CURDIR)/debian/lilypond-doc/usr/
+       # it installs a random dir-dep file for no reason
+       rm -f $(CURDIR)/debian/lilypond-doc/usr/share/info/*-dir-dep*
+
        dh_installdocs
+       find $(CURDIR)/debian/lilypond-doc/usr/share/doc/lilypond/html \
+               -type d -empty -delete
        dh_installemacsen
-       dh_scrollkeeper
 
-       find input \( -name '*.*ly' -o -name '*.abc' -o -name '*.tex' -o -name 'TODO' \) ! -regex '.*/out-www/.*' \
-               -exec cp -a --parents '{}' $(r_data)/$(d)/examples ';'
+       install -m 644 debian/xiao-haizi-guai-guai.ly debian/sakura-sakura.ly \
+               $(r_data)/$(d)/examples
        dh_installchangelogs
 
-       mv $(r_data)/usr/share/lilypond/$(VERSION)/fonts/map/lilypond.map \
-          $(r_data)/etc/texmf/dvips/lilypond.map
-
        dh_link usr/share/lilypond/$(VERSION)/tex \
                        usr/share/texmf/tex/lilypond \
                usr/share/lilypond/$(VERSION)/fonts/source \
@@ -141,6 +140,8 @@ binary-indep: build-doc install
                etc/texmf/dvips/lilypond.map \
                        usr/share/lilypond/$(VERSION)/dvips/lilypond.map
 
+       dh_pysupport /usr/share/lilypond/${VERSION}/python
+
        dh_compress -X$(d)/html/
        dh_fixperms
        dh_installdeb
@@ -155,34 +156,17 @@ binary-arch: build install
        dh_installdocs AUTHORS.txt NEWS.txt README.txt \
                DEDICATION THANKS 
 
-#      dh_installdocs DEDICATION NEWS ROADMAP *.txt \
-#              Documentation/pictures/out/*.png
-#              Documentation/out/*.txt
-#              $(DVI_FILES) $(PS_FILES)
-#      mkdir $(r)/$(d)/bibliography $(r)/$(d)/misc
-#      cp -a Documentation/bibliography/*.bib $(r)/$(d)/bibliography/
-#      cp -a Documentation/misc/[ACN]* $(r)/$(d)/misc/
-
-#      dh_installexamples input
-
-#      for i in `find $(r)/$(d)/examples/ -type d -name out`; do \
-#              mv -fv $$i/* $$i/..; rmdir $$i; done
 
-#      dh_installmenu
        dh_installemacsen
-       dh_scrollkeeper
-#      dh_installcron
-#      dh_installman
-#      dh_undocumented
-       dh_installchangelogs ChangeLog
+       dh_installchangelogs Documentation/misc/CHANGES* Documentation/misc/ChangeLog*
 
        dh_strip
+       dh_pysupport /usr/share/lilypond/${VERSION}/python
        dh_compress
        dh_fixperms
        dh_installdeb
        dh_shlibdeps
        dh_gencontrol
-#      dh_makeshlibs
        dh_md5sums
        dh_builddeb