]> git.donarmstrong.com Git - lilypond.git/blobdiff - debian/rules
Enable usage of guile2 during configure
[lilypond.git] / debian / rules
index bf8c1b240e3fefe0ee3571d0937bebfd3942304f..87828fafdde40af6853e82376283835270d092d1 100755 (executable)
@@ -5,11 +5,9 @@
 # version 2 or later for copying conditions.  There is NO warranty.
 #
 
-export MAILADDRESS = lilypond@packages.debian.org
+include VERSION
 
-# fontconfig blows chunks if it can't write to $HOME; and some
-# buildds set it to a bogus value.
-export HOME = /tmp
+export MAILADDRESS = lilypond@packages.debian.org
 
 DEB_HOST_ARCH ?= $(shell dpkg-architecture -qDEB_HOST_ARCH)
 CFLAGS := $(shell dpkg-buildflags --get CFLAGS)
@@ -34,12 +32,12 @@ endif
 %:
        dh $@ --parallel --with autotools-dev --with python2 --with quilt
 
-
 ## we need to nuke the parser files, because if there is a mistmatch
 ## between upstreams bison and our bison, the build will fail epically
 override_dh_auto_configure:
        rm -f lily/out/parser.*
-       dh_auto_configure -- --disable-checking --enable-debugging $(config_opt)
+       ./autogen.sh --noconfigure
+       dh_auto_configure -- --disable-checking --enable-debugging --enable-guile2 $(config_opt)
 
 override_dh_auto_build-indep:
        dh_auto_build
@@ -50,6 +48,9 @@ override_dh_auto_install-indep:
        $(MAKE) install-info $(DOC_OPTIONS) prefix=$(CURDIR)/debian/tmp/usr
        rm -rf $(CURDIR)/debian/tmp/usr/share/omf
        rm -rf $(CURDIR)/debian/tmp/usr/share/doc/lilypond/html/input
+       perl debian/move_info_images_from_html_doc $(CURDIR)/debian/tmp/usr/share/info/ $(CURDIR)/debian/tmp/usr/share/doc/lilypond/html/Documentation/
+       perl debian/symlink_html_images_to_info_images $(CURDIR)/debian/tmp/usr/share/info/lilypond
+       perl debian/remove_w3c_callback $(CURDIR)/debian/tmp/usr/share/doc/lilypond/ $(CURDIR)/debian/tmp/usr/share/info/
 
 ## Unfortunately, lilypond is kind of broken, and installs the wrong
 ## info documentation (missing images) if we call their makefile
@@ -90,8 +91,8 @@ override_dh_install:
        dh_install --list-missing
 
 override_dh_python2:
-       dh_python2
-       dh_python2 usr/share/lilypond/*/python/
+       dh_python2 --verbose
+       dh_python2 --verbose usr/share/lilypond/$(MAJOR_VERSION).$(MINOR_VERSION).$(PATCH_LEVEL)/python/
 
 override_dh_compress:
        dh_compress -X.ly
@@ -104,6 +105,12 @@ override_dh_installdocs:
                install -m0644 $$a debian/$$package/usr/share/doc-base/$$package; \
        done;
 
+override_dh_auto_test:
+ifneq (,$(filter $(DEB_BUILD_OPTIONS),nocheck))
+       $(MAKE) test-baseline
+    $(MAKE) test
+endif
+
 ## this rule will update debian/control and the per-language install
 ## files; all of the files it generates/modifies should be included in
 ## the Debian package and should not need to be regenerated or