]> git.donarmstrong.com Git - lilypond.git/blobdiff - debian/rules
Enable usage of guile2 during configure
[lilypond.git] / debian / rules
index 7e59b1e63a1441dd9c9716a6e9580bd88dafb510..87828fafdde40af6853e82376283835270d092d1 100755 (executable)
@@ -9,10 +9,6 @@ include VERSION
 
 export MAILADDRESS = lilypond@packages.debian.org
 
-# fontconfig blows chunks if it can't write to $HOME; and some
-# buildds set it to a bogus value.
-export HOME = /tmp
-
 DEB_HOST_ARCH ?= $(shell dpkg-architecture -qDEB_HOST_ARCH)
 CFLAGS := $(shell dpkg-buildflags --get CFLAGS)
 CXXFLAGS := $(shell dpkg-buildflags --get CXXFLAGS)
@@ -40,7 +36,8 @@ endif
 ## between upstreams bison and our bison, the build will fail epically
 override_dh_auto_configure:
        rm -f lily/out/parser.*
-       dh_auto_configure -- --disable-checking --enable-debugging $(config_opt)
+       ./autogen.sh --noconfigure
+       dh_auto_configure -- --disable-checking --enable-debugging --enable-guile2 $(config_opt)
 
 override_dh_auto_build-indep:
        dh_auto_build