]> git.donarmstrong.com Git - lilypond.git/blobdiff - debian/rules
Add "--no-parallel" to dh_auto_clean in debian/rules
[lilypond.git] / debian / rules
index 28a6437f9f603ba2bb05186e65cf88b88ae4d3a7..55d5d16ef4728eff6a9da7a953aab05b78edde55 100755 (executable)
@@ -32,7 +32,7 @@ endif
 %:
        dh $@ --parallel --with autotools-dev --with python2 --with quilt
 
-## we need to nuke the parser files, because if there is a mistmatch
+## we need to nuke the parser files, because if there is a mismatch
 ## between upstreams bison and our bison, the build will fail epically
 override_dh_auto_configure:
        rm -f lily/out/parser.*
@@ -59,13 +59,13 @@ override_dh_auto_install-indep:
 override_dh_auto_install-arch:
        for dir in `echo */*makefile|xargs -n 1 dirname|grep -v Documentation`; do \
                $(MAKE) --no-builtin-rules PACKAGE=LILYPOND package=lilypond -C $$dir install $(DOC_OPTIONS) prefix=$(CURDIR)/debian/tmp/usr/; \
-       done;
+       done
 
-## we need to nuke the parser files, because if there is a mistmatch
+## we need to nuke the parser files, because if there is a mismatch
 ## between upstreams bison and our bison, the build will fail epically
 override_dh_auto_clean:
        rm -f lily/out/parser.*
-       dh_auto_clean
+       dh_auto_clean --no-parallel
 
 ## we need to install only the png, jpg, css, ly and english html
 ## files into the doc-html package, and only the english pdfs into the
@@ -102,12 +102,12 @@ override_dh_installdocs:
                package=`basename $$a .doc-base-special`; \
                install -d debian/$$package/usr/share/doc-base; \
                install -m0644 $$a debian/$$package/usr/share/doc-base/$$package; \
-       done;
+       done
 
 override_dh_auto_test:
 ifneq (,$(filter $(DEB_BUILD_OPTIONS),nocheck))
        $(MAKE) test-baseline
-    $(MAKE) test
+       $(MAKE) test
 endif
 
 ## this rule will update debian/control and the per-language install