]> git.donarmstrong.com Git - lilypond.git/blobdiff - debian/rules
Add "--no-parallel" to dh_auto_clean in debian/rules
[lilypond.git] / debian / rules
index 19fca156890848d773e2beae8ad62f40f5b456bd..55d5d16ef4728eff6a9da7a953aab05b78edde55 100755 (executable)
@@ -9,10 +9,6 @@ include VERSION
 
 export MAILADDRESS = lilypond@packages.debian.org
 
-# fontconfig blows chunks if it can't write to $HOME; and some
-# buildds set it to a bogus value.
-export HOME = /tmp
-
 DEB_HOST_ARCH ?= $(shell dpkg-architecture -qDEB_HOST_ARCH)
 CFLAGS := $(shell dpkg-buildflags --get CFLAGS)
 CXXFLAGS := $(shell dpkg-buildflags --get CXXFLAGS)
@@ -36,8 +32,7 @@ endif
 %:
        dh $@ --parallel --with autotools-dev --with python2 --with quilt
 
-
-## we need to nuke the parser files, because if there is a mistmatch
+## we need to nuke the parser files, because if there is a mismatch
 ## between upstreams bison and our bison, the build will fail epically
 override_dh_auto_configure:
        rm -f lily/out/parser.*
@@ -52,6 +47,9 @@ override_dh_auto_install-indep:
        $(MAKE) install-info $(DOC_OPTIONS) prefix=$(CURDIR)/debian/tmp/usr
        rm -rf $(CURDIR)/debian/tmp/usr/share/omf
        rm -rf $(CURDIR)/debian/tmp/usr/share/doc/lilypond/html/input
+       perl debian/move_info_images_from_html_doc $(CURDIR)/debian/tmp/usr/share/info/ $(CURDIR)/debian/tmp/usr/share/doc/lilypond/html/Documentation/
+       perl debian/symlink_html_images_to_info_images $(CURDIR)/debian/tmp/usr/share/info/lilypond
+       perl debian/remove_w3c_callback $(CURDIR)/debian/tmp/usr/share/doc/lilypond/ $(CURDIR)/debian/tmp/usr/share/info/
 
 ## Unfortunately, lilypond is kind of broken, and installs the wrong
 ## info documentation (missing images) if we call their makefile
@@ -61,13 +59,13 @@ override_dh_auto_install-indep:
 override_dh_auto_install-arch:
        for dir in `echo */*makefile|xargs -n 1 dirname|grep -v Documentation`; do \
                $(MAKE) --no-builtin-rules PACKAGE=LILYPOND package=lilypond -C $$dir install $(DOC_OPTIONS) prefix=$(CURDIR)/debian/tmp/usr/; \
-       done;
+       done
 
-## we need to nuke the parser files, because if there is a mistmatch
+## we need to nuke the parser files, because if there is a mismatch
 ## between upstreams bison and our bison, the build will fail epically
 override_dh_auto_clean:
        rm -f lily/out/parser.*
-       dh_auto_clean
+       dh_auto_clean --no-parallel
 
 ## we need to install only the png, jpg, css, ly and english html
 ## files into the doc-html package, and only the english pdfs into the
@@ -104,7 +102,13 @@ override_dh_installdocs:
                package=`basename $$a .doc-base-special`; \
                install -d debian/$$package/usr/share/doc-base; \
                install -m0644 $$a debian/$$package/usr/share/doc-base/$$package; \
-       done;
+       done
+
+override_dh_auto_test:
+ifneq (,$(filter $(DEB_BUILD_OPTIONS),nocheck))
+       $(MAKE) test-baseline
+       $(MAKE) test
+endif
 
 ## this rule will update debian/control and the per-language install
 ## files; all of the files it generates/modifies should be included in