]> git.donarmstrong.com Git - lilypond.git/blobdiff - debian/rules
install info; remove useless offline-root directory
[lilypond.git] / debian / rules
index e1c28bc912d1a677711e98704504a72e2086ad9e..339a7070d12a04a8aae7f3df63325a09c4e4e919 100755 (executable)
@@ -82,10 +82,7 @@ clean:
        [ ! -f Makefile ] || $(MAKE) web-clean
        [ ! -f Makefile ] || $(MAKE) distclean
        rm -f lib/python
-       rm -f ./stepmake/bin/config.guess ./stepmake/bin/config.guess.sub ./stepmake/bin/config.sub
 
-       # Still not clean enough?  Let's use... BRUTE STRENGTH!  :-)
-       find . -type d -name 'out' -o -name 'out-www' | xargs rm -rf
        rm -f buildscripts/*.pyc
        rm -f lib/lilypond/python examples.html
        rm -f debian/emacsen-startup
@@ -118,7 +115,12 @@ binary-indep: build-doc install
        # it installs a random dir-dep file for no reason
        rm -f $(CURDIR)/debian/lilypond-doc/usr/share/info/*-dir-dep*
 
+       dh_installinfo
        dh_installdocs
+       # remove the useless offline-root directory
+       mv $(CURDIR)/debian/lilypond-doc/usr/share/doc/lilypond/html/offline-root/* \
+               $(CURDIR)/debian/lilypond-doc/usr/share/doc/lilypond/html/.;
+       rmdir $(CURDIR)/debian/lilypond-doc/usr/share/doc/lilypond/html/offline-root;
        find $(CURDIR)/debian/lilypond-doc/usr/share/doc/lilypond/html \
                -type d -empty -delete
        dh_installemacsen