]> git.donarmstrong.com Git - lilypond.git/blobdiff - debian/rules
install info; remove useless offline-root directory
[lilypond.git] / debian / rules
index 1381798aa3910a5264f974b65831cb016d8ec48e..339a7070d12a04a8aae7f3df63325a09c4e4e919 100755 (executable)
@@ -58,15 +58,8 @@ build-stamp:
                --prefix=/usr --enable-optimising \
                --infodir='$${prefix}/share/info' \
                --mandir='$${prefix}/share/man'
-       $(MAKE)
-       # ignore test failures on architectures which aren't i386 or
-       # amd64 until we properly fix failures when /dev/tty doesn't
-       # exist (#572290)
-       if dpkg-architecture -eamd64 || dpkg-architecture -ei386; then \
-               $(MAKE) test; \
-       else \
-               $(MAKE) test || true; \
-        fi;
+       ulimit -c unlimited && $(MAKE)
+       ulimit -c unlimited && $(MAKE) test;
 
        touch build-stamp
 
@@ -76,9 +69,9 @@ build-doc-stamp:
 
        # make html
        # unfortunatly, this does not work well with multiple processors
-       $(MAKE) -j1 doc WEB_TARGETS="offline"
+       ulimit -c unlimited && $(MAKE) -j1 doc WEB_TARGETS="offline"
        # make info
-       $(MAKE) info
+       ulimit -c unlimited && $(MAKE) info
 
        touch build-doc-stamp
 
@@ -89,10 +82,7 @@ clean:
        [ ! -f Makefile ] || $(MAKE) web-clean
        [ ! -f Makefile ] || $(MAKE) distclean
        rm -f lib/python
-       rm -f ./stepmake/bin/config.guess ./stepmake/bin/config.guess.sub
 
-       # Still not clean enough?  Let's use... BRUTE STRENGTH!  :-)
-       find . -type d -name 'out' -o -name 'out-www' | xargs rm -rf
        rm -f buildscripts/*.pyc
        rm -f lib/lilypond/python examples.html
        rm -f debian/emacsen-startup
@@ -125,32 +115,26 @@ binary-indep: build-doc install
        # it installs a random dir-dep file for no reason
        rm -f $(CURDIR)/debian/lilypond-doc/usr/share/info/*-dir-dep*
 
+       dh_installinfo
        dh_installdocs
+       # remove the useless offline-root directory
+       mv $(CURDIR)/debian/lilypond-doc/usr/share/doc/lilypond/html/offline-root/* \
+               $(CURDIR)/debian/lilypond-doc/usr/share/doc/lilypond/html/.;
+       rmdir $(CURDIR)/debian/lilypond-doc/usr/share/doc/lilypond/html/offline-root;
        find $(CURDIR)/debian/lilypond-doc/usr/share/doc/lilypond/html \
                -type d -empty -delete
        dh_installemacsen
 
-       #find input \( -name '*.*ly' -o -name '*.abc' -o -name '*.tex' -o -name 'TODO' \) ! -regex '.*/out-www/.*' \
-       #       -exec cp -a --parents '{}' $(r_data)/$(d)/examples ';'
        install -m 644 debian/xiao-haizi-guai-guai.ly debian/sakura-sakura.ly \
                $(r_data)/$(d)/examples
        dh_installchangelogs
 
-#      mv $(r_data)/usr/share/lilypond/$(VERSION)/fonts/map/lilypond.map \
-#         $(r_data)/etc/texmf/dvips/lilypond.map
-
        dh_link usr/share/lilypond/$(VERSION)/tex \
                        usr/share/texmf/tex/lilypond \
                usr/share/lilypond/$(VERSION)/fonts/source \
                        usr/share/texmf/fonts/source/public/lilypond \
-               usr/share/lilypond/$(VERSION)/fonts/afm \
-                       usr/share/texmf/fonts/afm/public/lilypond \
-               usr/share/lilypond/$(VERSION)/fonts/tfm \
-                       usr/share/texmf/fonts/tfm/public/lilypond \
                usr/share/lilypond/$(VERSION)/fonts/type1 \
                        usr/share/texmf/fonts/type1/public/lilypond \
-               etc/texmf/dvips/lilypond.map \
-                       usr/share/lilypond/$(VERSION)/dvips/lilypond.map
 
        dh_pysupport /usr/share/lilypond/${VERSION}/python
 
@@ -173,6 +157,7 @@ binary-arch: build install
        dh_installchangelogs Documentation/misc/CHANGES* Documentation/misc/ChangeLog*
 
        dh_strip
+       dh_pysupport /usr/share/lilypond/${VERSION}/python
        dh_compress
        dh_fixperms
        dh_installdeb