]> git.donarmstrong.com Git - lilypond.git/blobdiff - debian/rules
disable autoreconf for the time being
[lilypond.git] / debian / rules
index 65219ebcc6dd852407073ff1fcf53d02eeb455e8..28a6437f9f603ba2bb05186e65cf88b88ae4d3a7 100755 (executable)
@@ -9,10 +9,6 @@ include VERSION
 
 export MAILADDRESS = lilypond@packages.debian.org
 
-# fontconfig blows chunks if it can't write to $HOME; and some
-# buildds set it to a bogus value.
-export HOME = /tmp
-
 DEB_HOST_ARCH ?= $(shell dpkg-architecture -qDEB_HOST_ARCH)
 CFLAGS := $(shell dpkg-buildflags --get CFLAGS)
 CXXFLAGS := $(shell dpkg-buildflags --get CXXFLAGS)
@@ -29,17 +25,12 @@ endif
 endif
 
 DOC_OPTIONS := WEB_TARGETS="offline"
-ifneq (,$(filter $(shell dpkg-architecture -qDEB_HOST_ARCH), amd64)) 
 ifneq (,$(filter parallel=%,$(DEB_BUILD_OPTIONS)))
        DOC_OPTIONS := $(DOC_OPTIONS) CPU_COUNT=$(firstword $(patsubst parallel=%,%,$(filter parallel=%,$(DEB_BUILD_OPTIONS))))
-PARALLEL_OPTION := "--parallel"
-endif
-else
-PARALLEL_OPTION :=
 endif
 
 %:
-       dh $@ $(PARALLEL_OPTION) --with autotools-dev --with python2 --with quilt
+       dh $@ --parallel --with autotools-dev --with python2 --with quilt
 
 ## we need to nuke the parser files, because if there is a mistmatch
 ## between upstreams bison and our bison, the build will fail epically
@@ -113,6 +104,12 @@ override_dh_installdocs:
                install -m0644 $$a debian/$$package/usr/share/doc-base/$$package; \
        done;
 
+override_dh_auto_test:
+ifneq (,$(filter $(DEB_BUILD_OPTIONS),nocheck))
+       $(MAKE) test-baseline
+    $(MAKE) test
+endif
+
 ## this rule will update debian/control and the per-language install
 ## files; all of the files it generates/modifies should be included in
 ## the Debian package and should not need to be regenerated or