]> git.donarmstrong.com Git - lilypond.git/blobdiff - debian/rules
Ditch useless links (Closes: #522120)
[lilypond.git] / debian / rules
old mode 100644 (file)
new mode 100755 (executable)
index b71ba55..1384909
@@ -1,6 +1,5 @@
 #!/usr/bin/make -f
-# Made with the aid of debhelper by by Joey Hess,
-# based on the sample debian/rules file for GNU hello by Ian Jackson.
+# debian/rules for LilyPond in Debian.
 #
 # This is free software; see the GNU General Public Licence
 # version 2 or later for copying conditions.  There is NO warranty.
 
 package = lilypond
 
-SHELL = /bin/bash
+SHELL = /bin/sh
+r = debian/$(package)
+r_data = debian/$(package)-data
+r_doc = debian/$(package)-doc
+d = usr/share/doc/$(package)
+
+# since I'm building this a few times on my 8-way machine, try to
+# build it faster
+ifneq (,$(filter parallel=%,$(DEB_BUILD_OPTIONS)))
+    NUMJOBS = $(patsubst parallel=%,%,$(filter parallel=%,$(DEB_BUILD_OPTIONS)))
+    MAKEFLAGS += -j$(NUMJOBS) CPU_COUNT=$(NUMJOBS)
+endif
+
+
+include VERSION
+VERSION = $(MAJOR_VERSION).$(MINOR_VERSION).$(PATCH_LEVEL)
+
+# "main_memory = 263000" in /etc/texmf/texmf.cnf isn't large enough
+# for latex to process standchen.dvi.latex, so adding extra_mem_* ...
+# export extra_mem_top = 100000
+# export extra_mem_bot = 100000
+# But now, building lilypond.dvi requires increased pool_size (2002-02-18)
+# export pool_size = 500000
+# But now, it seems that none of the above is needed in 1.4.11  (2002-02-24)
+export MODE = ljfour
+export BDPI = 600
+export USER_CFLAGS = -DDEBIAN
+export DEB_BUILD = yes
+export MAILADDRESS = lilypond@packages.debian.org
+
+# fontconfig blows chunks if it can't write $HOME; and some buildd's
+# set it to a bogus value.
+export HOME = /tmp
 
 # Uncomment this to turn on verbose mode.
 #export DH_VERBOSE=1
 
+# This has to be exported to make some magic below work.
+export DH_OPTIONS
+
 build: build-stamp
 build-stamp:
        dh_testdir
-       ./configure --disable-checking --disable-debugging \
-               --enable-printing --prefix=/usr --enable-optimise \
-               --enable-shared
-       $(MAKE) all
-       $(MAKE) -C Documentation gifs
+
+       cp -f /usr/share/misc/config.guess /usr/share/misc/config.sub ./stepmake/bin/
+       ./configure --disable-checking --enable-debugging \
+               --prefix=/usr --enable-optimising \
+               --infodir='$${prefix}/share/info' \
+               --mandir='$${prefix}/share/man'
+       $(MAKE)
+       $(MAKE) test;
+
        touch build-stamp
 
+build-doc: build build-doc-stamp
+build-doc-stamp:
+       dh_testdir
+
+       # make html
+       # unfortunatly, this does not work well with multiple processors
+       $(MAKE) -j1 doc WEB_TARGETS="offline"
+       # make info
+       $(MAKE) info
+
+       touch build-doc-stamp
+
 clean:
        dh_testdir
        dh_testroot
-       rm -f build-stamp
-       -$(MAKE) distclean
+       rm -f build-stamp build-doc-stamp
+       [ ! -f Makefile ] || $(MAKE) web-clean
+       [ ! -f Makefile ] || $(MAKE) distclean
+       rm -f lib/python
+       rm -f ./stepmake/bin/config.guess ./stepmake/bin/config.guess.sub ./stepmake/bin/config.sub
+
+       # Still not clean enough?  Let's use... BRUTE STRENGTH!  :-)
+       find . -type d -name 'out' -o -name 'out-www' | xargs rm -rf
+       rm -f buildscripts/*.pyc
+       rm -f lib/lilypond/python examples.html
+       rm -f debian/emacsen-startup
+       rm -f debian/lilypond1.7*.dirs debian/lilypond.dirs
+       rm -f debian/postinst debian/prerm debian/postrm
+       rm -f debian/lilypond-data.doc-base debian/lilypond.doc-base
+       rm -f GNUmakefile config.log config.make config.status config.hh
+
        dh_clean
 
-# Build architecture-independent files here.
-binary-indep: build
-# We have nothing to do by default.
+install: DH_OPTIONS=
+install: build
+       dh_testdir
+       dh_testroot
+       dh_clean -k
+       dh_installdirs
+
+       # Add here commands to install the package into debian/tmp.
+       $(MAKE) install prefix=$(CURDIR)/debian/tmp/usr
+
+       dh_install --sourcedir=debian/tmp --list-missing
 
-binary-arch: build
+# Build architecture-independent files here.
+binary-indep: DH_OPTIONS=-i
+binary-indep: build-doc install
        dh_testdir
        dh_testroot
-       dh_installdirs usr/lib/texmf/doc usr/lib/emacs/site-lisp
-       ln -fs ../../../doc/lilypond debian/tmp/usr/lib/texmf/doc/lilypond
-       $(MAKE) prefix=`pwd`/debian/tmp/usr install
-       cp -av bin/out/ly2dvi debian/tmp/usr/bin
-       cp -av mudela-mode.el debian/tmp/usr/lib/emacs/site-lisp
-       dh_installdocs ANNOUNCE ANNOUNCE-0.1 README NEWS ONEWS DEDICATION \
-               BUGS TODO \
-               Documentation/*.doc Documentation/out/{*.txt,*.gif}
-       dh_installexamples input/{*.ly,TODO}
-       cp -aPv `find mutopia \( -name '*.ly' -o -name '*.tex' -o -name 'TODO' \)` \
-               debian/tmp/usr/doc/lilypond/examples
-#      dh_installmenu
-#      dh_installcron
-#      dh_installmanpages
-#      dh_undocumented
+       # Install LilyPond web documentation...
+       $(MAKE) install-doc prefix=$(CURDIR)/debian/lilypond-doc/usr/
+       # it installs a random dir-dep file for no reason
+       rm -f $(CURDIR)/debian/lilypond-doc/usr/share/info/*-dir-dep*
+
+       dh_installdocs
+       find $(CURDIR)/debian/lilypond-doc/usr/share/doc/lilypond/html \
+               -type d -empty -delete
+       dh_installemacsen
+
+       install -m 644 debian/xiao-haizi-guai-guai.ly debian/sakura-sakura.ly \
+               $(r_data)/$(d)/examples
        dh_installchangelogs
+
+       dh_link usr/share/lilypond/$(VERSION)/tex \
+                       usr/share/texmf/tex/lilypond \
+               usr/share/lilypond/$(VERSION)/fonts/source \
+                       usr/share/texmf/fonts/source/public/lilypond \
+               usr/share/lilypond/$(VERSION)/fonts/type1 \
+                       usr/share/texmf/fonts/type1/public/lilypond \
+
+       dh_pysupport /usr/share/lilypond/${VERSION}/python
+
+       dh_compress -X$(d)/html/
+       dh_fixperms
+       dh_installdeb
+       dh_gencontrol
+       dh_md5sums
+       dh_builddeb
+
+binary-arch: DH_OPTIONS=-s
+binary-arch: build install
+       dh_testdir
+       dh_testroot
+       dh_installdocs AUTHORS.txt NEWS.txt README.txt \
+               DEDICATION THANKS 
+
+
+       dh_installemacsen
+       dh_installchangelogs Documentation/misc/CHANGES* Documentation/misc/ChangeLog*
+
        dh_strip
+       dh_pysupport /usr/share/lilypond/${VERSION}/python
        dh_compress
        dh_fixperms
-       dh_suidregister
        dh_installdeb
        dh_shlibdeps
        dh_gencontrol
-#      dh_makeshlibs
-       dh_du
        dh_md5sums
        dh_builddeb
 
-source diff:
-       @echo >&2 'source and diff are obsolete - use dpkg-source -b'; false
-
 binary: binary-indep binary-arch
-.PHONY: build clean binary-indep binary-arch binary
+.PHONY: build clean install binary-indep binary-arch binary