]> git.donarmstrong.com Git - lilypond.git/blobdiff - debian/rules
Remove unneeded --parallel options from debhelper calls
[lilypond.git] / debian / rules
index 75e06aa4766ee46911da9101a226f6d99dda49e7..0139b9d0183f6f901a1198e230ca50fc06b42c7f 100755 (executable)
@@ -87,8 +87,11 @@ export LILYPOND_VERSION := $(MAJOR_VERSION).$(MINOR_VERSION).$(PATCH_LEVEL)
                -e 's!@DEB_HOST_MULTIARCH@!$(DEB_HOST_MULTIARCH)!g' \
                -e 's!@LILYPOND_VERSION@!$(LILYPOND_VERSION)!g'
 
+# Do not use debhelper's autoreconf, the build currently
+# fails with this option and we take care of that
+# ourselves anyway.
 %:
-       dh $@ --parallel --with autotools-dev --with python2 --with quilt
+       dh $@ --without autoreconf --with python2 --with quilt
 
 ## we need to nuke the parser files, because if there is a mismatch
 ## between upstreams bison and our bison, the build will fail epically
@@ -99,11 +102,12 @@ override_dh_auto_configure:
        cd guile18 && $(MAKE) ${guile_make_args}
        $(MAKE) -C guile18 install DESTDIR=$(CURDIR)/out/guile
        rm -f lily/out/parser.*
+       ./autogen.sh --noconfigure
        GUILE_LOAD_PATH="$(GUILE_LOAD_PATH)" \
                dh_auto_configure -- --disable-checking --enable-debugging $(config_opt)
 
 override_dh_auto_build-indep:
-       dh_auto_build -i -O--parallel
+       dh_auto_build -i
        $(MAKE) doc $(DOC_OPTIONS)
 
 ## Unfortunately, lilypond is kind of broken, and installs the wrong
@@ -138,7 +142,7 @@ override_dh_auto_clean:
        dh_auto_clean --no-parallel
 
 override_dh_install-arch:
-       dh_install -a -O--parallel --list-missing
+       dh_install -a --list-missing
 
 ## we need to install only the png, jpg, css, ly and english html
 ## files into the doc-html package, and only the english pdfs into the
@@ -160,7 +164,7 @@ override_dh_install-indep:
        find $(CURDIR)/debian/tmp/ -type f \
                -regex '.*usr/share/doc/lilypond/.*/[^\.]+.preview.pdf' \
                -printf '%P\n' >> $(CURDIR)/debian/lilypond-doc-pdf.install
-       dh_install -i -O--parallel --list-missing
+       dh_install -i --list-missing
 
 override_dh_python2:
        dh_python2 --verbose
@@ -179,7 +183,7 @@ override_dh_installdocs:
 
 override_dh_shlibdeps-arch:
        $(eval unexport LD_LIBRARY_PATH)
-       dh_shlibdeps -a -O--parallel -lusr/lib/$(DEB_HOST_MULTIARCH)/lilypond/$(LILYPOND_VERSION)/guile
+       dh_shlibdeps -a -lusr/lib/$(DEB_HOST_MULTIARCH)/lilypond/$(LILYPOND_VERSION)/guile
 
 # Skip tests for architecture-dependent-only build because
 # the test would fail without built documentation.