]> git.donarmstrong.com Git - neurodebian.git/commitdiff
VM: depends on zenity, install ipython01x only for older ones, default XFCE4 pannel
authorYaroslav Halchenko <debian@onerussian.com>
Mon, 10 Dec 2012 16:26:34 +0000 (11:26 -0500)
committerYaroslav Halchenko <debian@onerussian.com>
Mon, 10 Dec 2012 16:26:34 +0000 (11:26 -0500)
debian/control
tools/nd-vmsetupwizard
vm/d-i/wheezy/initial_setup
vm/d-i/wheezy/preseed.cfg.in

index be49dddc68f78626ee980e4ee7118c0c42075afa..0517d5d46ec757914805e3bf7a55f440e76036f2 100644 (file)
@@ -69,6 +69,7 @@ Depends: ${misc:Depends},
          sudo,
          neurodebian-desktop,
          gdm | lightdm,
+                zenity,
 Recommends: chromium-browser,
             update-manager-gnome, update-notifier,
 Description: NeuroDebian guest additions (DO NOT INSTALL OUTSIDE VIRTUALBOX)
index 337b4bb68ba19b663347494cf8b2e0c4c2181abe..a89976339ae81b2305484d3eb5744d71c07903ce 100755 (executable)
@@ -106,6 +106,10 @@ fi
 #       ln -f is used for further robustness
 [ ! -L $HOME/host ] && ln -sf /media/sf_host $HOME/host
 
+# Figure out which version of IPython is available
+ipython_version=$(apt-cache policy ipython 2>/dev/null | sed -ne '/Version table:/ { n;s,^[ \*]*\(.*\) .*,\1,gp}')
+dpkg --compare-versions $ipython_version lt 0.13.1 && ipython=ipython01x || ipython=ipython
+
 # TODO: add PyMVPA:
 #   FALSE "PyMVPA" "python-mvpa2,python-mvpa2-doc,python-mvpa2-tutorial-data" \
 # needs -doc and -tutorial-data package
@@ -120,10 +124,10 @@ FALSE "Emacs" "emacs" \
 FALSE "Graphics (e.g. GIMP, Inscape)" "gimp,inkscape,svgtune,xzgv,vym" \
 FALSE "Octave" "octave,qtoctave" \
 FALSE "OpenOffice.org" "openoffice.org" \
-FALSE "PyMVPA Tutorial" "ipython01x,python-mvpa2,python-mvpa2-doc,python-mvpa2-tutorialdata,spyder" \
+FALSE "PyMVPA Tutorial" "$ipython,python-mvpa2,python-mvpa2-doc,python-mvpa2-tutorialdata,spyder" \
 FALSE "Python: Electrophysiology & Modeling" "python-brian,python-pynn,python-pyentropy,stimfit" \
-FALSE "Python: Neuroimaging" "ipython01x,spyder,nipy-suite,python-mvpa2" \
-FALSE "Python: Scientific stack" "ipython01x,spyder,python-matplotlib,python-pandas,python-sympy" \
+FALSE "Python: Neuroimaging" "$ipython,spyder,nipy-suite,python-mvpa2" \
+FALSE "Python: Scientific stack" "$ipython,spyder,python-matplotlib,python-pandas,python-sympy" \
 FALSE "R" "r-recommended" \
 FALSE "TeX Live" "texlive" \
 FALSE "Adobe Flash browser plugin" "flashplugin-nonfree" \
index b57e35936d72b9d22a241d817bf9ec6f9f5814e9..76831e74e6a9bdc9e79b89049ccc29db49eb1f6a 100755 (executable)
@@ -80,7 +80,7 @@ touch /dev/vboxguest
 cunamer=`uname -r`
 cdarch=${cunamer##*-}
 # We carry 686 only
-[ $cdarch = '486' ] && darch='686' || darch=$cdarch
+[ $cdarch = '486' ] && darch='686-pae' || darch=$cdarch
 apt-get install -y linux-headers-$cdarch
 
 ## # Forcefully install guest additions from backports so we are
@@ -125,13 +125,13 @@ apt-get install --no-install-recommends -y \
  mc evince bash-completion ntpdate file-roller \
  eog vim reportbug \
  software-center synaptic menu less libxp6 \
- task-xfce-desktop lightdm \
+ task-xfce-desktop lightdm zenity \
  chromium-browser \
  sudo neurodebian-desktop update-notifier
 
 # "Slightly" better terminal by default
 # TODO: might want to change default bg color to black there
-apt-get install rxvt-unicode
+apt-get install -y rxvt-unicode
 update-alternatives --set x-terminal-emulator /usr/bin/urxvt
 
 # XXX last ones are actually pulled it by neurodebian-guest-additions whenever we
@@ -165,12 +165,20 @@ apt-get autoremove --purge -y
 # use NeuroDebian website as default homepage
 sed -i -e 's,http://www.debian.org,http://neuro.debian.net,g' /etc/chromium*/master_preferences
 
+# Place default XFCE4 panel config, otherwise a dialog appears
+# Thanks go to cavalier@freenode IRC for the hint
+xfdir=/home/brain/.config/xfce4/xfconf/xfce-perchannel-xml
+mkdir -p $xfdir
+cp /etc/xdg/xfce4/panel/default.xml $xfdir/xfce4-panel.xml
+chown brain.brain -R /home/brain/.config
+
 # reduce grub timeout to speed up boot of VM
 sed -i -e 's/GRUB_TIMEOUT=5/GRUB_TIMEOUT=1/g' /etc/default/grub
 update-grub
 
 # finally configure geomirror for APT and disable deb-src lists
-sed -i -e "s,\(deb\(\|-src\) http://\)[^/]*/,\1$(dpkg --print-architecture)-geomirror.debian.net/,g" \
+cp /etc/apt/sources.list /etc/apt/sources.list.orig
+sed -i -e "s,\(deb\(\|-src\) http://\)[^/]*/debian,\1$(dpkg --print-architecture)-geomirror.debian.net/debian,g" \
     -e "s/^deb-src/#deb-src/" /etc/apt/sources.list
 
 etckeeper commit "Initial VM setup done"
index 5024aa7d0d1ff29113cd6cffcc42799bc2769b4f..ac426772e0245071d16761f611b90dad98b6a750 100644 (file)
@@ -202,7 +202,7 @@ d-i apt-setup/contrib boolean true
 #d-i apt-setup/use_mirror boolean false
 # Select which update services to use; define the mirrors to be used.
 # Values shown below are the normal defaults.
-#d-i apt-setup/services-select multiselect security, volatile
+d-i apt-setup/services-select multiselect security, volatile
 d-i apt-setup/security_host string security.debian.org
 #d-i apt-setup/volatile_host string volatile.debian.org
 # XXX?