]> git.donarmstrong.com Git - neurodebian.git/commitdiff
ENH: install lightdm, default login for brain, urxvt (+tune ups) as default console
authorYaroslav Halchenko <debian@onerussian.com>
Fri, 7 Dec 2012 23:28:57 +0000 (18:28 -0500)
committerYaroslav Halchenko <debian@onerussian.com>
Fri, 7 Dec 2012 23:29:07 +0000 (18:29 -0500)
debian/changelog
debian/control
debian/neurodebian-desktop.install
debian/neurodebian-guest-additions.postinst
vm/d-i/wheezy/initial_setup
xdg/Xresources/neurodebian [new file with mode: 0644]

index ad929db81b9acbd03e1c5873c845913eb1252430..24adb80d4198cd305d63fc20884756c52e13bb67 100644 (file)
@@ -1,3 +1,11 @@
+neurodebian (0.30~dev0) wheezy; urgency=low
+
+  * VM (6.999.b4.20121206) - development VM based on upcoming wheezy
+    release's beta4
+    - uses XFCE4 instead of Gnome(3) -- Depends on gdm | lightdm now
+
+ -- Yaroslav Halchenko <debian@onerussian.com>  Fri, 07 Dec 2012 13:07:07 -0500
+
 neurodebian (0.29) unstable; urgency=low
 
   [ Yaroslav Halchenko & Michael Hanke ]
index 08ab348d07d416d9eea328c09f3ce1c6ec2a1b63..be49dddc68f78626ee980e4ee7118c0c42075afa 100644 (file)
@@ -65,8 +65,12 @@ Description: Helper for NeuroDebian popularity contest submissions
 Package: neurodebian-guest-additions
 Architecture: all
 Pre-Depends: virtualbox-ose-guest-utils, virtualbox-ose-guest-x11, virtualbox-ose-guest-dkms
-Depends: ${misc:Depends}, sudo, neurodebian-desktop, gdm | gdm3, update-manager-gnome, update-notifier
-Recommends: chromium-browser
+Depends: ${misc:Depends},
+         sudo,
+         neurodebian-desktop,
+         gdm | lightdm,
+Recommends: chromium-browser,
+            update-manager-gnome, update-notifier,
 Description: NeuroDebian guest additions (DO NOT INSTALL OUTSIDE VIRTUALBOX)
  This package configures a Debian installation as a guest operating system
  in a VirtualBox-based virtual machine for NeuroDebian.
index eb9daa06cb39a6de796f3ec8441e0c770995cb50..511057cba737c02c2ad5fab344c8e65c758028ca 100644 (file)
@@ -4,3 +4,4 @@ xdg/neurodebian.menu etc/xdg/menus/applications-merged
 xdg/directories/* usr/share/desktop-directories
 xdg/desktop/neurodebian-* usr/share/applications
 tools/nd-autoinstall usr/bin
+xdg/Xresources/neurodebian etc/X11/Xresources
index 6a5336e4cedc9096b1298aba3bfdab0657c09015..a714ea0f091a88be159efe2bb34d5210dd31680a 100755 (executable)
@@ -9,17 +9,30 @@ _set_gdm_auto_login() {
     elif [ -z "$(grep 'AutomaticLogin=brain' $gdm_conf)" ]; then
         echo "I: Enabling autologin of user 'brain' for GNOME $gnome_ver."
         sed -i -e 's/^\[daemon\]$/\[daemon\]\nAutomaticLoginEnable=true\nAutomaticLogin=brain\n/' $gdm_conf
+        # update gconf defaults tree
+               update-gconf-defaults
     fi
 }
 
+# XFCE4
+_set_lightdm_auto_login() {
+    lightdm_conf="$1"
+    if [ ! -e $lightdm_conf ]; then
+               echo "I: No config file $lightdm_conf found"
+    elif [ ! -z "$(grep '^# *autologin-user=' $lightdm_conf)" ]; then
+        echo "I: Enabling autologin of user 'brain' for lightdm."
+        sed -i -e 's/^# *autologin-user=.*$/autologin-user=brain/' $lightdm_conf
+    fi
+
+}
+
 gdm_conf=/etc/gdm/gdm.conf
 if [ "$1" = "configure" -o "$1" = "abort-upgrade" ]; then
 
-    _set_gdm_auto_login /etc/gdm/gdm.conf 2
-    _set_gdm_auto_login /etc/gdm3/daemon.conf 3
+       [ -e /etc/gdm/gdm.conf ] && _set_gdm_auto_login /etc/gdm/gdm.conf 2
+    [ -e /etc/gdm3/daemon.conf ] && _set_gdm_auto_login /etc/gdm3/daemon.conf 3
 
-    # update gconf defaults tree
-    update-gconf-defaults
+       [ -e /etc/lightdm/lightdm.conf ] && _set_lightdm_auto_login /etc/lightdm/lightdm.conf
 fi
 
 #DEBHELPER#
index 10a82308adb90dc9210cafd6f03081ff24874b89..b57e35936d72b9d22a241d817bf9ec6f9f5814e9 100755 (executable)
@@ -90,8 +90,7 @@ apt-get install -y linux-headers-$cdarch
 ##     >| /var/log/initial_setup-dkms.log 2>&1
 
 # to get all the rest stuff in recommends
-apt-get install -y dkms
-# TODO: neurodebian-guest-additions  -- pulls in gdm3 ATM
+apt-get install -y dkms neurodebian-guest-additions
 
 if [ "$darch" != "$cdarch" ] ; then
     # Because DKMS builds for currently running kernel, which during
@@ -130,10 +129,14 @@ apt-get install --no-install-recommends -y \
  chromium-browser \
  sudo neurodebian-desktop update-notifier
 
+# "Slightly" better terminal by default
+# TODO: might want to change default bg color to black there
+apt-get install rxvt-unicode
+update-alternatives --set x-terminal-emulator /usr/bin/urxvt
+
 # XXX last ones are actually pulled it by neurodebian-guest-additions whenever we
 # resolve their destiny ;-)   a;though it might be pooling too much, eg exim4
 
-# TODO: autologin for lightdm (autologin-user=brain in /etc/lightdm/lightdm.conf), default panel (with chromium) for xfce
 # TODO: pre-configure the panel "Welcome to the first start of the panel", "Use default config"?
 
 # Clean-up installed development files which got pulled in for
diff --git a/xdg/Xresources/neurodebian b/xdg/Xresources/neurodebian
new file mode 100644 (file)
index 0000000..0c35011
--- /dev/null
@@ -0,0 +1,8 @@
+URxvt.background: black
+URxvt.foreground: white
+URxvt.coursorColor: red
+URxvt.saveLines: 1000
+URxvt.perl-ext: searchable-scrollback<M-s>,tabbed,option-popup,selection
+# workaround for #546527
+URxvt.perl-ext-common: default,-option-popup,-selection-popup
+URxvt.underlineURLs: true