]> git.donarmstrong.com Git - neurodebian.git/commitdiff
BF: Disable logic for demanding netselect (absent on ubuntus)
authorYaroslav Halchenko <debian@onerussian.com>
Wed, 6 Aug 2014 02:05:41 +0000 (22:05 -0400)
committerYaroslav Halchenko <debian@onerussian.com>
Wed, 6 Aug 2014 02:30:57 +0000 (22:30 -0400)
probably we could sophisticate it with all vendor-specific gizmos
http://raphaelhertzog.com/2010/09/27/different-dependencies-between-debian-and-ubuntu-but-common-source-package/
but it is just more reasonable to assume that netselect would eventually
come back

debian/control
debian/neurodebian-repository.config
debian/neurodebian-repository.templates

index e52b4f8ff3c31f713966a50f9f86278ab3598094..74bbc2bf649456d6bfde123edc9d56d9d2d70636 100644 (file)
@@ -28,7 +28,7 @@ Description: turnkey platform for the neuroscience
 
 Package: neurodebian-repository
 Architecture: all
-Pre-depends: python-minimal, netselect, wget
+Pre-depends: python-minimal, wget
 Depends: neurodebian-keyring, ${misc:Depends}
 Recommends: netselect
 Description: NeuroDebian APT repository installer
index a40f1533e409cfd6b4510ca49018b4aafeaf7d46..0f3776c8a6dd50bbf0465d50301468d10438498b 100755 (executable)
@@ -52,27 +52,33 @@ while [ "$STATE" != 0 -a "$STATE" != 8 ]; do
     esac
 
     if db_go; then
-               case $STATE in
-                       2)
-                               db_metaget neurodebian-repository/mirror value
-                               selected_mirror="$RET"
-                               # TODOs:
-                               # - handle custom
-                               # - separate out alias from url
-                               debug "selected mirror: $selected_mirror"
-                               if [ "$selected_mirror" = "best" ] && ! which netselect &>/dev/null; then
-                                       if [ "$mirror_selection_ret" = "30 question skipped" ]; then
-                                               # if the question was not even shown, we would
-                                               # not get a chance to specify mirror, thus
-                                               # better just fail altogether and demand intervention
-                                               db_input high neurodebian-repository/netselect-cannot-be-used
-                                               exit 1
-                                       else
-                                               db_input high neurodebian-repository/netselect-not-found
-                                               continue;
-                                       fi
-                               fi
-               esac
+# Ubuntus managed to remove netselect "to accompany apt-netselect"
+# https://bugs.launchpad.net/ubuntu/+source/netselect/+bug/337377
+# So for now remove this mandatory demanding of netselect for "best", and
+# rely on logic in nd-aptenable to select default mirror (currently origin)
+# as the 'best'
+#
+#              case $STATE in
+#                      2)
+#                              db_metaget neurodebian-repository/mirror value
+#                              selected_mirror="$RET"
+#                              # TODOs:
+#                              # - handle custom
+#                              # - separate out alias from url
+#                              debug "selected mirror: $selected_mirror"
+#                              if [ "$selected_mirror" = "best" ] && ! which netselect &>/dev/null; then
+#                                      if [ "$mirror_selection_ret" = "30 question skipped" ]; then
+#                                              # if the question was not even shown, we would
+#                                              # not get a chance to specify mirror, thus
+#                                              # better just fail altogether and demand intervention
+#                                              db_input high neurodebian-repository/netselect-cannot-be-used
+#                                              exit 1
+#                                      else
+#                                              db_input high neurodebian-repository/netselect-not-found
+#                                              continue;
+#                                      fi
+#                              fi
+#              esac
         STATE=$(($STATE + 1))
     else
         STATE=$(($STATE - 1))
index 5a206a491a09d3df7e37d0fa5afe27786df21b28..eb31072b7dbb35270be91cd473dc1eb5de4a02df 100644 (file)
@@ -27,8 +27,8 @@ Description: NeuroDebian mirror to use:
   - origin: original NeuroDebian repository
   - best: will try to use netselect to select "closest" mirror.
     Depending on the configuration of the firewall, and actual mirror
-    setup, might fail to select actually closest one.  netselect
-    must be installed to use this feature.
+    setup, might fail to select actually closest one.  If netselect
+    is not available, default mirror (possibly 'origin') will be used.
 
 
 Template: neurodebian-repository/flavor