]> git.donarmstrong.com Git - neurodebian.git/commitdiff
some notes + adding netselect into pre-depends of the neurodebian-repository
authorYaroslav Halchenko <debian@onerussian.com>
Wed, 30 Jul 2014 17:17:27 +0000 (13:17 -0400)
committerYaroslav Halchenko <debian@onerussian.com>
Fri, 1 Aug 2014 00:12:39 +0000 (20:12 -0400)
debian/TODO
debian/control

index 66496b0846bfd3b893b59f5f9e10d198781e3868..c1c3f9c80895547efae7f438211bf7a57c11f2db 100644 (file)
@@ -4,3 +4,50 @@
   would need to assure that mvpa2-tutorial is aware of ipython1x first
   then... not now
 * make all nd_* scripts usable out of the box on non-x86 boxes
+* TODO testing of neurodebian "installer" packages
+** notes from manual attempts in a docker:
+
+*** just dpkg -i way
+rm neurodebian-*deb; apt-get update -y; apt-get install -y netselect python-minimal wget; wget http://www.onerussian.com/tmp/neurodebian-{repository,keyring}_0.33~a1_all.deb; DEBIAN_FRONTEND=noninteractive dpkg -i neurodebian-{keyring,repository}_0.33~a1_all.deb
+
+*** via apt
+
+#/bin/bash
+set -ex
+
+# minimal installation with few of those packages
+apt_file=/etc/apt/sources.list.d/local.list
+
+# clean up from a previous test
+dpkg --purge neurodebian-repository neurodebian-keyring || :
+echo PURGE | debconf-communicate neurodebian-repository || :
+rm -rf /tmp/apt $apt_file;
+
+mkdir -p /tmp/apt; cd /tmp/apt;
+rm -f neurodebian-*deb; apt-get update -y; apt-get install -y wget;
+wget http://www.onerussian.com/tmp/neurodebian-repository_0.33~a1_all.deb;
+wget http://www.onerussian.com/tmp/neurodebian-keyring_0.33~a1_all.deb;
+
+# generate APT repo
+apt-get install -y dpkg-dev ;  dpkg-scanpackages  . /dev/null > Packages
+# Add it to the list of available
+echo "deb file:///tmp/apt ./" >| $apt_file; apt-get update
+# Install the beast
+apt-get install -y --allow-unauthenticated neurodebian-repository
+
+# Verify that it has correct entries
+release=$(grep -v '^[\s#]*$' /etc/apt/sources.list | head -1 | awk '{print $3;}')
+grep -E "^deb\s+http.* $release main\s*\$" /etc/apt/sources.list.d/neurodebian.sources.list
+grep -E '^deb\s+http.* data main\s*$' /etc/apt/sources.list.d/neurodebian.sources.list
+# May be even retrospect stored debconf configuration
+apt-get install debconf-utils
+debconf-get-selections | grep neurodebian-repository/release.*select.*auto
+# And apt-get must be working
+apt-get update
+# Make sure it is active
+apt-cache policy | grep o=NeuroDebian,.*,n=data
+apt-cache policy | grep o=NeuroDebian,.*,n=$release
+
+echo "I: success"
+
+*** ~/bin/docker-debians-run /bin/bash -c "apt-get -y update >/dev/null; apt-get install -y wget >/dev/null; bash <(wget -q --no-check-certificate -O- https://raw.githubusercontent.com/yarikoptic/neurodebian/enh/neurodebian-installer/tools/nd-aptenable) --overwrite --install --mirror=us-nh" 
index 74bbc2bf649456d6bfde123edc9d56d9d2d70636..e52b4f8ff3c31f713966a50f9f86278ab3598094 100644 (file)
@@ -28,7 +28,7 @@ Description: turnkey platform for the neuroscience
 
 Package: neurodebian-repository
 Architecture: all
-Pre-depends: python-minimal, wget
+Pre-depends: python-minimal, netselect, wget
 Depends: neurodebian-keyring, ${misc:Depends}
 Recommends: netselect
 Description: NeuroDebian APT repository installer