]> git.donarmstrong.com Git - neurodebian.git/commitdiff
Merge branch 'master' of git://git.debian.org/pkg-exppsy/neurodebian
authorYaroslav Halchenko <debian@onerussian.com>
Mon, 16 May 2011 16:38:05 +0000 (12:38 -0400)
committerYaroslav Halchenko <debian@onerussian.com>
Mon, 16 May 2011 16:38:05 +0000 (12:38 -0400)
* 'master' of git://git.debian.org/pkg-exppsy/neurodebian:
  Fix div by zero prob.
  Make time figure.

Conflicts:
survey/makestats -- in list of sources for get_nice_name

1  2 
survey/Makefile
survey/makestats

diff --cc survey/Makefile
index ef2d8f1793bd3992b8f8c54f8c765b969cab54b1,9ce5fc06e945781dfd3d880c88327a343e21eedb..e817fc8ed400aacc1765ccd58b90db052107c2b7
@@@ -43,15 -43,9 +43,15 @@@ datamodlist.txt: survey.rs
        grep '"bg_datamod"' survey.rst | sed -e 's/.*name="bg_datamod" value="//' \
                -e 's," />,: ",' -e 's,<br />$$,",' -e 's/ "$$/ "Other"/' > $@
  
 +# Generic rule to extract from drop-down selections
 +%-dd-list.txt: survey.rst
 +      @echo "I: Extracting fields for $* into $@"
 +      @sed -n -e '/bg_$*/,/\/tr/p' survey.rst \
 +      | sed -ne '/option/s,.*value="\([^"]*\)" *label=\("[^"]*"\)>.*,\1: \2,gp' >| $@
 +
  upload: index.html results.html results_snippet.html jquery.form.js survey.css surveycollector.cgi
        rsync -rvzlhp --delete  \
-         --exclude='*.txt' --exclude=surveydata --exclude='*.cgi' --exclude=figures \
+         --exclude='*.txt' --exclude=data --exclude='*.cgi' --exclude=figures \
                --chmod=Dg+s,g+rw * neurodebian@www.pymvpa.org:/home/neurodebian/survey/
        scp surveycollector.cgi neurodebian@www.pymvpa.org:/srv/neuro.debian.net/cgi-bin/
  
index 3829f1312a2c64e07a4f89541d5dc5e48873252f,09b0c9415b20fe6d7f39a554c2c836dc841cfa7d..7da486e97ba46760ec4e3beb84f5e43ad3f53964
@@@ -162,8 -168,7 +170,8 @@@ class DB(dict)
  
      def get_nice_name(self, id):
          srcs = [DB.os_dict, os_cat_names, DB.sw_dict, sw_categories,
-                 resource_categories, DB.datamod_dict, DB.position_dict,
-                 DB.employer_dict]
 -                resource_categories, time_categories, DB.datamod_dict]
++                resource_categories, time_categories,
++                DB.datamod_dict, DB.position_dict, DB.employer_dict]
          for src in srcs:
              if id in src:
                  return src[id]