]> git.donarmstrong.com Git - neurodebian.git/commitdiff
provide human-readable descriptions for positions and employer (venue)
authorYaroslav Halchenko <debian@onerussian.com>
Mon, 16 May 2011 16:36:05 +0000 (12:36 -0400)
committerYaroslav Halchenko <debian@onerussian.com>
Mon, 16 May 2011 16:36:05 +0000 (12:36 -0400)
survey/Makefile
survey/makestats

index 31ee5e166e16a6eb5671a19e3e9c0d1d8ccc9aa7..ef2d8f1793bd3992b8f8c54f8c765b969cab54b1 100644 (file)
@@ -18,7 +18,7 @@ results_snippet.html: results.html
                | tail -n$$(echo "$$(wc -l < results.html) - $$(grep -n '<body>' \
                < results.html | cut -d ':' -f 1,1) - 2" | bc ) > $@
 
-statfigures: oslist.txt swlist.txt datamodlist.txt
+statfigures: oslist.txt swlist.txt datamodlist.txt employer-dd-list.txt position-dd-list.txt
 # create "lockfile'
        @touch $@
        @[ "$$(cat nsubmissions.stamp 2>/dev/null || echo)" != "$$(ls -1 data |wc -l)" ] \
@@ -43,6 +43,12 @@ datamodlist.txt: survey.rst
        grep '"bg_datamod"' survey.rst | sed -e 's/.*name="bg_datamod" value="//' \
                -e 's," />,: ",' -e 's,<br />$$,",' -e 's/ "$$/ "Other"/' > $@
 
+# Generic rule to extract from drop-down selections
+%-dd-list.txt: survey.rst
+       @echo "I: Extracting fields for $* into $@"
+       @sed -n -e '/bg_$*/,/\/tr/p' survey.rst \
+       | sed -ne '/option/s,.*value="\([^"]*\)" *label=\("[^"]*"\)>.*,\1: \2,gp' >| $@
+
 upload: index.html results.html results_snippet.html jquery.form.js survey.css surveycollector.cgi
        rsync -rvzlhp --delete  \
         --exclude='*.txt' --exclude=surveydata --exclude='*.cgi' --exclude=figures \
index 540e209e203ca7a1f205448362b7ddb4074e622a..3829f1312a2c64e07a4f89541d5dc5e48873252f 100755 (executable)
@@ -93,6 +93,8 @@ class DB(dict):
     os_dict = load_list2dict('oslist.txt')
     datamod_dict = load_list2dict('datamodlist.txt')
     sw_dict = load_list2dict('swlist.txt')
+    position_dict = load_list2dict('position-dd-list.txt')
+    employer_dict = load_list2dict('employer-dd-list.txt')
 
     def __init__(self, srcdir):
         # eats the whole directory
@@ -160,7 +162,8 @@ class DB(dict):
 
     def get_nice_name(self, id):
         srcs = [DB.os_dict, os_cat_names, DB.sw_dict, sw_categories,
-                resource_categories, DB.datamod_dict]
+                resource_categories, DB.datamod_dict, DB.position_dict,
+                DB.employer_dict]
         for src in srcs:
             if id in src:
                 return src[id]