]> git.donarmstrong.com Git - neurodebian.git/commitdiff
ENH: Serve institution icons at height 50 size
authorYaroslav Halchenko <debian@onerussian.com>
Thu, 17 Oct 2013 18:23:31 +0000 (14:23 -0400)
committerYaroslav Halchenko <debian@onerussian.com>
Thu, 17 Oct 2013 18:23:31 +0000 (14:23 -0400)
otherwise loads longer and looks ugly on firefox not
doing nice interpolation

Makefile
artwork/.gitignore
artwork/Makefile
sphinx/_templates/layout.html

index 256bdfcb32cbd48bbb4105a77bdd5e57152a4cd1..e9205fd56fe468fa4b32812ef07a5a480e98450b 100644 (file)
--- a/Makefile
+++ b/Makefile
@@ -26,7 +26,7 @@ pics:
 
 html: pics source
        rsync -rvlhpt sphinx/ build/src
-       cd artwork;     cp button_w200.png logo_tuned/fmri_w200.png uni-md-logo.png ccn-logo.png ../build/src/_static; cd ..
+       cd artwork;     cp button_w200.png logo_tuned/fmri_w200.png uni-md-logo_h50.png ccn-logo_h50.png ../build/src/_static; cd ..
        cp 3rd/jquery.livetwitter/jquery.livetwitter.min.js build/src/_static
        cp neurodebian.cfg build/src/_static
        cd build/src && $(MAKE) html BUILDDIR=$(CURDIR)/build 2>&1
index 320616afd542465003f399f2fc0fa74262157a3c..1ec65ae6f8467df695bc2e666dc48265433514b2 100644 (file)
@@ -13,3 +13,5 @@ banner.pdf
 qrcode_sticker.pdf
 qrcode_sticker.png
 derivatives.png
+ccn-logo_h50.png
+uni-md-logo_h50.png
index c6b7713fafa4cba2c670bed50db241e868add58f..4872ee8226571c9b351226ecfe5b8417796a836e 100644 (file)
@@ -1,12 +1,14 @@
 all:: pics
 
 SVGIS=$(shell /bin/ls *.svgtune | sed -e 's/.svgtune/_tuned/g')
+ICONSIZED=ccn-logo_h50.png uni-md-logo_h50.png
 
-pics: $(SVGIS)
+pics: $(SVGIS) $(ICONSIZED)
 
 clean::
        for p in *.svg; do rm -f $${p%*.svg}.{pdf,eps,png}; done
        rm -rf *_tuned
+       rm -f  $(ICONSIZED)
 
 ignore-%:
        @grep -q "^$*$$" .gitignore || { \
@@ -28,6 +30,10 @@ ignore-%:
        @echo "Rendering $@"
        @inkscape -z -f "$<" -e "$@" -w 200
 
+# icon sized versions
+%_h50.png: %.png ignore-%_h50.png
+       @echo "Generating downscaled $@"
+       @convert -geometry x50 "$<" "$@"
 
 # Some enforced conversions to overcome problems with transparency issues
 # in PDFs
index 2b63bdac76ea8044ba8700d132d4a4f788d71e51..4cbb0046c032b437c7101c7847158272e5a0254b 100644 (file)
@@ -29,8 +29,8 @@
 
   <div class="buttonbar rightbar">
   <ul>
-  <li><a href="http://www.ipsy.ovgu.de/psychoinformatics.html" target="_blank"><img border="0" src="/_static/uni-md-logo.png" title="Psychoinformatics lab, University of Magdeburg, Germany" height="50" /></a></li>
-  <li><img border="0" src="/_static/ccn-logo.png" title="Center for Cognitive Neuroscience, Dartmouth College, USA" height="50" /></li>
+  <li><a href="http://www.ipsy.ovgu.de/psychoinformatics.html" target="_blank"><img border="0" src="/_static/uni-md-logo_h50.png" title="Psychoinformatics lab, University of Magdeburg, Germany" height="50" /></a></li>
+  <li><img border="0" src="/_static/ccn-logo_h50.png" title="Center for Cognitive Neuroscience, Dartmouth College, USA" height="50" /></li>
   </ul>
   </div>
 {% endblock %}