]> git.donarmstrong.com Git - debian/debian-policy.git/commitdiff
[bug545548-srivasta]: Use a less confusing merge work-flow in the README
authorManoj Srivastava <srivasta@debian.org>
Mon, 5 Oct 2009 05:22:47 +0000 (00:22 -0500)
committerManoj Srivastava <srivasta@debian.org>
Mon, 5 Oct 2009 05:24:15 +0000 (00:24 -0500)
While still minimizing unneeded merges between master and bug branches,
this version of the document uses a less confusing command sequence. Also
update the HTML page.

Signed-off-by: Manoj Srivastava <srivasta@debian.org>
README.html
README.org

index 2da20e2af48860a2b1eea99ef8a3af77b3477276..19608a2560c59701f7a20ffe4daa4a0db050839e 100644 (file)
@@ -13,7 +13,7 @@ lang="en" xml:lang="en">
 <title>Debian Policy</title>
 <meta http-equiv="Content-Type" content="text/html;charset=utf-8"/>
 <meta name="generator" content="Org-mode"/>
-<meta name="generated" content="2009-09-15 15:48:45 CDT"/>
+<meta name="generated" content="2009-10-05 00:20:29 CDT"/>
 <meta name="author" content="Manoj Srivastava And Russ Allbery"/>
 <meta name="description" content=""/>
 <meta name="keywords" content=""/>
@@ -198,14 +198,18 @@ git commit
 git checkout master
 git pull
 
-# If there are changes in master that make the branch not apply cleanly:
- : git checkout -b temp master; git merge &lt;local-branch-name&gt;
-# If error, reset temp, merge master into local; else skip these three lines
- : git reset --hard HEAD;
- : git checkout &lt;local-branch-name&gt;; 
+git checkout master
+git merge --no-commit &lt;local-branch-name&gt;
+git reset --hard HEAD;
+git checkout &lt;local-branch-name&gt;; 
+
+# If there are changes in master that make the branch not apply cleanly, there
+# should have been en error during the merge step above. If there was an
+# error, merge the master branch into the local branch, fix the conflicts, and
+# commit the new version of the local branch.
  : git merge master
-# get rid of the temp branch:
- : git branch -D temp
+# Edit files to remove conflict
+ : git commit -s 
 
 # Checkout the local branch, to create the patch to send to the policy
 git checkout &lt;local-branch-name&gt;
@@ -491,12 +495,20 @@ git push origin bug12345-rra
 # update your local master branch
 git checkout master
 git pull
-# If there are changes in master that make the branch not apply cleanly:
-: git checkout -b temp master; git merge bug12345-rra
-# If error;
-: git reset --hard HEAD;
-: git checkout bug12345-rra; git branch -D temp
-: git merge master
+
+git checkout master
+git merge --no-commit bug12345-rra
+git reset --hard HEAD;
+
+# If there are changes in master that make the branch not apply cleanly, there
+# should have been en error during the merge step above. If there was an
+# error, merge the master branch into the local branch, fix the conflicts, and
+# commit the new version of the local branch.
+ : git checkout bug12345-rra
+ : git merge master
+# Edit files to remove conflict
+ : git commit -s 
+
 git checkout master
 git merge bug12345-rra
 # edit debian/changelog and upgrading-checklist.html
@@ -671,8 +683,8 @@ reach one of the resolution states above.
 <p class="author"> Author: Manoj Srivastava And Russ Allbery
 <a href="mailto:srivasta@debian.org">&lt;srivasta@debian.org&gt;</a>
 </p>
-<p class="date"> Date: 2009-09-15 15:48:45 CDT</p>
-<p class="creator">HTML generated by org-mode 6.30trans in emacs 23</p>
+<p class="date"> Date: 2009-10-05 00:20:29 CDT</p>
+<p class="creator">HTML generated by org-mode 6.31trans in emacs 23</p>
 </div>
 </div>
 </body>
index 85963965d51b88cf16319d735b0c304fda7ef0f6..4a7458cc21935c6018ee0ae4a25fb07dac9bf17f 100644 (file)
@@ -70,14 +70,18 @@ git commit
 git checkout master
 git pull
 
-# If there are changes in master that make the branch not apply cleanly:
- : git checkout -b temp master; git merge <local-branch-name>
-# If error, reset temp, merge master into local; else skip these three lines
- : git reset --hard HEAD;
- : git checkout <local-branch-name>; 
+git checkout master
+git merge --no-commit <local-branch-name>
+git reset --hard HEAD;
+git checkout <local-branch-name>; 
+
+# If there are changes in master that make the branch not apply cleanly, there
+# should have been en error during the merge step above. If there was an
+# error, merge the master branch into the local branch, fix the conflicts, and
+# commit the new version of the local branch.
  : git merge master
-# get rid of the temp branch:
- : git branch -D temp
+# Edit files to remove conflict
+ : git commit -s 
 
 # Checkout the local branch, to create the patch to send to the policy
 git checkout <local-branch-name>
@@ -235,12 +239,20 @@ git push origin bug12345-rra
 # update your local master branch
 git checkout master
 git pull
-# If there are changes in master that make the branch not apply cleanly:
-: git checkout -b temp master; git merge bug12345-rra
-# If error;
-: git reset --hard HEAD;
-: git checkout bug12345-rra; git branch -D temp
-: git merge master
+
+git checkout master
+git merge --no-commit bug12345-rra
+git reset --hard HEAD;
+
+# If there are changes in master that make the branch not apply cleanly, there
+# should have been en error during the merge step above. If there was an
+# error, merge the master branch into the local branch, fix the conflicts, and
+# commit the new version of the local branch.
+ : git checkout bug12345-rra
+ : git merge master
+# Edit files to remove conflict
+ : git commit -s 
+
 git checkout master
 git merge bug12345-rra
 # edit debian/changelog and upgrading-checklist.html