]> git.donarmstrong.com Git - debian/debian-policy.git/commitdiff
[bug545548-srivasta]: Arrange to regenerate derived files from org source
authorManoj Srivastava <srivasta@debian.org>
Sun, 13 Sep 2009 21:29:09 +0000 (16:29 -0500)
committerManoj Srivastava <srivasta@debian.org>
Tue, 15 Sep 2009 21:09:18 +0000 (16:09 -0500)
For machines without a newer Emacs, this has no effect, but if a new
Emacs is present, the .txt and .html files shall be regenerated if the
org file is newer.

Signed-off-by: Manoj Srivastava <srivasta@debian.org>
Makefile
README.html
README.org
README.txt
debian/rules

index d9031ff7e2659ee931c69e6a567a7a366d84b631..c3e6b4914d07f62b482fce8d9acbebd39a296189 100644 (file)
--- a/Makefile
+++ b/Makefile
@@ -8,6 +8,8 @@ ifneq (,$(strip $(HAVE_ORG_EMACS)))
 %.txt: %.org
        $(EMACS) --batch -Q -l ./README-css.el -l org --visit $^ \
           --funcall org-export-as-ascii >/dev/null 2>&1
+       test "$@" != "README.txt"  ||                            \
+           perl -pli -e 's,./Process.org,Process.txt,g' $@
 %.html: %.org
        $(EMACS) --batch -Q -l ./README-css.el -l org --visit $^ \
           --funcall org-export-as-html-batch >/dev/null 2>&1
index 765c626a4d2040dc47cedeccad2b69c7e3492172..2da20e2af48860a2b1eea99ef8a3af77b3477276 100644 (file)
@@ -13,22 +13,19 @@ lang="en" xml:lang="en">
 <title>Debian Policy</title>
 <meta http-equiv="Content-Type" content="text/html;charset=utf-8"/>
 <meta name="generator" content="Org-mode"/>
-<meta name="generated" content="2009-09-12 17:30:48 CDT"/>
-<meta name="author" content="Manoj Srivastava"/>
+<meta name="generated" content="2009-09-15 15:48:45 CDT"/>
+<meta name="author" content="Manoj Srivastava And Russ Allbery"/>
 <meta name="description" content=""/>
 <meta name="keywords" content=""/>
 
-<link href="/styles/simple_screen.css" type="text/css" rel="stylesheet" media="screen" />
-<link href="/styles/simple_print.css"  type="text/css" rel="stylesheet" media="print" />
-<link href="/styles/common.css"        type="text/css" rel="stylesheet" />
 <style type="text/css">
   html { font-family: Times, serif; font-size: 12pt; }
   .title  { text-align: center; }
   p.verse { margin-left: 3% }
   pre {
         border: 1pt solid #AEBDCC;
-        color: gainsboro;
-        background-color: DarkSlateGrey;
+        color: #000000;
+        background-color: LightSlateGray;
         padding: 5pt;
         font-family: "Courier New", courier, monospace;
         font-size: 90%;
@@ -46,8 +43,8 @@ lang="en" xml:lang="en">
                                  font-weight:bold; }
 
   body {
-    color: LightSlateGray;
-    background-color: #000000;
+   color: DarkSlateGrey;
+   background-color: gainsboro;
    font-family: Palatino, "Palatino Linotype", "Hoefler Text", "Times New Roman", Times, Georgia, Utopia, serif;
   }
   .org-agenda-date          { color: #87cefa;    }
@@ -179,7 +176,7 @@ Request tracker:: <a href="http://bugs.debian.org/src:debian-policy">http://bugs
 <p>Debian Policy uses a formal procedure and a set of user tags to manage
 the lifecycle of change proposals. For definitions of those tags and
 proposal states and information about what the next step is for each
-phase, see PolicyChangesProcess.
+phase, see <a href="./Process.html">Policy changes process</a>.
 </p>
 <p>
 Once the wording for a change has been finalized, please send a patch
@@ -215,7 +212,7 @@ git checkout &lt;local-branch-name&gt;
 dir=$(mktemp -d)
 git format-patch -o $dir -s master
 # check out the patches created in $dir
-git send-email --from <span style="color: #ffc1c1;">"you &lt;<a href="mailto:your&#64;email">your&#64;email</a>&gt;"</span>             \
+git send-email --from <span style="font-style: italic;">"you &lt;<a href="mailto:your&#64;email">your&#64;email</a>&gt;"</span>             \
                --to debian-policy@lists.debian.org   \
                $dir/
 </pre>
@@ -328,7 +325,7 @@ In addition to the main technical manual, the team currently also maintains:
 </li>
 </ul>
 
-<p>These documents are maintained using the <a href="http://wiki.debian.org/PolicyChangesProcess">Policy changes process</a>, and
+<p>These documents are maintained using the <a href="./Process.html">Policy changes process</a>, and
 the current state of all change proposals is tracked using the
 <a href="http://bugs.debian.org/src:debian-policy">debian-policy BTS</a>.
 </p>
@@ -350,7 +347,7 @@ will involve guiding the discussion, seeking additional input
 (particularly from experts in the area being discussed), possibly
 raising the issue on other mailing lists, proposing or getting other
 people to propose specific wording changes, and writing diffs against
-the current Policy document. All of the steps of <a href="http://wiki.debian.org/PolicyChangesProcess">Policy changes process</a> 
+the current Policy document. All of the steps of <a href="./Process.html">Policy changes process</a> 
 can be done by people other than Policy team members except
 the final acceptance steps and almost every change can be worked on
 independently, so there's a lot of opportunity for people to help.
@@ -563,7 +560,7 @@ branches. The equivalent of the following commands should do that:
 
 <pre class="src src-Sh">for i in `git show-ref --heads | awk '{print $2}'`; do
     j=$(basename $i)
-    if [ <span style="color: #ffc1c1;">"$j"</span> != <span style="color: #ffc1c1;">"master"</span> ]; then
+    if [ <span style="font-style: italic;">"$j"</span> != <span style="font-style: italic;">"master"</span> ]; then
         git checkout $j &amp;&amp; git merge master
     fi
 done
@@ -633,11 +630,10 @@ Policy release. Resolving a bug means one of the following:
 </p>
 <ul>
 <li>
-Proposing new language to address the bug that's seconded and
-approved by the readers of the Policy list following the
-PolicyChangesProcess (or that's accepted by one of the Policy
-delegates if the change isn't normative; i.e., doesn't change the
-technical meaning of the document).
+Proposing new language to address the bug that's seconded and approved by
+the readers of the Policy list following the <a href="./Progress.html">Policy changes process</a> (or
+that's accepted by one of the Policy delegates if the change isn't
+normative; i.e., doesn't change the technical meaning of the document).
 </li>
 <li>
 Determining that the bug is not relevant to Policy and closing it.
@@ -672,10 +668,10 @@ reach one of the resolution states above.
 </div>
 </div>
 <div id="postamble">
-<p class="author"> Author: Manoj Srivastava
+<p class="author"> Author: Manoj Srivastava And Russ Allbery
 <a href="mailto:srivasta@debian.org">&lt;srivasta@debian.org&gt;</a>
 </p>
-<p class="date"> Date: 2009-09-12 17:30:48 CDT</p>
+<p class="date"> Date: 2009-09-15 15:48:45 CDT</p>
 <p class="creator">HTML generated by org-mode 6.30trans in emacs 23</p>
 </div>
 </div>
index 322822921389b6bab501f7f700e7a7c2e7469d51..85963965d51b88cf16319d735b0c304fda7ef0f6 100644 (file)
@@ -51,7 +51,7 @@
 Debian Policy uses a formal procedure and a set of user tags to manage
 the lifecycle of change proposals. For definitions of those tags and
 proposal states and information about what the next step is for each
-phase, see PolicyChangesProcess.
+phase, see [[./Process.org][Policy changes process]].
 
 Once the wording for a change has been finalized, please send a patch
 against the current Git master branch to the bug report, if you're not
@@ -140,7 +140,7 @@ In addition to the main technical manual, the team currently also maintains:
 + [[http://www.debian.org/doc/packaging-manuals/debconf_specification.html][Debconf Specification]]
 + [[http://www.debian.org/doc/packaging-manuals/virtual-package-names-list.txt][Authoritative list of virtual package names ]]
 
-These documents are maintained using the [[http://wiki.debian.org/PolicyChangesProcess][Policy changes process]], and
+These documents are maintained using the [[./Process.org][Policy changes process]], and
 the current state of all change proposals is tracked using the
 [[http://bugs.debian.org/src:debian-policy][debian-policy BTS]].
 
@@ -154,7 +154,7 @@ will involve guiding the discussion, seeking additional input
 (particularly from experts in the area being discussed), possibly
 raising the issue on other mailing lists, proposing or getting other
 people to propose specific wording changes, and writing diffs against
-the current Policy document. All of the steps of [[http://wiki.debian.org/PolicyChangesProcess][Policy changes process]] 
+the current Policy document. All of the steps of [[./Process.org][Policy changes process]] 
 can be done by people other than Policy team members except
 the final acceptance steps and almost every change can be worked on
 independently, so there's a lot of opportunity for people to help.
@@ -319,11 +319,10 @@ useful, when trying to find a place to start, to pick a manageable set
 of bugs and set as a target resolving them completely before the next
 Policy release. Resolving a bug means one of the following:
 
-+ Proposing new language to address the bug that's seconded and
-  approved by the readers of the Policy list following the
-  PolicyChangesProcess (or that's accepted by one of the Policy
-  delegates if the change isn't normative; i.e., doesn't change the
-  technical meaning of the document).
++ Proposing new language to address the bug that's seconded and approved by
+  the readers of the Policy list following the [[./Progress.org][Policy changes process]] (or
+  that's accepted by one of the Policy delegates if the change isn't
+  normative; i.e., doesn't change the technical meaning of the document).
 + Determining that the bug is not relevant to Policy and closing it.
 + Determining that either there is no consensus that the bug indicates
   a problem, that the solutions that we can currently come up with are
index ff48eaa0ef8fc3154e134cfb9809cb51dc556246..55e9b230efeb9cff97dee295ecae18cdcb22c505 100644 (file)
@@ -1,8 +1,8 @@
                             Debian Policy
                             =============
 
-Author: Manoj Srivastava <srivasta@debian.org>
-Date: 2009-09-13 00:31:16 CDT
+Author: Manoj Srivastava And Russ Allbery <srivasta@debian.org>
+Date: 2009-09-15 15:48:35 CDT
 
 
 Infrastructure 
@@ -26,7 +26,7 @@ Interacting with the team
 Debian Policy uses a formal procedure and a set of user tags to manage
 the lifecycle of change proposals. For definitions of those tags and
 proposal states and information about what the next step is for each
-phase, see PolicyChangesProcess.
+phase, see [Policy changes process].
 
 Once the wording for a change has been finalized, please send a patch
 against the current Git master branch to the bug report, if you're not
@@ -68,6 +68,9 @@ changes. You may want to use some common prefix like local-. You can
 use git format-patch and git send-email if you want, but usually it's
 overkill.
 
+
+[Policy changes process]: Process.txt
+
 Usual Roles 
 ~~~~~~~~~~~~
 
@@ -126,7 +129,7 @@ the current state of all change proposals is tracked using the
 [Debian MIME support sub-policy]: http://www.debian.org/doc/packaging-manuals/mime-policy/
 [Debconf Specification]: http://www.debian.org/doc/packaging-manuals/debconf_specification.html
 [Authoritative list of virtual package names ]: http://www.debian.org/doc/packaging-manuals/virtual-package-names-list.txt
-[Policy changes process]: http://wiki.debian.org/PolicyChangesProcess
+[Policy changes process]: Process.txt
 [debian-policy BTS]: http://bugs.debian.org/src:debian-policy
 
 Get involved 
@@ -179,7 +182,7 @@ help you get started.
 
 [current open bugs]: http://bugs.debian.org/src:debian-policy
 [debian-policy@lists.debian.org]: mailto:debian-policy@lists.debian.org
-[Policy changes process]: http://wiki.debian.org/PolicyChangesProcess
+[Policy changes process]: Process.txt
 [debian-policy@lists.debian.org ]: mailto:debian-policy@lists.debian.org
 
 Maintenance procedures 
@@ -312,11 +315,10 @@ useful, when trying to find a place to start, to pick a manageable set
 of bugs and set as a target resolving them completely before the next
 Policy release. Resolving a bug means one of the following:
 
-+ Proposing new language to address the bug that's seconded and
-  approved by the readers of the Policy list following the
-  PolicyChangesProcess (or that's accepted by one of the Policy
-  delegates if the change isn't normative; i.e., doesn't change the
-  technical meaning of the document).
++ Proposing new language to address the bug that's seconded and approved by
+  the readers of the Policy list following the [Policy changes process] (or
+  that's accepted by one of the Policy delegates if the change isn't
+  normative; i.e., doesn't change the technical meaning of the document).
 + Determining that the bug is not relevant to Policy and closing it.
 + Determining that either there is no consensus that the bug indicates
   a problem, that the solutions that we can currently come up with are
@@ -339,3 +341,6 @@ One of the best ways to help out is to pick one or two bugs (checking
 on the Policy list first), say that you'll make resolving them a goal
 for the next release, and guide the discussion until the bugs can
 reach one of the resolution states above.
+
+[Policy changes process]: ./Progress.org
+
index 393c1f1b83a4138cb55520db43c4e0fe2041528b..dcf5e915d53908837e0d944f24ab7b286922dd61 100755 (executable)
@@ -83,7 +83,9 @@ make_directory  := install -p -d      -o root -g root  -m  755
 
 
 all build: stamp-build
-stamp-build: version.ent $(sanitycheck)
+stamp-build: version.ent $(sanitycheck) upgrading-checklist.html \
+              upgrading-checklist.txt README.txt README.html \
+              Process.txt Process.html
        $(MAKE) $(SGML_FILES:=.sgml.validate) \
                $(SGML_FILES:=.html.tar.gz) \
                 $(SGML_FILES:=-1.html) \