]> git.donarmstrong.com Git - lilypond.git/blobdiff - debian/rules
(start_translation_timestep): split
[lilypond.git] / debian / rules
index 04b677b0852383bd698634588020c42cd9afec4f..ffd1788a453324ca376315dbdfea590e9c0685e3 100644 (file)
@@ -13,7 +13,10 @@ SHELL = /bin/sh
 r = debian/$(package)
 r_data = debian/$(package)-data
 r_doc = debian/$(package)-doc
+
+# FIXME: /usr
 d = usr/share/doc/$(package)
+info = /usr/share/info/$(package)
 
 include VERSION
 VERSION = $(MAJOR_VERSION).$(MINOR_VERSION).$(PATCH_LEVEL)
@@ -41,11 +44,11 @@ build: build-stamp
 build-stamp:
        dh_testdir
 
-       ./configure --enable-checking --enable-debugging \
-               --prefix=/usr --enable-optimise \
+       ./configure --disable-checking --enable-debugging \
+               --prefix=/usr --enable-optimising \
                --infodir='$${prefix}/share/info' \
                --mandir='$${prefix}/share/man'
-       $(MAKE) MAKE_PFA_FILES=1
+       $(MAKE)
 
        touch build-stamp
 
@@ -75,6 +78,7 @@ clean:
        rm -f debian/emacsen-startup
        rm -f debian/lilypond1.7*.dirs debian/lilypond.dirs
        rm -f debian/postinst debian/prerm debian/postrm
+       rm -f debian/lilypond-data.doc-base debian/lilypond.doc-base
 
        dh_clean
 
@@ -86,7 +90,7 @@ install: build
        dh_installdirs
 
        # Add here commands to install the package into debian/tmp.
-       $(MAKE) install prefix=$(CURDIR)/debian/tmp/usr MAKE_PFA_FILES=1
+       $(MAKE) install prefix=$(CURDIR)/debian/tmp/usr
 
        dh_install --sourcedir=debian/tmp --list-missing
 
@@ -103,10 +107,13 @@ binary-indep: build-doc install
        dh_testroot
        # Install LilyPond web documentation...
        $(MAKE) prefix=$(PWD)/$(r_doc)/usr webdir=$(PWD)/$(r_doc)/$(d)/html out=www web-install
-       # Add symlinks to the PostScript docs and LilyPond logo PNGs ...
+       # Add symlinks to the PostScript docs and LilyPond logo PNGs for HTML...
        cd $(r_doc)/$(d) \
            && cp -s `find html/Documentation -name '*.ps.gz'` . \
            && cp -s html/Documentation/pictures/out-www/*.png .
+       # Add symlinks to the documentation PNGs for info...
+       cd $(r_doc)/$(info) \
+           && cp -s ../../doc/$(package)/html/Documentation/user/out-www/*.png .
 #      # Copy the DVI docs too ...
 #      cp -a `find Documentation -name '*.dvi' ! -name 'lily-[0-9]*.dvi'` \
 #              $(r_doc)/$(d)/