]> git.donarmstrong.com Git - lilypond.git/blobdiff - debian/rules
update from Debian
[lilypond.git] / debian / rules
index b3ade4c133ccb06261767c68534037c29bb6f719..fb06f3b809d4c5d63c0a5c54490d019bc5a70f34 100644 (file)
@@ -1,6 +1,5 @@
 #!/usr/bin/make -f
-# Made with the aid of debhelper by Joey Hess,
-# based on the sample debian/rules file for GNU hello by Ian Jackson.
+# debian/rules for LilyPond in Debian.
 #
 # This is free software; see the GNU General Public Licence
 # version 2 or later for copying conditions.  There is NO warranty.
@@ -18,13 +17,6 @@ d = usr/share/doc/$(package)
 include VERSION
 VERSION = $(MAJOR_VERSION).$(MINOR_VERSION).$(PATCH_LEVEL)
 
-#export CC = gcc-3.2
-#export CXX = g++-3.2
-gcc_version = $(shell g++ --version 2>&1 \
-               | grep '[0-9]\.[0-9]' | head -1 \
-               | sed -e 's/.*[^-.0-9]\([0-9][0-9]*\.[0-9][.0-9]*\).*/\1/' \
-                     -e 's/^\([0-9]\+\).*/\1/')
-
 # "main_memory = 263000" in /etc/texmf/texmf.cnf isn't large enough
 # for latex to process standchen.dvi.latex, so adding extra_mem_* ...
 # export extra_mem_top = 100000
@@ -42,7 +34,7 @@ export MAILADDRESS = lilypond@packages.debian.org
 #export DH_VERBOSE=1
 
 # This is the debhelper compatibility version to use.
-export DH_COMPAT=3
+export DH_COMPAT=4
 
 # This has to be exported to make some magic below work.
 export DH_OPTIONS
@@ -51,13 +43,10 @@ build: build-stamp
 build-stamp:
        dh_testdir
 
-       if [ "$(gcc_version)" = "3" ]; then ./lexer-gcc-3.1.sh; fi
-       CPPFLAGS=-I`pwd`/lily/out \
        ./configure --enable-checking --enable-debugging \
                --prefix=/usr --enable-optimise \
                --infodir='$${prefix}/share/info' \
                --mandir='$${prefix}/share/man'
-       if [ "$(gcc_version)" = "3" ]; then ./lexer-gcc-3.1.sh; fi
        $(MAKE) MAKE_PFA_FILES=1
 
        touch build-stamp
@@ -66,8 +55,12 @@ build-doc: build build-doc-stamp
 build-doc-stamp:
        dh_testdir
 
+       # make info
        $(MAKE) -C Documentation
+       # make html
        $(MAKE) web
+       $(MAKE) -C Documentation/user omf
+#      find . -type d -name 'out-www' | xargs rm -rf
 
        touch build-doc-stamp
 
@@ -80,7 +73,6 @@ clean:
 
        # Still not clean enough?  Let's use... BRUTE STRENGTH!  :-)
        find . -type d -name 'out' -o -name 'out-www' | xargs rm -rf
-       rm -f debian/lilypond.links
 
        dh_clean
 
@@ -93,6 +85,8 @@ install: build
        # Add here commands to install the package into debian/tmp.
        dh_installdirs
        $(MAKE) prefix=$(PWD)/$(r)/usr MAKE_PFA_FILES=1 install
+       # Ugh, remove hundred music-glossary copies
+#      find . -name 'music-glossary.info-*' | xargs rm -f
 
 #      # Change from an absolute symlink to a relative symlink (Lintian)
 #      if [ -L $(r)/usr/share/lilypond/cmtfm ]; then \
@@ -105,19 +99,19 @@ binary-indep: DH_OPTIONS=-i
 binary-indep: build-doc install
        dh_testdir
        dh_testroot
-       # Extract LilyPond website tarball ...
-       tar -C $(r_doc)/$(d)/html -xvzf out/web.tar.gz
+       # Install LilyPond web documentation...
+       $(MAKE) prefix=$(PWD)/$(r_doc)/usr webdir=$(PWD)/$(r_doc)/$(d)/html out=www web-install
        # Add symlinks to the PostScript docs and LilyPond logo PNGs ...
        cd $(r_doc)/$(d) \
            && cp -s `find html/Documentation -name '*.ps.gz'` . \
            && cp -s html/Documentation/pictures/out-www/*.png .
-       # Copy the DVI docs too ...
-       cp -a `find Documentation -name '*.dvi' ! -name 'lily-[0-9]*.dvi'` \
-               $(r_doc)/$(d)/
+#      # Copy the DVI docs too ...
+#      cp -a `find Documentation -name '*.dvi' ! -name 'lily-[0-9]*.dvi'` \
+#              $(r_doc)/$(d)/
        dh_installdocs
        dh_installchangelogs
        dh_link
-       dh_compress -Xusr/share/doc/lilypond/html/
+       dh_compress -X$(d)/html/
        dh_fixperms
        dh_installdeb
        dh_gencontrol
@@ -128,9 +122,8 @@ binary-arch: DH_OPTIONS=-s
 binary-arch: build install
        dh_testdir
        dh_testroot
-       cp -av lilypond-mode.el lilypond-font-lock.el lilypond-indent.el \
-               $(r)/usr/share/emacs/site-lisp/
-       dh_installdocs DEDICATION NEWS ROADMAP *.txt
+       dh_installdocs AUTHORS.txt NEWS.txt README.txt \
+               DEDICATION THANKS 
 
 #      dh_installdocs DEDICATION NEWS ROADMAP *.txt \
 #              Documentation/pictures/out/*.png
@@ -141,16 +134,22 @@ binary-arch: build install
 #      cp -a Documentation/misc/[ACN]* $(r)/$(d)/misc/
 
 #      dh_installexamples input
-       find input \( -name '*.*ly' -o -name '*.abc' -o -name '*.tex' -o -name 'TODO' \) \
+
+       find input \( -name '*.*ly' -o -name '*.abc' -o -name '*.tex' -o -name 'TODO' \) ! -regex '.*/out-www/.*' \
                -exec cp -a --parents '{}' $(r)/$(d)/examples ';'
-       for i in `find $(r)/$(d)/examples/ -type d -name out`; do \
-               mv -fv $$i/* $$i/..; rmdir $$i; done
+#      for i in `find $(r)/$(d)/examples/ -type d -name out`; do \
+#              mv -fv $$i/* $$i/..; rmdir $$i; done
+
 #      dh_installmenu
        dh_installemacsen
+       dh_scrollkeeper
 #      dh_installcron
 #      dh_installman
 #      dh_undocumented
        dh_installchangelogs ChangeLog
+
+       mv $(r)/usr/share/lilypond/$(VERSION)/dvips/lilypond.map \
+          $(r)/etc/texmf/dvips/lilypond.map
        dh_link usr/share/lilypond/$(VERSION)/tex \
                        usr/share/texmf/tex/lilypond \
                usr/share/lilypond/$(VERSION)/fonts/source \
@@ -159,8 +158,8 @@ binary-arch: build install
                        usr/share/texmf/fonts/afm/public/lilypond \
                usr/share/lilypond/$(VERSION)/fonts/tfm \
                        usr/share/texmf/fonts/tfm/public/lilypond \
-               usr/share/lilypond/$(VERSION)/dvips/lilypond.map \
-                       usr/share/texmf/dvips/config/lilypond.map
+               etc/texmf/dvips/lilypond.map \
+                       usr/share/lilypond/$(VERSION)/dvips/lilypond.map
        dh_strip
        dh_compress
        dh_fixperms