]> git.donarmstrong.com Git - lilypond.git/blobdiff - debian/rules
Fix FTBFS when built with dpkg-buildpackage -A
[lilypond.git] / debian / rules
index 87828fafdde40af6853e82376283835270d092d1..f567568063f0030aaf886fd9bc4506d484f4312f 100755 (executable)
@@ -32,7 +32,7 @@ endif
 %:
        dh $@ --parallel --with autotools-dev --with python2 --with quilt
 
-## we need to nuke the parser files, because if there is a mistmatch
+## we need to nuke the parser files, because if there is a mismatch
 ## between upstreams bison and our bison, the build will fail epically
 override_dh_auto_configure:
        rm -f lily/out/parser.*
@@ -40,18 +40,9 @@ override_dh_auto_configure:
        dh_auto_configure -- --disable-checking --enable-debugging --enable-guile2 $(config_opt)
 
 override_dh_auto_build-indep:
-       dh_auto_build
+       dh_auto_build -i -O--parallel
        $(MAKE) doc $(DOC_OPTIONS)
 
-override_dh_auto_install-indep:
-       $(MAKE) install-doc $(DOC_OPTIONS) prefix=$(CURDIR)/debian/tmp/usr/
-       $(MAKE) install-info $(DOC_OPTIONS) prefix=$(CURDIR)/debian/tmp/usr
-       rm -rf $(CURDIR)/debian/tmp/usr/share/omf
-       rm -rf $(CURDIR)/debian/tmp/usr/share/doc/lilypond/html/input
-       perl debian/move_info_images_from_html_doc $(CURDIR)/debian/tmp/usr/share/info/ $(CURDIR)/debian/tmp/usr/share/doc/lilypond/html/Documentation/
-       perl debian/symlink_html_images_to_info_images $(CURDIR)/debian/tmp/usr/share/info/lilypond
-       perl debian/remove_w3c_callback $(CURDIR)/debian/tmp/usr/share/doc/lilypond/ $(CURDIR)/debian/tmp/usr/share/info/
-
 ## Unfortunately, lilypond is kind of broken, and installs the wrong
 ## info documentation (missing images) if we call their makefile
 ## directly. They also don't provide an install rule which doesn't
@@ -60,20 +51,35 @@ override_dh_auto_install-indep:
 override_dh_auto_install-arch:
        for dir in `echo */*makefile|xargs -n 1 dirname|grep -v Documentation`; do \
                $(MAKE) --no-builtin-rules PACKAGE=LILYPOND package=lilypond -C $$dir install $(DOC_OPTIONS) prefix=$(CURDIR)/debian/tmp/usr/; \
-       done;
+       done
 
-## we need to nuke the parser files, because if there is a mistmatch
+## We need the non-Documentation arch-independent files installed by
+## the arch-dependent "$(MAKE) install" too, hence the dependency
+## on override_dh_auto_install-arch
+override_dh_auto_install-indep: override_dh_auto_install-arch
+       $(MAKE) install-doc $(DOC_OPTIONS) prefix=$(CURDIR)/debian/tmp/usr/
+       $(MAKE) install-info $(DOC_OPTIONS) prefix=$(CURDIR)/debian/tmp/usr
+       rm -rf $(CURDIR)/debian/tmp/usr/share/omf
+       rm -rf $(CURDIR)/debian/tmp/usr/share/doc/lilypond/html/input
+       perl debian/move_info_images_from_html_doc $(CURDIR)/debian/tmp/usr/share/info/ $(CURDIR)/debian/tmp/usr/share/doc/lilypond/html/Documentation/
+       perl debian/symlink_html_images_to_info_images $(CURDIR)/debian/tmp/usr/share/info/lilypond
+       perl debian/remove_w3c_callback $(CURDIR)/debian/tmp/usr/share/doc/lilypond/ $(CURDIR)/debian/tmp/usr/share/info/
+
+## we need to nuke the parser files, because if there is a mismatch
 ## between upstreams bison and our bison, the build will fail epically
 override_dh_auto_clean:
        rm -f lily/out/parser.*
-       dh_auto_clean
+       dh_auto_clean --no-parallel
+
+override_dh_install-arch:
+       dh_install -a -O--parallel --list-missing
 
 ## we need to install only the png, jpg, css, ly and english html
 ## files into the doc-html package, and only the english pdfs into the
 ## doc-pdf package. Because dh_install doesn't support regexes, we'll
 ## use find to replace the contents of the .install file before we
 ## call dh_install
-override_dh_install:
+override_dh_install-indep:
        /bin/echo -e 'usr/share/doc/lilypond/html/*/*/*.ly\nusr/share/doc/lilypond/html/*/*/*.png' \
                > $(CURDIR)/debian/lilypond-doc-html.install
        /bin/echo -e 'usr/share/doc/lilypond/html/*/*/*.jpg\nusr/share/doc/lilypond/html/*/*/*.css' \
@@ -88,14 +94,14 @@ override_dh_install:
        find $(CURDIR)/debian/tmp/ -type f \
                -regex '.*usr/share/doc/lilypond/.*/[^\.]+.preview.pdf' \
                -printf '%P\n' >> $(CURDIR)/debian/lilypond-doc-pdf.install
-       dh_install --list-missing
+       dh_install -i -O--parallel --list-missing
 
 override_dh_python2:
        dh_python2 --verbose
        dh_python2 --verbose usr/share/lilypond/$(MAJOR_VERSION).$(MINOR_VERSION).$(PATCH_LEVEL)/python/
 
 override_dh_compress:
-       dh_compress -X.ly
+       dh_compress -X.ly -X.pdf
 
 override_dh_installdocs:
        dh_installdocs
@@ -103,12 +109,12 @@ override_dh_installdocs:
                package=`basename $$a .doc-base-special`; \
                install -d debian/$$package/usr/share/doc-base; \
                install -m0644 $$a debian/$$package/usr/share/doc-base/$$package; \
-       done;
+       done
 
 override_dh_auto_test:
 ifneq (,$(filter $(DEB_BUILD_OPTIONS),nocheck))
        $(MAKE) test-baseline
-    $(MAKE) test
+       $(MAKE) test
 endif
 
 ## this rule will update debian/control and the per-language install