]> git.donarmstrong.com Git - lilypond.git/blobdiff - debian/rules
* lily/include/music.hh (class Music): remove Music::duration_log()
[lilypond.git] / debian / rules
index 4df410873e97e905f464f4fcea979fecb0637118..e9e88ae787c0a4a2a9b49a7cbca4bdedc8816e5e 100644 (file)
@@ -11,8 +11,12 @@ package = lilypond
 
 SHELL = /bin/sh
 r = debian/$(package)
+r_data = debian/$(package)-data
 r_doc = debian/$(package)-doc
+
+# FIXME: /usr
 d = usr/share/doc/$(package)
+info = /usr/share/info/$(package)
 
 include VERSION
 VERSION = $(MAJOR_VERSION).$(MINOR_VERSION).$(PATCH_LEVEL)
@@ -33,9 +37,6 @@ export MAILADDRESS = lilypond@packages.debian.org
 # Uncomment this to turn on verbose mode.
 #export DH_VERBOSE=1
 
-# This is the debhelper compatibility version to use.
-export DH_COMPAT=4
-
 # This has to be exported to make some magic below work.
 export DH_OPTIONS
 
@@ -43,11 +44,11 @@ build: build-stamp
 build-stamp:
        dh_testdir
 
-       ./configure --enable-checking --enable-debugging \
-               --prefix=/usr --enable-optimise \
+       ./configure --disable-checking --enable-debugging \
+               --prefix=/usr --enable-optimising \
                --infodir='$${prefix}/share/info' \
                --mandir='$${prefix}/share/man'
-       $(MAKE) MAKE_PFA_FILES=1
+       $(MAKE)
 
        touch build-stamp
 
@@ -73,6 +74,11 @@ clean:
 
        # Still not clean enough?  Let's use... BRUTE STRENGTH!  :-)
        find . -type d -name 'out' -o -name 'out-www' | xargs rm -rf
+       rm -f lib/lilypond/python examples.html
+       rm -f debian/emacsen-startup
+       rm -f debian/lilypond1.7*.dirs debian/lilypond.dirs
+       rm -f debian/postinst debian/prerm debian/postrm
+       rm -f debian/lilypond-data.doc-base debian/lilypond.doc-base
 
        dh_clean
 
@@ -81,12 +87,12 @@ install: build
        dh_testdir
        dh_testroot
        dh_clean -k
+       dh_installdirs
 
        # Add here commands to install the package into debian/tmp.
-       dh_installdirs
-       $(MAKE) prefix=$(PWD)/$(r)/usr MAKE_PFA_FILES=1 install
-       # Ugh, remove hundred music-glossary copies
-#      find . -name 'music-glossary.info-*' | xargs rm -f
+       $(MAKE) install prefix=$(CURDIR)/debian/tmp/usr
+
+       dh_install --sourcedir=debian/tmp --list-missing
 
 #      # Change from an absolute symlink to a relative symlink (Lintian)
 #      if [ -L $(r)/usr/share/lilypond/cmtfm ]; then \
@@ -101,16 +107,40 @@ binary-indep: build-doc install
        dh_testroot
        # Install LilyPond web documentation...
        $(MAKE) prefix=$(PWD)/$(r_doc)/usr webdir=$(PWD)/$(r_doc)/$(d)/html out=www web-install
-       # Add symlinks to the PostScript docs and LilyPond logo PNGs ...
+       # Add symlinks to the PostScript docs and LilyPond logo PNGs for HTML...
        cd $(r_doc)/$(d) \
            && cp -s `find html/Documentation -name '*.ps.gz'` . \
            && cp -s html/Documentation/pictures/out-www/*.png .
+       # Add symlinks to the documentation PNGs for info...
+       cd $(r_doc)/$(info) \
+           && cp -s ../../doc/$(package)/html/Documentation/user/out-www/*.png .
 #      # Copy the DVI docs too ...
 #      cp -a `find Documentation -name '*.dvi' ! -name 'lily-[0-9]*.dvi'` \
 #              $(r_doc)/$(d)/
        dh_installdocs
+       dh_installemacsen
+       dh_scrollkeeper
+
+       find input \( -name '*.*ly' -o -name '*.abc' -o -name '*.tex' -o -name 'TODO' \) ! -regex '.*/out-www/.*' \
+               -exec cp -a --parents '{}' $(r_data)/$(d)/examples ';'
        dh_installchangelogs
-       dh_link
+
+       mv $(r_data)/usr/share/lilypond/$(VERSION)/fonts/map/lilypond.map \
+          $(r_data)/etc/texmf/dvips/lilypond.map
+
+       dh_link usr/share/lilypond/$(VERSION)/tex \
+                       usr/share/texmf/tex/lilypond \
+               usr/share/lilypond/$(VERSION)/fonts/source \
+                       usr/share/texmf/fonts/source/public/lilypond \
+               usr/share/lilypond/$(VERSION)/fonts/afm \
+                       usr/share/texmf/fonts/afm/public/lilypond \
+               usr/share/lilypond/$(VERSION)/fonts/tfm \
+                       usr/share/texmf/fonts/tfm/public/lilypond \
+               usr/share/lilypond/$(VERSION)/fonts/type1 \
+                       usr/share/texmf/fonts/type1/public/lilypond \
+               etc/texmf/dvips/lilypond.map \
+                       usr/share/lilypond/$(VERSION)/dvips/lilypond.map
+
        dh_compress -X$(d)/html/
        dh_fixperms
        dh_installdeb
@@ -122,12 +152,8 @@ binary-arch: DH_OPTIONS=-s
 binary-arch: build install
        dh_testdir
        dh_testroot
-       cp -av lilypond-mode.el lilypond-font-lock.el lilypond-indent.el \
-               lilypond.words \
-               $(r)/usr/share/emacs/site-lisp/
        dh_installdocs AUTHORS.txt NEWS.txt README.txt \
-               DEDICATION THANKS \
-               README.mandrake
+               DEDICATION THANKS 
 
 #      dh_installdocs DEDICATION NEWS ROADMAP *.txt \
 #              Documentation/pictures/out/*.png
@@ -139,8 +165,6 @@ binary-arch: build install
 
 #      dh_installexamples input
 
-       find input \( -name '*.*ly' -o -name '*.abc' -o -name '*.tex' -o -name 'TODO' \) ! -regex '.*/out-www/.*' \
-               -exec cp -a --parents '{}' $(r)/$(d)/examples ';'
 #      for i in `find $(r)/$(d)/examples/ -type d -name out`; do \
 #              mv -fv $$i/* $$i/..; rmdir $$i; done
 
@@ -152,18 +176,6 @@ binary-arch: build install
 #      dh_undocumented
        dh_installchangelogs ChangeLog
 
-       mv $(r)/usr/share/lilypond/$(VERSION)/dvips/lilypond.map \
-          $(r)/etc/texmf/dvips/lilypond.map
-       dh_link usr/share/lilypond/$(VERSION)/tex \
-                       usr/share/texmf/tex/lilypond \
-               usr/share/lilypond/$(VERSION)/fonts/source \
-                       usr/share/texmf/fonts/source/public/lilypond \
-               usr/share/lilypond/$(VERSION)/fonts/afm \
-                       usr/share/texmf/fonts/afm/public/lilypond \
-               usr/share/lilypond/$(VERSION)/fonts/tfm \
-                       usr/share/texmf/fonts/tfm/public/lilypond \
-               etc/texmf/dvips/lilypond.map \
-                       usr/share/lilypond/$(VERSION)/dvips/lilypond.map
        dh_strip
        dh_compress
        dh_fixperms