]> git.donarmstrong.com Git - lilypond.git/blobdiff - debian/rules
release: 1.3.104
[lilypond.git] / debian / rules
index d024ca3783d42ba2154b4f7c6214760b7c3551ec..de648132d45bd2ea17400c4315e19df4ae731aae 100755 (executable)
@@ -18,14 +18,14 @@ d = usr/share/doc/$(package)
 # Uncomment this to turn on verbose mode.
 #export DH_VERBOSE=1
 
-# This is the debhelper compatability version to use.
+# This is the debhelper compatibility version to use.
 export DH_COMPAT=1
 
 build: build-stamp
 build-stamp:
        dh_testdir
 
-       ./configure --disable-checking --disable-debugging \
+       ./configure --enable-checking --disable-debugging \
                --enable-printing --prefix=/usr --enable-optimise \
                --enable-shared \
                --infodir='$${prefix}/share/info' \
@@ -40,9 +40,10 @@ build-stamp:
 clean:
        dh_testdir
        dh_testroot
-       rm -f build-stamp install-stamp
+       rm -f build-stamp
        -$(MAKE) distclean
-       rm -f stepmake/stepmake/aclocal.m4
+       # Remove obsolete files which are still in the upstream tarball (1.3.42)
+       rm -f debian/control.in debian/doc-base debian/prerm
        dh_clean
 
        # Correct the owner of the out/dummy.dep files when built with sudo.
@@ -70,6 +71,12 @@ install: build
        ln -s ../../../../lilypond/afm $(r)/usr/share/texmf/fonts/afm/public/lilypond
        ln -s ../../../../lilypond/tfm $(r)/usr/share/texmf/fonts/tfm/public/lilypond
 
+       # Change from an absolute symlink to a relative symlink (Lintian)
+       if [ -L $(r)/usr/share/lilypond/cmtfm ]; then \
+               rm -f $(r)/usr/share/lilypond/cmtfm; \
+               ln -s ../texmf/fonts/tfm/public/cm $(r)/usr/share/lilypond/cmtfm; \
+       fi
+
 # Build architecture-independent files here.
 binary-indep: build install
 # We have nothing to do by default.
@@ -77,8 +84,9 @@ binary-indep: build install
 binary-arch: build install
        dh_testdir
        dh_testroot
-       cp -av lilypond-mode.el $(r)/usr/share/emacs/site-lisp/
-       dh_installdocs DEDICATION TODO *.txt \
+       cp -av lilypond-mode.el lilypond-font-lock.el \
+               $(r)/usr/share/emacs/site-lisp/
+       dh_installdocs DEDICATION NEWS ROADMAP *.txt \
                Documentation/pictures/out/*.png \
                Documentation/out/*.txt \
                Documentation/*/out/[a-z]*.dvi \