]> git.donarmstrong.com Git - lilypond.git/blobdiff - debian/rules
''
[lilypond.git] / debian / rules
old mode 100755 (executable)
new mode 100644 (file)
index 7538d7b..d8dfa0a
@@ -15,17 +15,15 @@ r = debian/$(package)
 r_doc = debian/$(package)-doc
 d = usr/share/doc/$(package)
 
-# TELY_FILES := $(notdir $(wildcard Documentation/user/*.tely))
-# DVI_FILES = $(addprefix Documentation/user/out/, $(TELY_FILES:.tely=.dvi))
-# PS_FILES = $(DVI_FILES:.dvi=.ps)
-
 # "main_memory = 263000" in /etc/texmf/texmf.cnf isn't large enough
 # for latex to process standchen.dvi.latex, so adding extra_mem_* ...
-export extra_mem_top=100000
-export extra_mem_bot=100000
-export MODE=ljfour
-export BDPI=600
-export MAILADDRESS=lilypond@packages.debian.org
+export extra_mem_top = 100000
+export extra_mem_bot = 100000
+export MODE = ljfour
+export BDPI = 600
+export USER_CFLAGS = -DDEBIAN
+export DEB_BUILD = yes
+export MAILADDRESS = lilypond@packages.debian.org
 
 # Uncomment this to turn on verbose mode.
 #export DH_VERBOSE=1
@@ -44,7 +42,7 @@ build-stamp:
                --prefix=/usr --enable-optimise \
                --infodir='$${prefix}/share/info' \
                --mandir='$${prefix}/share/man'
-       $(MAKE) USER_CFLAGS=-DDEBIAN all
+       $(MAKE) MAKE_PFA_FILES=1
 
        touch build-stamp
 
@@ -66,7 +64,6 @@ clean:
 
        # Still not clean enough?  Let's use... BRUTE STRENGTH!  :-)
        find . -type d -name 'out' -o -name 'out-www' | xargs rm -rf
-       rm -f debian/doc-base debian/TODO
 
        dh_clean
 
@@ -78,7 +75,7 @@ install: build
 
        # Add here commands to install the package into debian/tmp.
        dh_installdirs
-       $(MAKE) prefix=$(PWD)/$(r)/usr USER_CFLAGS=-DDEBIAN install
+       $(MAKE) prefix=$(PWD)/$(r)/usr  MAKE_PFA_FILES=1 install
 
        # Change from an absolute symlink to a relative symlink (Lintian)
        if [ -L $(r)/usr/share/lilypond/cmtfm ]; then \
@@ -103,7 +100,7 @@ binary-indep: build-doc install
        dh_installdocs
        dh_installchangelogs
        dh_link
-       dh_compress
+       dh_compress -Xusr/share/doc/lilypond/html/
        dh_fixperms
        dh_installdeb
        dh_gencontrol
@@ -142,10 +139,7 @@ binary-arch: build install
        dh_compress
        dh_fixperms
        dh_installdeb
-#      dh_shlibdeps
-       # Ugh, ugly kludge to avoid the circular symlinks under html/
-       cd debian/lilypond && dpkg-shlibdeps -T../substvars -dDepends \
-               usr/bin/lilypond usr/bin/midi2ly
+       dh_shlibdeps
        dh_gencontrol
 #      dh_makeshlibs
        dh_md5sums