]> git.donarmstrong.com Git - lilypond.git/blobdiff - debian/rules
''
[lilypond.git] / debian / rules
old mode 100755 (executable)
new mode 100644 (file)
index 4263188..d8dfa0a
@@ -8,68 +8,74 @@
 # Currently maintained by Anthony Fok <foka@debian.org>
 # for Debian GNU/Linux.
 
-package = lilypond1.3
+package = lilypond
 
 SHELL = /bin/sh
-r = debian/tmp
-TMP = `pwd`/debian/tmp
+r = debian/$(package)
+r_doc = debian/$(package)-doc
 d = usr/share/doc/$(package)
 
+# "main_memory = 263000" in /etc/texmf/texmf.cnf isn't large enough
+# for latex to process standchen.dvi.latex, so adding extra_mem_* ...
+export extra_mem_top = 100000
+export extra_mem_bot = 100000
+export MODE = ljfour
+export BDPI = 600
+export USER_CFLAGS = -DDEBIAN
+export DEB_BUILD = yes
+export MAILADDRESS = lilypond@packages.debian.org
+
 # Uncomment this to turn on verbose mode.
 #export DH_VERBOSE=1
 
 # This is the debhelper compatibility version to use.
-export DH_COMPAT=1
+export DH_COMPAT=3
+
+# This has to be exported to make some magic below work.
+export DH_OPTIONS
 
 build: build-stamp
 build-stamp:
        dh_testdir
 
        ./configure --enable-checking --disable-debugging \
-               --enable-printing --prefix=/usr --enable-optimise \
-               --enable-shared \
+               --prefix=/usr --enable-optimise \
                --infodir='$${prefix}/share/info' \
                --mandir='$${prefix}/share/man'
-       $(MAKE) all
-       $(MAKE) -C Documentation
-       $(MAKE) -C Documentation/user ps
-       $(MAKE) -C Documentation/pictures pngs
+       $(MAKE) MAKE_PFA_FILES=1
 
        touch build-stamp
 
+build-doc: build build-doc-stamp
+build-doc-stamp:
+       dh_testdir
+
+       $(MAKE) -C Documentation
+       $(MAKE) web
+
+       touch build-doc-stamp
+
 clean:
        dh_testdir
        dh_testroot
-       rm -f build-stamp
+       rm -f build-stamp build-doc-stamp
+       -$(MAKE) WWW-clean top-WWW-clean
        -$(MAKE) distclean
-       # Remove obsolete files which are still in the upstream tarball (1.3.42)
-       rm -f debian/control.in debian/doc-base debian/prerm
-       dh_clean
 
-       # Correct the owner of the out/dummy.dep files when built with sudo.
-       if [ -n "$$SUDO_USER" -a -n "$$SUDO_GID" ]; then \
-               find . -user root | xargs -r chown --dereference $$SUDO_USER.$$SUDO_GID; \
-       fi
+       # Still not clean enough?  Let's use... BRUTE STRENGTH!  :-)
+       find . -type d -name 'out' -o -name 'out-www' | xargs rm -rf
+
+       dh_clean
 
+install: DH_OPTIONS=
 install: build
        dh_testdir
        dh_testroot
        dh_clean -k
-       dh_installdirs usr/share/doc/texmf \
-               $(d)/examples \
-               usr/share/emacs/site-lisp \
-               usr/share/texmf/tex \
-               usr/share/texmf/fonts/source/public \
-               usr/share/texmf/fonts/afm/public \
-               usr/share/texmf/fonts/tfm/public
-       ln -fs ../$(package) $(r)/usr/share/doc/texmf/lilypond
-
-       $(MAKE) prefix=$(TMP)/usr install
-
-       ln -s ../../lilypond/tex $(r)/usr/share/texmf/tex/lilypond
-       ln -s ../../../../lilypond/mf $(r)/usr/share/texmf/fonts/source/public/lilypond
-       ln -s ../../../../lilypond/afm $(r)/usr/share/texmf/fonts/afm/public/lilypond
-       ln -s ../../../../lilypond/tfm $(r)/usr/share/texmf/fonts/tfm/public/lilypond
+
+       # Add here commands to install the package into debian/tmp.
+       dh_installdirs
+       $(MAKE) prefix=$(PWD)/$(r)/usr  MAKE_PFA_FILES=1 install
 
        # Change from an absolute symlink to a relative symlink (Lintian)
        if [ -L $(r)/usr/share/lilypond/cmtfm ]; then \
@@ -78,22 +84,45 @@ install: build
        fi
 
 # Build architecture-independent files here.
-binary-indep: build install
-# We have nothing to do by default.
+binary-indep: DH_OPTIONS=-i
+binary-indep: build-doc install
+       dh_testdir
+       dh_testroot
+       # Extract LilyPond website tarball ...
+       tar -C $(r_doc)/$(d)/html -xvzf out/web.tar.gz
+       # Add symlinks to the PostScript docs and LilyPond logo PNGs ...
+       cd $(r_doc)/$(d) \
+           && cp -s `find html/Documentation -name '*.ps.gz'` . \
+           && cp -s html/Documentation/pictures/out-www/*.png .
+       # Copy the DVI docs too ...
+       cp -a `find Documentation -name '*.dvi' ! -name 'lily-[0-9]*.dvi'` \
+               $(r_doc)/$(d)/
+       dh_installdocs
+       dh_installchangelogs
+       dh_link
+       dh_compress -Xusr/share/doc/lilypond/html/
+       dh_fixperms
+       dh_installdeb
+       dh_gencontrol
+       dh_md5sums
+       dh_builddeb
 
+binary-arch: DH_OPTIONS=-a
 binary-arch: build install
        dh_testdir
        dh_testroot
        cp -av lilypond-mode.el lilypond-font-lock.el \
                $(r)/usr/share/emacs/site-lisp/
-       dh_installdocs DEDICATION NEWS ROADMAP TODO *.txt \
-               Documentation/pictures/out/*.png \
-               Documentation/out/*.txt \
-               Documentation/*/out/[a-z]*.dvi \
-               Documentation/*/out/*.ps
-       mkdir $(r)/$(d)/bibliography $(r)/$(d)/misc
-       cp -a Documentation/bibliography/*.bib $(r)/$(d)/bibliography/
-       cp -a Documentation/misc/[ACN]* $(r)/$(d)/misc/
+       dh_installdocs DEDICATION NEWS ROADMAP *.txt
+
+#      dh_installdocs DEDICATION NEWS ROADMAP *.txt \
+#              Documentation/pictures/out/*.png
+#              Documentation/out/*.txt
+#              $(DVI_FILES) $(PS_FILES)
+#      mkdir $(r)/$(d)/bibliography $(r)/$(d)/misc
+#      cp -a Documentation/bibliography/*.bib $(r)/$(d)/bibliography/
+#      cp -a Documentation/misc/[ACN]* $(r)/$(d)/misc/
+
 #      dh_installexamples input
        cp -aP `find input mutopia \( -name '*.*ly' -o -name '*.abc' -o -name '*.tex' -o -name 'TODO' \)` \
                $(r)/$(d)/examples
@@ -102,14 +131,13 @@ binary-arch: build install
 #      dh_installmenu
        dh_installemacsen
 #      dh_installcron
-#      dh_installmanpages
+#      dh_installman
 #      dh_undocumented
        dh_installchangelogs -k CHANGES
        dh_link
        dh_strip
        dh_compress
        dh_fixperms
-#      dh_suidregister
        dh_installdeb
        dh_shlibdeps
        dh_gencontrol