]> git.donarmstrong.com Git - lilypond.git/blobdiff - debian/rules
* tex/titledefs.tex: Avoid that the first score line is extra
[lilypond.git] / debian / rules
index 5a5ad205a2a958c23d9ae1077b5a1f75881575a0..c95956fbd1527b66f56ed386c86d740d2674e8d8 100644 (file)
@@ -7,7 +7,7 @@
 # Currently maintained by Anthony Fok <foka@debian.org>
 # for Debian GNU/Linux.
 
-package = lilypond1.7
+package = lilypond
 
 SHELL = /bin/sh
 r = debian/$(package)
@@ -34,7 +34,7 @@ export MAILADDRESS = lilypond@packages.debian.org
 #export DH_VERBOSE=1
 
 # This is the debhelper compatibility version to use.
-export DH_COMPAT=3
+export DH_COMPAT=4
 
 # This has to be exported to make some magic below work.
 export DH_OPTIONS
@@ -42,20 +42,25 @@ export DH_OPTIONS
 build: build-stamp
 build-stamp:
        dh_testdir
+
        ./configure --enable-checking --enable-debugging \
                --prefix=/usr --enable-optimise \
                --infodir='$${prefix}/share/info' \
                --mandir='$${prefix}/share/man'
        $(MAKE) MAKE_PFA_FILES=1
+
        touch build-stamp
 
 build-doc: build build-doc-stamp
 build-doc-stamp:
        dh_testdir
 
+       # make info
        $(MAKE) -C Documentation
+       # make html
        $(MAKE) web
-       find . -type d -name 'out-www' | xargs rm -rf
+       $(MAKE) -C Documentation/user omf
+#      find . -type d -name 'out-www' | xargs rm -rf
 
        touch build-doc-stamp
 
@@ -68,7 +73,6 @@ clean:
 
        # Still not clean enough?  Let's use... BRUTE STRENGTH!  :-)
        find . -type d -name 'out' -o -name 'out-www' | xargs rm -rf
-       rm -f debian/lilypond.links
 
        dh_clean
 
@@ -82,15 +86,21 @@ install: build
        dh_installdirs
        $(MAKE) prefix=$(PWD)/$(r)/usr MAKE_PFA_FILES=1 install
        # Ugh, remove hundred music-glossary copies
-       find . -name 'music-glossary.info-*' | xargs rm -f
+#      find . -name 'music-glossary.info-*' | xargs rm -f
+
+#      # Change from an absolute symlink to a relative symlink (Lintian)
+#      if [ -L $(r)/usr/share/lilypond/cmtfm ]; then \
+#              rm -f $(r)/usr/share/lilypond/cmtfm; \
+#              ln -s ../texmf/fonts/tfm/public/cm $(r)/usr/share/lilypond/cmtfm; \
+#      fi
 
 # Build architecture-independent files here.
 binary-indep: DH_OPTIONS=-i
 binary-indep: build-doc install
        dh_testdir
        dh_testroot
-       # Extract LilyPond website tarball ...
-       tar -C $(r_doc)/$(d)/html -xvzf out/web.tar.gz
+       # Install LilyPond web documentation...
+       $(MAKE) prefix=$(PWD)/$(r_doc)/usr webdir=$(PWD)/$(r_doc)/$(d)/html out=www web-install
        # Add symlinks to the PostScript docs and LilyPond logo PNGs ...
        cd $(r_doc)/$(d) \
            && cp -s `find html/Documentation -name '*.ps.gz'` . \
@@ -112,10 +122,8 @@ binary-arch: DH_OPTIONS=-s
 binary-arch: build install
        dh_testdir
        dh_testroot
-       cp -av lilypond-mode.el lilypond-font-lock.el lilypond-indent.el \
-               lilypond.words \
-               $(r)/usr/share/emacs/site-lisp/
-       dh_installdocs DEDICATION ROADMAP *.txt
+       dh_installdocs AUTHORS.txt NEWS.txt README.txt \
+               DEDICATION THANKS 
 
 #      dh_installdocs DEDICATION NEWS ROADMAP *.txt \
 #              Documentation/pictures/out/*.png
@@ -126,12 +134,15 @@ binary-arch: build install
 #      cp -a Documentation/misc/[ACN]* $(r)/$(d)/misc/
 
 #      dh_installexamples input
-#      find input \( -name '*.*ly' -o -name '*.abc' -o -name '*.tex' -o -name 'TODO' \) \
-#              -exec cp -a --parents '{}' $(r)/$(d)/examples ';'
+
+       find input \( -name '*.*ly' -o -name '*.abc' -o -name '*.tex' -o -name 'TODO' \) ! -regex '.*/out-www/.*' \
+               -exec cp -a --parents '{}' $(r)/$(d)/examples ';'
 #      for i in `find $(r)/$(d)/examples/ -type d -name out`; do \
 #              mv -fv $$i/* $$i/..; rmdir $$i; done
+
 #      dh_installmenu
        dh_installemacsen
+       dh_scrollkeeper
 #      dh_installcron
 #      dh_installman
 #      dh_undocumented
@@ -147,6 +158,8 @@ binary-arch: build install
                        usr/share/texmf/fonts/afm/public/lilypond \
                usr/share/lilypond/$(VERSION)/fonts/tfm \
                        usr/share/texmf/fonts/tfm/public/lilypond \
+               usr/share/lilypond/$(VERSION)/fonts/type1 \
+                       usr/share/texmf/fonts/type1/public/lilypond \
                etc/texmf/dvips/lilypond.map \
                        usr/share/lilypond/$(VERSION)/dvips/lilypond.map
        dh_strip