]> git.donarmstrong.com Git - lilypond.git/blobdiff - debian/rules
Fix bad Recommends on texlive-latex-base (Closes: #594403)
[lilypond.git] / debian / rules
index 8075ae357bd0a9a6a1992e6e007cf6cde3e338b6..ac50d8b899cca72ac29b52150cafd620897f08e5 100755 (executable)
@@ -59,14 +59,7 @@ build-stamp:
                --infodir='$${prefix}/share/info' \
                --mandir='$${prefix}/share/man'
        $(MAKE)
-       # ignore test failures on architectures which aren't i386 or
-       # amd64 until we properly fix failures when /dev/tty doesn't
-       # exist (#572290)
-       if dpkg-architecture -eamd64 || dpkg-architecture -ei386; then \
-               $(MAKE) test; \
-       else \
-               $(MAKE) test || true; \
-        fi;
+       $(MAKE) test;
 
        touch build-stamp
 
@@ -130,15 +123,10 @@ binary-indep: build-doc install
                -type d -empty -delete
        dh_installemacsen
 
-       #find input \( -name '*.*ly' -o -name '*.abc' -o -name '*.tex' -o -name 'TODO' \) ! -regex '.*/out-www/.*' \
-       #       -exec cp -a --parents '{}' $(r_data)/$(d)/examples ';'
        install -m 644 debian/xiao-haizi-guai-guai.ly debian/sakura-sakura.ly \
                $(r_data)/$(d)/examples
        dh_installchangelogs
 
-#      mv $(r_data)/usr/share/lilypond/$(VERSION)/fonts/map/lilypond.map \
-#         $(r_data)/etc/texmf/dvips/lilypond.map
-
        dh_link usr/share/lilypond/$(VERSION)/tex \
                        usr/share/texmf/tex/lilypond \
                usr/share/lilypond/$(VERSION)/fonts/source \
@@ -173,6 +161,7 @@ binary-arch: build install
        dh_installchangelogs Documentation/misc/CHANGES* Documentation/misc/ChangeLog*
 
        dh_strip
+       dh_pysupport /usr/share/lilypond/${VERSION}/python
        dh_compress
        dh_fixperms
        dh_installdeb