]> git.donarmstrong.com Git - lilypond.git/blobdiff - debian/rules
Replace removed fonts ttf-kochi-gothic and ttf-kochi-mincho with fonts-ipafont-gothic...
[lilypond.git] / debian / rules
index 65219ebcc6dd852407073ff1fcf53d02eeb455e8..87828fafdde40af6853e82376283835270d092d1 100755 (executable)
@@ -9,10 +9,6 @@ include VERSION
 
 export MAILADDRESS = lilypond@packages.debian.org
 
-# fontconfig blows chunks if it can't write to $HOME; and some
-# buildds set it to a bogus value.
-export HOME = /tmp
-
 DEB_HOST_ARCH ?= $(shell dpkg-architecture -qDEB_HOST_ARCH)
 CFLAGS := $(shell dpkg-buildflags --get CFLAGS)
 CXXFLAGS := $(shell dpkg-buildflags --get CXXFLAGS)
@@ -29,23 +25,19 @@ endif
 endif
 
 DOC_OPTIONS := WEB_TARGETS="offline"
-ifneq (,$(filter $(shell dpkg-architecture -qDEB_HOST_ARCH), amd64)) 
 ifneq (,$(filter parallel=%,$(DEB_BUILD_OPTIONS)))
        DOC_OPTIONS := $(DOC_OPTIONS) CPU_COUNT=$(firstword $(patsubst parallel=%,%,$(filter parallel=%,$(DEB_BUILD_OPTIONS))))
-PARALLEL_OPTION := "--parallel"
-endif
-else
-PARALLEL_OPTION :=
 endif
 
 %:
-       dh $@ $(PARALLEL_OPTION) --with autotools-dev --with python2 --with quilt
+       dh $@ --parallel --with autotools-dev --with python2 --with quilt
 
 ## we need to nuke the parser files, because if there is a mistmatch
 ## between upstreams bison and our bison, the build will fail epically
 override_dh_auto_configure:
        rm -f lily/out/parser.*
-       dh_auto_configure -- --disable-checking --enable-debugging $(config_opt)
+       ./autogen.sh --noconfigure
+       dh_auto_configure -- --disable-checking --enable-debugging --enable-guile2 $(config_opt)
 
 override_dh_auto_build-indep:
        dh_auto_build
@@ -113,6 +105,12 @@ override_dh_installdocs:
                install -m0644 $$a debian/$$package/usr/share/doc-base/$$package; \
        done;
 
+override_dh_auto_test:
+ifneq (,$(filter $(DEB_BUILD_OPTIONS),nocheck))
+       $(MAKE) test-baseline
+    $(MAKE) test
+endif
+
 ## this rule will update debian/control and the per-language install
 ## files; all of the files it generates/modifies should be included in
 ## the Debian package and should not need to be regenerated or