]> git.donarmstrong.com Git - lilypond.git/blobdiff - debian/rules
(binary-indep): Link images for info.
[lilypond.git] / debian / rules
index ea2e3f7f626356b2a8eec1bab69d3c26a4d7bc9e..5089a866c601e2eb5dfc54fc0c5f460b9d03227f 100644 (file)
@@ -1,6 +1,5 @@
 #!/usr/bin/make -f
-# Made with the aid of debhelper by Joey Hess,
-# based on the sample debian/rules file for GNU hello by Ian Jackson.
+# debian/rules for LilyPond in Debian.
 #
 # This is free software; see the GNU General Public Licence
 # version 2 or later for copying conditions.  There is NO warranty.
@@ -12,13 +11,23 @@ package = lilypond
 
 SHELL = /bin/sh
 r = debian/$(package)
+r_data = debian/$(package)-data
 r_doc = debian/$(package)-doc
+
+# FIXME: /usr
 d = usr/share/doc/$(package)
+info = /usr/share/info/$(package)
+
+include VERSION
+VERSION = $(MAJOR_VERSION).$(MINOR_VERSION).$(PATCH_LEVEL)
 
 # "main_memory = 263000" in /etc/texmf/texmf.cnf isn't large enough
 # for latex to process standchen.dvi.latex, so adding extra_mem_* ...
-export extra_mem_top = 100000
-export extra_mem_bot = 100000
+# export extra_mem_top = 100000
+# export extra_mem_bot = 100000
+# But now, building lilypond.dvi requires increased pool_size (2002-02-18)
+# export pool_size = 500000
+# But now, it seems that none of the above is needed in 1.4.11  (2002-02-24)
 export MODE = ljfour
 export BDPI = 600
 export USER_CFLAGS = -DDEBIAN
@@ -28,9 +37,6 @@ export MAILADDRESS = lilypond@packages.debian.org
 # Uncomment this to turn on verbose mode.
 #export DH_VERBOSE=1
 
-# This is the debhelper compatibility version to use.
-export DH_COMPAT=3
-
 # This has to be exported to make some magic below work.
 export DH_OPTIONS
 
@@ -38,11 +44,11 @@ build: build-stamp
 build-stamp:
        dh_testdir
 
-       ./configure --enable-checking --disable-debugging \
-               --prefix=/usr --enable-optimise \
+       ./configure --disable-checking --enable-debugging \
+               --prefix=/usr --enable-optimising \
                --infodir='$${prefix}/share/info' \
                --mandir='$${prefix}/share/man'
-       $(MAKE) MAKE_PFA_FILES=1
+       $(MAKE)
 
        touch build-stamp
 
@@ -50,8 +56,12 @@ build-doc: build build-doc-stamp
 build-doc-stamp:
        dh_testdir
 
+       # make info
        $(MAKE) -C Documentation
+       # make html
        $(MAKE) web
+       $(MAKE) -C Documentation/user omf
+#      find . -type d -name 'out-www' | xargs rm -rf
 
        touch build-doc-stamp
 
@@ -64,6 +74,11 @@ clean:
 
        # Still not clean enough?  Let's use... BRUTE STRENGTH!  :-)
        find . -type d -name 'out' -o -name 'out-www' | xargs rm -rf
+       rm -f lib/lilypond/python examples.html
+       rm -f debian/emacsen-startup
+       rm -f debian/lilypond1.7*.dirs debian/lilypond.dirs
+       rm -f debian/postinst debian/prerm debian/postrm
+       rm -f debian/lilypond-data.doc-base debian/lilypond.doc-base
 
        dh_clean
 
@@ -72,48 +87,73 @@ install: build
        dh_testdir
        dh_testroot
        dh_clean -k
+       dh_installdirs
 
        # Add here commands to install the package into debian/tmp.
-       dh_installdirs
-       $(MAKE) prefix=$(PWD)/$(r)/usr  MAKE_PFA_FILES=1 install
+       $(MAKE) install prefix=$(CURDIR)/debian/tmp/usr
+
+       dh_install --sourcedir=debian/tmp --list-missing
 
-       # Change from an absolute symlink to a relative symlink (Lintian)
-       if [ -L $(r)/usr/share/lilypond/cmtfm ]; then \
-               rm -f $(r)/usr/share/lilypond/cmtfm; \
-               ln -s ../texmf/fonts/tfm/public/cm $(r)/usr/share/lilypond/cmtfm; \
-       fi
+#      # Change from an absolute symlink to a relative symlink (Lintian)
+#      if [ -L $(r)/usr/share/lilypond/cmtfm ]; then \
+#              rm -f $(r)/usr/share/lilypond/cmtfm; \
+#              ln -s ../texmf/fonts/tfm/public/cm $(r)/usr/share/lilypond/cmtfm; \
+#      fi
 
 # Build architecture-independent files here.
 binary-indep: DH_OPTIONS=-i
 binary-indep: build-doc install
        dh_testdir
        dh_testroot
-       # Extract LilyPond website tarball ...
-       tar -C $(r_doc)/$(d)/html -xvzf out/web.tar.gz
-       # Add symlinks to the PostScript docs and LilyPond logo PNGs ...
+       # Install LilyPond web documentation...
+       $(MAKE) prefix=$(PWD)/$(r_doc)/usr webdir=$(PWD)/$(r_doc)/$(d)/html out=www web-install
+       # Add symlinks to the PostScript docs and LilyPond logo PNGs for HTML...
        cd $(r_doc)/$(d) \
            && cp -s `find html/Documentation -name '*.ps.gz'` . \
            && cp -s html/Documentation/pictures/out-www/*.png .
-       # Copy the DVI docs too ...
-       cp -a `find Documentation -name '*.dvi' ! -name 'lily-[0-9]*.dvi'` \
-               $(r_doc)/$(d)/
+       # Add symlinks to the PostScript docs and LilyPond logo PNGs for info...
+       cd $(r_doc)/$(info) \
+           && cp -s ../../doc/$(package)/html/Documentation/user/out-www/*.png .
+#      # Copy the DVI docs too ...
+#      cp -a `find Documentation -name '*.dvi' ! -name 'lily-[0-9]*.dvi'` \
+#              $(r_doc)/$(d)/
        dh_installdocs
+       dh_installemacsen
+       dh_scrollkeeper
+
+       find input \( -name '*.*ly' -o -name '*.abc' -o -name '*.tex' -o -name 'TODO' \) ! -regex '.*/out-www/.*' \
+               -exec cp -a --parents '{}' $(r_data)/$(d)/examples ';'
        dh_installchangelogs
-       dh_link
-       dh_compress -Xusr/share/doc/lilypond/html/
+
+       mv $(r_data)/usr/share/lilypond/$(VERSION)/dvips/lilypond.map \
+          $(r_data)/etc/texmf/dvips/lilypond.map
+
+       dh_link usr/share/lilypond/$(VERSION)/tex \
+                       usr/share/texmf/tex/lilypond \
+               usr/share/lilypond/$(VERSION)/fonts/source \
+                       usr/share/texmf/fonts/source/public/lilypond \
+               usr/share/lilypond/$(VERSION)/fonts/afm \
+                       usr/share/texmf/fonts/afm/public/lilypond \
+               usr/share/lilypond/$(VERSION)/fonts/tfm \
+                       usr/share/texmf/fonts/tfm/public/lilypond \
+               usr/share/lilypond/$(VERSION)/fonts/type1 \
+                       usr/share/texmf/fonts/type1/public/lilypond \
+               etc/texmf/dvips/lilypond.map \
+                       usr/share/lilypond/$(VERSION)/dvips/lilypond.map
+
+       dh_compress -X$(d)/html/
        dh_fixperms
        dh_installdeb
        dh_gencontrol
        dh_md5sums
        dh_builddeb
 
-binary-arch: DH_OPTIONS=-a
+binary-arch: DH_OPTIONS=-s
 binary-arch: build install
        dh_testdir
        dh_testroot
-       cp -av lilypond-mode.el lilypond-font-lock.el lilypond-indent.el \
-               $(r)/usr/share/emacs/site-lisp/
-       dh_installdocs DEDICATION NEWS ROADMAP *.txt
+       dh_installdocs AUTHORS.txt NEWS.txt README.txt \
+               DEDICATION THANKS 
 
 #      dh_installdocs DEDICATION NEWS ROADMAP *.txt \
 #              Documentation/pictures/out/*.png
@@ -124,17 +164,18 @@ binary-arch: build install
 #      cp -a Documentation/misc/[ACN]* $(r)/$(d)/misc/
 
 #      dh_installexamples input
-       cp -aP `find input mutopia \( -name '*.*ly' -o -name '*.abc' -o -name '*.tex' -o -name 'TODO' \)` \
-               $(r)/$(d)/examples
-       for i in `find $(r)/$(d)/examples/ -type d -name out`; do \
-               mv -fv $$i/* $$i/..; rmdir $$i; done
+
+#      for i in `find $(r)/$(d)/examples/ -type d -name out`; do \
+#              mv -fv $$i/* $$i/..; rmdir $$i; done
+
 #      dh_installmenu
        dh_installemacsen
+       dh_scrollkeeper
 #      dh_installcron
 #      dh_installman
 #      dh_undocumented
-       dh_installchangelogs -k CHANGES
-       dh_link
+       dh_installchangelogs ChangeLog
+
        dh_strip
        dh_compress
        dh_fixperms