]> git.donarmstrong.com Git - lilypond.git/blobdiff - debian/rules
release: 1.0.17
[lilypond.git] / debian / rules
old mode 100644 (file)
new mode 100755 (executable)
index f0d60cf..3a78b27
@@ -8,9 +8,10 @@
 # Currently maintained by Anthony Fok <foka@debian.org>
 # for Debian GNU/Linux.
 
-package=lilypond
-
-SHELL=/bin/bash
+package = lilypond
+SHELL = /bin/sh
+r = debian/tmp
+d = usr/doc/$(package)
 
 # Uncomment this to turn on verbose mode.
 #export DH_VERBOSE=1
@@ -18,53 +19,93 @@ SHELL=/bin/bash
 build: build-stamp
 build-stamp:
        dh_testdir
-       ./configure --disable-checking --disable-debugging \
+
+       CC=egcc ./configure --disable-checking --disable-debugging \
                --enable-printing --prefix=/usr --enable-optimise \
                --enable-shared
-       make all
+       $(MAKE) all
+       # $(MAKE) htmldoc
+
        touch build-stamp
 
 clean:
        dh_testdir
        dh_testroot
-       rm -f build-stamp
+       rm -f build-stamp install-stamp
        -$(MAKE) distclean
-       # Don't put dh_clean before "make distclean"!  dh_clean is
-       # "too smart" and it deletes too many files!
+
+       # Correct the owner of the out/dummy.dep files when built with sudo.
+       if [ -n "$$SUDO_USER" -a -n "$$SUDO_GID" ]; then \
+               find . -user root | xargs -r chown $$SUDO_USER.$$SUDO_GID; \
+       else \
+               find . -user root | xargs -r chown $$LOGNAME; \
+       fi
+
+       # Remove the following line once the *.make files are fixed
+       rm -f stepmake/bin/*.pyc
+       rm -f stepmake/stepmake/stepmake
+       rm -f stepmake/stepmake/bin
+       rm -f GNUmakefile stepmake/GNUmakefile
+       rm -f config.h
+       rm -f wwwlist
+
        dh_clean
-       rm -f {,*/}out/{*,.build} flower/config.{log,status}
+
+install: install-stamp
+install-stamp: build-stamp
+       dh_testdir
+       dh_testroot
+       dh_clean -k
+       dh_installdirs usr/lib/texmf/doc \
+               usr/lib/emacs/site-lisp \
+               usr/doc/$(package)/examples
+       ln -fs ../../../doc/lilypond $(r)/usr/lib/texmf/doc/lilypond
+
+       $(MAKE) prefix=`pwd`/$(r)/usr install
+
+       touch install-stamp
 
 # Build architecture-independent files here.
-binary-indep: build
+binary-indep: build install
 # We have nothing to do by default.
 
-binary-arch: build
+binary-arch: build install
        dh_testdir
        dh_testroot
-       dh_installdirs usr/lib/texmf/doc
-       $(MAKE) prefix=`pwd`/debian/tmp/usr install
-       ln -fs ../../../doc/lilypond debian/tmp/usr/lib/texmf/doc/lilypond
-       dh_installdocs ANNOUNCE ANNOUNCE-0.1 README NEWS ONEWS DEDICATION \
-               BUGS TODO \
-               Documentation/out/*.text Documentation/*.doc \
-               Documentation/lelie_logo.xpm bin/ly2dvi.sh
-       dh_installexamples input/*.ly input/*.tex
+       cp -av mudela-mode.el $(r)/usr/lib/emacs/site-lisp
+       dh_installdocs ANNOUNCEMENT ANNOUNCE-0.1 NEWS* DEDICATION \
+               BUGS TODO *.txt \
+               Documentation/pictures/*.xpm \
+               Documentation/out/*.txt \
+               Documentation/tex/*.doc \
+               Documentation/tex/*.bib
+#      dh_installexamples input
+       cp -aP `find input mutopia \( -name '*.ly' -o -name '*.tex' -o -name 'TODO' \)` \
+               $(r)/$(d)/examples
+       for i in `find $(r)/$(d)/examples/ -type d -name out`; do \
+               mv -fv $$i/* $$i/..; rmdir $$i; done
 #      dh_installmenu
+#      dh_installemacsen
 #      dh_installcron
 #      dh_installmanpages
 #      dh_undocumented
        dh_installchangelogs
-       dh_strip
+#      dh_strip
        dh_compress
+       ( cd $(r)/$(d) && \
+               if [ -f NEWS ]; then gzip -9vf NEWS; fi )
+       ln -s NEWS.gz $(r)/$(d)/changelog.gz
        dh_fixperms
        dh_suidregister
        dh_installdeb
        dh_shlibdeps
        dh_gencontrol
 #      dh_makeshlibs
-       dh_du
        dh_md5sums
        dh_builddeb
 
+source diff:
+       @echo >&2 'source and diff are obsolete - use dpkg-source -b'; false
+
 binary: binary-indep binary-arch
-.PHONY: build clean binary-indep binary-arch binary
+.PHONY: build clean install binary-indep binary-arch binary