]> git.donarmstrong.com Git - lilypond.git/blobdiff - debian/rules
release: 1.1.33
[lilypond.git] / debian / rules
old mode 100644 (file)
new mode 100755 (executable)
index f0d60cf..38207ca
@@ -8,9 +8,24 @@
 # Currently maintained by Anthony Fok <foka@debian.org>
 # for Debian GNU/Linux.
 
-package=lilypond
+package = lilypond
 
-SHELL=/bin/bash
+SHELL = /bin/sh
+r = debian/tmp
+d = usr/doc/$(package)
+
+strayfiles := stepmake/bin/*.pyc \
+       stepmake/stepmake/stepmake \
+       stepmake/stepmake/bin \
+       stepmake/stepmake/aclocal.m4 \
+       stepmake/GNUmakefile \
+       GNUmakefile \
+       config.h \
+       wwwlist \
+       Documentation/tex/fonts.aux \
+       Documentation/tex/fonts.log \
+       Documentation/tex/feta*.tfm \
+       Documentation/tex/feta*.*pk
 
 # Uncomment this to turn on verbose mode.
 #export DH_VERBOSE=1
@@ -18,43 +33,84 @@ SHELL=/bin/bash
 build: build-stamp
 build-stamp:
        dh_testdir
-       ./configure --disable-checking --disable-debugging \
-               --enable-printing --prefix=/usr --enable-optimise \
+
+       CC=egcc ./configure --disable-checking --disable-debugging \
+               --enable-printing --prefix=/usr --disable-optimise \
                --enable-shared
-       make all
+       $(MAKE) all
+       # $(MAKE) htmldoc
+
+       # Remove the "-" and the "-k" once the \times segfault
+       # bug is fixed.  (lilypond-1.1.31, 1999-02-17)
+       -$(MAKE) -k -C Documentation/tex dvi
+
        touch build-stamp
 
 clean:
        dh_testdir
        dh_testroot
-       rm -f build-stamp
+       rm -f build-stamp install-stamp
        -$(MAKE) distclean
-       # Don't put dh_clean before "make distclean"!  dh_clean is
-       # "too smart" and it deletes too many files!
        dh_clean
-       rm -f {,*/}out/{*,.build} flower/config.{log,status}
+
+       # Remove the following line once the *.make files are fixed
+       rm -f $(strayfiles)
+
+       # Correct the owner of the out/dummy.dep files when built with sudo.
+       if [ -n "$$SUDO_USER" -a -n "$$SUDO_GID" ]; then \
+               find . -user root | xargs -r chown --dereference $$SUDO_USER.$$SUDO_GID; \
+       fi
+
+install: install-stamp
+install-stamp: build-stamp
+       dh_testdir
+       dh_testroot
+       dh_clean -k
+       dh_installdirs usr/doc/texmf \
+               usr/lib/emacs/site-lisp \
+               usr/doc/$(package)/examples \
+               usr/lib/texmf/tex \
+               usr/lib/texmf/fonts/source/public \
+               usr/lib/texmf/fonts/afm/public \
+               usr/lib/texmf/fonts/tfm/public
+       ln -fs ../lilypond $(r)/usr/doc/texmf/lilypond
+
+       $(MAKE) prefix=`pwd`/$(r)/usr install
+
+       ln -s ../../../share/lilypond/tex $(r)/usr/lib/texmf/tex/lilypond
+       ln -s ../../../../../share/lilypond/mf $(r)/usr/lib/texmf/fonts/source/public/lilypond
+       ln -s ../../../../../share/lilypond/afm $(r)/usr/lib/texmf/fonts/afm/public/lilypond
+       ln -s ../../../../../share/lilypond/afm $(r)/usr/lib/texmf/fonts/tfm/public/lilypond
+
+       touch install-stamp
 
 # Build architecture-independent files here.
-binary-indep: build
+binary-indep: build install
 # We have nothing to do by default.
 
-binary-arch: build
+binary-arch: build install
        dh_testdir
        dh_testroot
-       dh_installdirs usr/lib/texmf/doc
-       $(MAKE) prefix=`pwd`/debian/tmp/usr install
-       ln -fs ../../../doc/lilypond debian/tmp/usr/lib/texmf/doc/lilypond
-       dh_installdocs ANNOUNCE ANNOUNCE-0.1 README NEWS ONEWS DEDICATION \
-               BUGS TODO \
-               Documentation/out/*.text Documentation/*.doc \
-               Documentation/lelie_logo.xpm bin/ly2dvi.sh
-       dh_installexamples input/*.ly input/*.tex
+       cp -av mudela-mode.el $(r)/usr/lib/emacs/site-lisp
+       dh_installdocs ANNOUNCEMENT ANNOUNCE-0.1 NEWS-* DEDICATION \
+               BUGS TODO *.txt \
+               Documentation/pictures/*.xpm \
+               Documentation/out/*.txt \
+               Documentation/tex/*.doc \
+               Documentation/tex/*.bib \
+               Documentation/tex/out/*.dvi
+#      dh_installexamples input
+       cp -aP `find input mutopia \( -name '*.ly' -o -name '*.tex' -o -name 'TODO' \)` \
+               $(r)/$(d)/examples
+       for i in `find $(r)/$(d)/examples/ -type d -name out`; do \
+               mv -fv $$i/* $$i/..; rmdir $$i; done
 #      dh_installmenu
+#      dh_installemacsen
 #      dh_installcron
 #      dh_installmanpages
 #      dh_undocumented
-       dh_installchangelogs
-       dh_strip
+       dh_installchangelogs -k NEWS
+#      dh_strip
        dh_compress
        dh_fixperms
        dh_suidregister
@@ -62,9 +118,11 @@ binary-arch: build
        dh_shlibdeps
        dh_gencontrol
 #      dh_makeshlibs
-       dh_du
        dh_md5sums
        dh_builddeb
 
+source diff:
+       @echo >&2 'source and diff are obsolete - use dpkg-source -b'; false
+
 binary: binary-indep binary-arch
-.PHONY: build clean binary-indep binary-arch binary
+.PHONY: build clean install binary-indep binary-arch binary