]> git.donarmstrong.com Git - lilypond.git/blobdiff - debian/rules
release: 1.3.120
[lilypond.git] / debian / rules
index b3aa3e63918de33586773aabda6a3b49c18b2e50..07880f23a6a81f56a7b1817b4ff5b9054c27aea8 100755 (executable)
 package = lilypond1.3
 
 SHELL = /bin/sh
-r = debian/tmp
-TMP = `pwd`/debian/tmp
+r = debian/$(package)
+TMP = `pwd`/$(r)
 d = usr/share/doc/$(package)
 
 # Uncomment this to turn on verbose mode.
 #export DH_VERBOSE=1
 
 # This is the debhelper compatibility version to use.
-export DH_COMPAT=1
+export DH_COMPAT=2
 
 build: build-stamp
 build-stamp:
@@ -42,8 +42,6 @@ clean:
        dh_testroot
        rm -f build-stamp
        -$(MAKE) distclean
-       # Remove obsolete files which are still in the upstream tarball (1.3.42)
-       rm -f debian/control.in debian/doc-base debian/prerm
        dh_clean
 
        # Correct the owner of the out/dummy.dep files when built with sudo.
@@ -82,6 +80,7 @@ binary-indep: build install
 # We have nothing to do by default.
 
 binary-arch: build install
+       dh_testversion 2
        dh_testdir
        dh_testroot
        cp -av lilypond-mode.el lilypond-font-lock.el \
@@ -104,13 +103,7 @@ binary-arch: build install
 #      dh_installcron
 #      dh_installmanpages
 #      dh_undocumented
-#      dh_installchangelogs -k CHANGES
-#      dh_installchangelogs CHANGES
-# These give all errrors.
-# Strange, in the maint-guide, it says add the upstream changelog name.
-# Let's install as doc, then.  --jcn
-       dh_installdocs CHANGES
-       dh_installchangelogs
+       dh_installchangelogs -k CHANGES
        dh_link
        dh_strip
        dh_compress