]> git.donarmstrong.com Git - lilypond.git/blobdiff - debian/rules
Remove unneeded --parallel options from debhelper calls
[lilypond.git] / debian / rules
index f567568063f0030aaf886fd9bc4506d484f4312f..0139b9d0183f6f901a1198e230ca50fc06b42c7f 100755 (executable)
@@ -10,6 +10,7 @@ include VERSION
 export MAILADDRESS = lilypond@packages.debian.org
 
 DEB_HOST_ARCH ?= $(shell dpkg-architecture -qDEB_HOST_ARCH)
+DEB_HOST_MULTIARCH ?= $(shell dpkg-architecture -qDEB_HOST_MULTIARCH)
 CFLAGS := $(shell dpkg-buildflags --get CFLAGS)
 CXXFLAGS := $(shell dpkg-buildflags --get CXXFLAGS)
 ifneq (,$(filter $(DEB_HOST_ARCH), i386 kfreebsd-i386))
@@ -27,20 +28,86 @@ endif
 DOC_OPTIONS := WEB_TARGETS="offline"
 ifneq (,$(filter parallel=%,$(DEB_BUILD_OPTIONS)))
        DOC_OPTIONS := $(DOC_OPTIONS) CPU_COUNT=$(firstword $(patsubst parallel=%,%,$(filter parallel=%,$(DEB_BUILD_OPTIONS))))
+       guile_make_args := -j$(firstword $(patsubst parallel=%,%,$(filter parallel=%,$(DEB_BUILD_OPTIONS))))
 endif
 
+########################################################################
+# START: Definitions from the old guile-1.8 (1.8.8+1-10) package
+########################################################################
+
+# These are used for cross-compiling and for saving the configure script
+# from having to guess our platform (since we know it already)
+DEB_HOST_GNU_TYPE   ?= $(shell dpkg-architecture -qDEB_HOST_GNU_TYPE)
+DEB_BUILD_GNU_TYPE  ?= $(shell dpkg-architecture -qDEB_BUILD_GNU_TYPE)
+
+ifeq (alpha,$(shell dpkg-architecture -qDEB_HOST_ARCH))
+  # The -O2 option breaks make check on alpha right now.
+  guile_deb_cflags := -Os -g
+else ifeq (sh4,$(shell dpkg-architecture -qDEB_HOST_ARCH))
+  # Renesas SH(sh4) needs -mieee.  Without it, test-conversion fails.
+  # (Bug: 531378)
+  guile_deb_cflags := -O2 -g -mieee
+else
+  guile_deb_cflags := -O2 -g
+endif
+
+ifneq (,$(findstring debug,$(DEB_BUILD_OPTIONS)))
+       CFLAGS += -g
+endif
+ifeq (,$(findstring nostrip,$(DEB_BUILD_OPTIONS)))
+       INSTALL_PROGRAM += -s
+endif
+
+guile_configure_args = \
+  --host=$(DEB_HOST_GNU_TYPE) \
+  --build=$(DEB_BUILD_GNU_TYPE) \
+  --with-threads=no \
+  --disable-error-on-warning \
+  --prefix=/usr
+
+ifeq (hurd-i386,$(shell dpkg-architecture -qDEB_HOST_ARCH))
+  guile_configure_args += LIBS=-lpthread
+endif
+
+########################################################################
+# END: Definitions from the old guile-1.8 (1.8.8+1-10) package
+########################################################################
+
+export PATH := $(CURDIR)/out/guile/usr/bin:$(PATH)
+export LD_LIBRARY_PATH := $(CURDIR)/out/guile/usr/lib:$(LD_LIBRARY_PATH)
+export GUILE_LOAD_PATH := $(CURDIR)/out/guile/usr/share/guile/1.8
+export LILYPOND_VERSION := $(MAJOR_VERSION).$(MINOR_VERSION).$(PATCH_LEVEL)
+
+%.reloc: %.reloc.in
+       sed < $< > $@ \
+               -e 's!@LILYPOND_VERSION@!$(LILYPOND_VERSION)!g'
+
+%.sh: %.sh.in
+       sed < $< > $@ \
+               -e 's!@DEB_HOST_MULTIARCH@!$(DEB_HOST_MULTIARCH)!g' \
+               -e 's!@LILYPOND_VERSION@!$(LILYPOND_VERSION)!g'
+
+# Do not use debhelper's autoreconf, the build currently
+# fails with this option and we take care of that
+# ourselves anyway.
 %:
-       dh $@ --parallel --with autotools-dev --with python2 --with quilt
+       dh $@ --without autoreconf --with python2 --with quilt
 
 ## we need to nuke the parser files, because if there is a mismatch
 ## between upstreams bison and our bison, the build will fail epically
 override_dh_auto_configure:
+       $(eval unexport GUILE_LOAD_PATH)
+       cd guile18 && ./autogen.sh
+       cd guile18 && CFLAGS="$(guile_deb_cflags)" ./configure ${guile_configure_args}
+       cd guile18 && $(MAKE) ${guile_make_args}
+       $(MAKE) -C guile18 install DESTDIR=$(CURDIR)/out/guile
        rm -f lily/out/parser.*
        ./autogen.sh --noconfigure
-       dh_auto_configure -- --disable-checking --enable-debugging --enable-guile2 $(config_opt)
+       GUILE_LOAD_PATH="$(GUILE_LOAD_PATH)" \
+               dh_auto_configure -- --disable-checking --enable-debugging $(config_opt)
 
 override_dh_auto_build-indep:
-       dh_auto_build -i -O--parallel
+       dh_auto_build -i
        $(MAKE) doc $(DOC_OPTIONS)
 
 ## Unfortunately, lilypond is kind of broken, and installs the wrong
@@ -48,15 +115,17 @@ override_dh_auto_build-indep:
 ## directly. They also don't provide an install rule which doesn't
 ## install the documentation, which we don't care about for the
 ## architecture dependent build
-override_dh_auto_install-arch:
+override_dh_auto_install-arch: debian/lilypond.sh debian/lilypond-invoke-editor.sh
        for dir in `echo */*makefile|xargs -n 1 dirname|grep -v Documentation`; do \
                $(MAKE) --no-builtin-rules PACKAGE=LILYPOND package=lilypond -C $$dir install $(DOC_OPTIONS) prefix=$(CURDIR)/debian/tmp/usr/; \
        done
+       sed -i -e '1s!$(CURDIR)/out/guile/usr/bin/guile!/usr/bin/guile!' \
+               debian/tmp/usr/bin/lilypond-invoke-editor
 
 ## We need the non-Documentation arch-independent files installed by
 ## the arch-dependent "$(MAKE) install" too, hence the dependency
 ## on override_dh_auto_install-arch
-override_dh_auto_install-indep: override_dh_auto_install-arch
+override_dh_auto_install-indep: override_dh_auto_install-arch debian/guile.reloc
        $(MAKE) install-doc $(DOC_OPTIONS) prefix=$(CURDIR)/debian/tmp/usr/
        $(MAKE) install-info $(DOC_OPTIONS) prefix=$(CURDIR)/debian/tmp/usr
        rm -rf $(CURDIR)/debian/tmp/usr/share/omf
@@ -68,11 +137,12 @@ override_dh_auto_install-indep: override_dh_auto_install-arch
 ## we need to nuke the parser files, because if there is a mismatch
 ## between upstreams bison and our bison, the build will fail epically
 override_dh_auto_clean:
+       [ ! -f guile18/Makefile ] || $(MAKE) -C guile18 maintainer-clean
        rm -f lily/out/parser.*
        dh_auto_clean --no-parallel
 
 override_dh_install-arch:
-       dh_install -a -O--parallel --list-missing
+       dh_install -a --list-missing
 
 ## we need to install only the png, jpg, css, ly and english html
 ## files into the doc-html package, and only the english pdfs into the
@@ -94,7 +164,7 @@ override_dh_install-indep:
        find $(CURDIR)/debian/tmp/ -type f \
                -regex '.*usr/share/doc/lilypond/.*/[^\.]+.preview.pdf' \
                -printf '%P\n' >> $(CURDIR)/debian/lilypond-doc-pdf.install
-       dh_install -i -O--parallel --list-missing
+       dh_install -i --list-missing
 
 override_dh_python2:
        dh_python2 --verbose
@@ -111,8 +181,16 @@ override_dh_installdocs:
                install -m0644 $$a debian/$$package/usr/share/doc-base/$$package; \
        done
 
-override_dh_auto_test:
-ifneq (,$(filter $(DEB_BUILD_OPTIONS),nocheck))
+override_dh_shlibdeps-arch:
+       $(eval unexport LD_LIBRARY_PATH)
+       dh_shlibdeps -a -lusr/lib/$(DEB_HOST_MULTIARCH)/lilypond/$(LILYPOND_VERSION)/guile
+
+# Skip tests for architecture-dependent-only build because
+# the test would fail without built documentation.
+override_dh_auto_test-arch:
+
+override_dh_auto_test-indep:
+ifeq (,$(filter $(DEB_BUILD_OPTIONS),nocheck))
        $(MAKE) test-baseline
        $(MAKE) test
 endif