]> git.donarmstrong.com Git - lilypond.git/blob - make/out/lilypond.mandrake.spec
release: 1.5.19
[lilypond.git] / make / out / lilypond.mandrake.spec
1 %define name lilypond
2 %define version 1.5.19
3 %define release 1mdk
4
5 Name: %{name}
6 Summary: A program for printing sheet music.
7 Version: %{version}
8 Release: %{release}
9 Source0: ftp.cs.uu.nl:/pub/GNU/LilyPond/development/lilypond-%{version}.tar.gz
10 ## Patch0: lilypond-GNUmakefile.in.patch.bz2
11 License: GPL
12 Group: Publishing
13 URL: http://www.lilypond.org/
14 BuildRoot: %{_tmppath}/%{name}-buildroot
15 BuildRequires: guile guile-devel
16 Requires: tetex
17
18 %description
19 LilyPond is a music typesetter.  It produces beautiful sheet music using a
20 high level description file as input.  Lilypond is part of the GNU project.
21  
22 LilyPond is split into two packages.  The package "lilypond" provides the
23 core package, containing the utilities for converting the music source
24 (.ly) files into printable output.  The package "lilypond-extras" provides
25 the full documentation, example .ly files for various features and the
26 Mutopia project files (musical equivalent of the Gutenberg project - see
27 http://www.mutopiaproject.org for details).
28  
29 If you are new to lilypond, you will almost certainly want to install the
30 "lilypond-extras" package in addition to the "lilypond" package.
31  
32 You may also wish to investigate the "denemo" package, which provides a
33 graphical front end to lilypond.
34
35 See the file README.first for more information.
36
37
38 %package extras
39 Summary: LilyPond documentation, examples and Mutopia files.
40 Group: Publishing
41 Requires: lilypond
42
43 %description extras
44 The documentation of LilyPond, both in HTML and PostScript, along with
45 example input files and the files from the Mutopia project.
46
47 %prep
48 %setup -a 1
49 ## % patch0 -b .orig
50
51 %build
52 # DO NOT use % { configure } , it hardcodes all paths, runs libtool,
53 # so we can't do make prefix=/tmp/ install.
54 # -- not sure what this comment means; it's a relic from the PPC spec file -- mbrown@fensystems.co.uk
55 ./configure --disable-checking --disable-debugging --enable-printing --prefix=%{_prefix} --disable-optimise --enable-shared
56 make
57 make local-web
58
59 %install
60
61 # Create installation root folders
62 rm -rf $RPM_BUILD_ROOT
63 RPM_DOC_ROOT=$RPM_BUILD_ROOT%{_docdir}/%{name}-%{version}
64 rm -rf $RPM_DOC_ROOT
65 mkdir -p $RPM_DOC_ROOT
66
67 make prefix="$RPM_BUILD_ROOT%{_prefix}" install
68 %{find_lang} %{name}
69
70 # Move info and man files into correct locations
71 mv $RPM_BUILD_ROOT/usr/info $RPM_BUILD_ROOT%{_infodir}
72 mv $RPM_BUILD_ROOT/usr/man $RPM_BUILD_ROOT%{_mandir}
73
74 # Move TeX font files into system TeX tree locations
75 mkdir -p $RPM_BUILD_ROOT%{_datadir}/texmf/fonts/{afm,source,tfm}
76 mv $RPM_BUILD_ROOT%{_datadir}/lilypond/afm $RPM_BUILD_ROOT%{_datadir}/texmf/fonts/afm/lilypond
77 mv $RPM_BUILD_ROOT%{_datadir}/lilypond/mf $RPM_BUILD_ROOT%{_datadir}/texmf/fonts/source/lilypond
78 mv $RPM_BUILD_ROOT%{_datadir}/lilypond/tfm $RPM_BUILD_ROOT%{_datadir}/texmf/fonts/tfm/lilypond
79 mkdir -p $RPM_BUILD_ROOT%{_datadir}/texmf/tex
80 mv $RPM_BUILD_ROOT%{_datadir}/lilypond/tex $RPM_BUILD_ROOT%{_datadir}/texmf/tex/lilypond
81
82 # Copy emacs mode files into %{_datadir}/lilypond/emacs
83 mkdir -p $RPM_BUILD_ROOT%{_datadir}/lilypond/emacs
84 cp *.el $RPM_BUILD_ROOT%{_datadir}/lilypond/emacs/
85
86 # Create documentation tree in %{_docdir}
87 mkdir -p $RPM_DOC_ROOT/HTML
88 tar -C $RPM_DOC_ROOT/HTML -xzf out/web.tar.gz
89 ln -s HTML/input $RPM_DOC_ROOT/Examples
90 ln -s HTML/input/test $RPM_DOC_ROOT/Tricks
91 ln -s HTML/mutopia $RPM_DOC_ROOT/Mutopia
92 mkdir -p $RPM_DOC_ROOT/Printable
93 ln -s ../HTML/Documentation/user/out-www/lilypond.ps.gz $RPM_DOC_ROOT/Printable/Manual.ps.gz
94 ln -s ../HTML/Documentation/user/out-www/glossary.ps.gz $RPM_DOC_ROOT/Printable/Glossary.ps.gz
95 cp AUTHORS.txt CHANGES COPYING DEDICATION FAQ.txt NEWS README.txt VERSION README.mandrake $RPM_DOC_ROOT/README.first
96
97 %post
98 touch /tmp/.lilypond-install
99 rm `find /var/lib/texmf -name 'feta*pk -print' -or -name 'feta*tfm -print'` /tmp/.lilypond-install
100 /usr/bin/mktexlsr
101 %_install_info lilypond.info
102 %_install_info lilypond-internals.info
103
104 %preun
105 %_remove_install_info lilypond.info
106 %_remove_install_info lilypond-internals.info
107
108 %postun
109 /usr/bin/mktexlsr
110
111
112 %files -f %{name}.lang
113 %defattr(-,root,root,0755)
114 %{_bindir}/*
115 %{_datadir}/lilypond/
116 %{_datadir}/texmf/fonts/afm/lilypond
117 %{_datadir}/texmf/fonts/source/lilypond
118 %{_datadir}/texmf/fonts/tfm/lilypond
119 %{_datadir}/texmf/tex/lilypond
120
121 %doc %{_infodir}/*
122 %doc %{_mandir}/man1/*
123 %doc %{_docdir}/%{name}-%{version}/AUTHORS.txt
124 %doc %{_docdir}/%{name}-%{version}/CHANGES
125 %doc %{_docdir}/%{name}-%{version}/COPYING
126 %doc %{_docdir}/%{name}-%{version}/DEDICATION
127 %doc %{_docdir}/%{name}-%{version}/FAQ.txt
128 %doc %{_docdir}/%{name}-%{version}/NEWS
129 %doc %{_docdir}/%{name}-%{version}/README.txt
130 %doc %{_docdir}/%{name}-%{version}/VERSION
131 %doc %{_docdir}/%{name}-%{version}/README.first
132
133 %files extras
134 %defattr(-,root,root,0755)
135 %doc %{_docdir}/%{name}-%{version}/HTML
136 %doc %{_docdir}/%{name}-%{version}/Mutopia
137 %doc %{_docdir}/%{name}-%{version}/Printable
138 %doc %{_docdir}/%{name}-%{version}/Tricks
139 %doc %{_docdir}/%{name}-%{version}/Examples
140
141
142 %changelog
143 * Fri Jun 01 2001 Lenny Cartier <lenny@mandrakesoft.com> 1.4.2-1mdk
144 - updated by Michael Brown <mbrown@linux-mandrake.com> :
145         - Upgraded to 1.4.2
146         - Changed URL
147         - Removed /etc/profile.d scripts: all TeX bits are now located properly
148         - Rearranged documentation
149         - Tidied spec file
150         - Updated README.first
151
152 * Mon Feb 26 2001 Lenny Cartier <lenny@mandrakesoft.com> 1.3.129-1mdk
153 - added in contribs by Michael Brown <mbrown@fensystems.co.uk> :
154         - Removed info files completely (couldn't get info reader to read them)
155         - TODO: Get this to work at some point (in the meantime, use documentation in lilypond-extras)
156
157 * Sat Feb 17 2001 Michael Brown <mbrown@fensystems.co.uk>
158 - Moved TeX font folders into the system TeX tree (this ensures that the /var/lib/texmf font cache is used instead of current folder)
159 - Added mktexlsr to post-install and post-uninstall scripts
160 - Patched scripts in /etc/profile.d to reflect changes to font locations
161 - Added QuickStart guide and Points to note sections to README.first (well worth reading)
162 - Fixed install-info and uninstall-info sections to use Mandrake's RPM macros :-)
163
164 * Tue Feb 13 2001 Michael Brown <mbrown@fensystems.co.uk>
165 - First Mandrake package
166 - spec file heavily adapted from PowerPC contribs.
167 - Note HTML documentation may contain duff links and may be incomplete.  Lots of warnings appear when building HTML docs.
168 - PostScript documentation is duplicated (how do you get an rpm package to contain a symlink?)
169 - Created README.first file