]> git.donarmstrong.com Git - deb_pkgs/libapache-gallery-perl.git/commitdiff
* Create var/cache/www and make it writable by www-data (Closes: #710281)
authorDon Armstrong <don@donarmstrong.com>
Sat, 31 May 2014 01:58:21 +0000 (01:58 +0000)
committerDon Armstrong <don@donarmstrong.com>
Sat, 31 May 2014 01:58:21 +0000 (01:58 +0000)
  Thanks to Bdale for noticing this.
* Do not attempt to delete /var/cache/www (Closes: #747260)
  Thanks to Andy Spiers <andy@spiers.co.uk> for the patch.
* Update standards version to 3.9.5 (no changes).
* Add rudimentary support for mp4 files (Closes: #704000).
  Thanks to Andres Salomon <dilinger@queued.net> for the patch.

git-svn-id: file:///srv/don_svn/deb_pkgs/libapache-gallery-perl/trunk@724 8f7917da-ec0b-0410-a553-b9b0e350d17e

debian/changelog
debian/control
debian/cron.daily
lib/Apache/Gallery.pm

index 47d67d3302f569699751c479424ddf3ff0e9353a..28eb866488f1edf0cd747bdee99fdf1a0d06d7e8 100644 (file)
@@ -1,3 +1,15 @@
+libapache-gallery-perl (1.0.2-3) unstable; urgency=medium
+
+  * Create var/cache/www and make it writable by www-data (Closes: #710281)
+    Thanks to Bdale for noticing this.
+  * Do not attempt to delete /var/cache/www (Closes: #747260)
+    Thanks to Andy Spiers <andy@spiers.co.uk> for the patch.
+  * Update standards version to 3.9.5 (no changes).
+  * Add rudimentary support for mp4 files (Closes: #704000).
+    Thanks to Andres Salomon <dilinger@queued.net> for the patch.
+  
+ -- Don Armstrong <don@debian.org>  Fri, 30 May 2014 18:53:18 -0700
+
 libapache-gallery-perl (1.0.2-2) unstable; urgency=low
 
   * Rewrite path to icons in request
index 307ca59787bbbedfee18ec521ab7ad02a93b95d0..2cf41ef2bc7b7a7c7e9a398328e72f33ba030444 100644 (file)
@@ -7,7 +7,7 @@ Build-Depends-Indep: perl, libmodule-build-perl, sharutils,
  libimage-size-perl, libimage-info-perl, libtemplate-perl,
  libimage-imlib2-perl, libtext-template-perl
 Build-Depends: debhelper (>= 8)
-Standards-Version: 3.9.2
+Standards-Version: 3.9.5
 
 Package: libapache-gallery-perl
 Architecture: all
index 0fe36db8cd302a8a7cf7774e93f3143a3f23cf69..3a80f98f37ace16a0502edd8e102f9dad4b5488a 100644 (file)
@@ -17,7 +17,7 @@ if [ -d "$cachedir" ]; then
     # remove empty directories
     start-stop-daemon --start --pidfile /dev/null --startas /bin/sh \
        --oknodo --chuid "$user" -- -c \
-       "find '$cachedir' -depth -type d -print0 | \
+       "find '$cachedir' -mindepth 1 -depth -type d -print0 | \
         xargs -r0 rmdir --ignore-fail-on-non-empty"
 fi
 
index e02bee91b384403cd8e4bc10334d4df3a7ed2c6e..c9a78d2502fefeed362c6836865080efe595e9d4 100644 (file)
@@ -187,10 +187,9 @@ sub handler {
 
        my $doc_pattern = $r->dir_config('GalleryDocFile');
        unless ($doc_pattern) {
-               $doc_pattern = '\.(mpe?g|avi|mov|asf|wmv|doc|mp3|ogg|pdf|rtf|wav|dlt|txt|html?|csv|eps)$'
+               $doc_pattern = '\.(mpe?g|avi|mov|asf|wmv|doc|mp3|mp4|ogg|pdf|rtf|wav|dlt|txt|html?|csv|eps)$'
        }
-       my $img_pattern = $r->dir_config('GalleryImgFile');
-       unless ($img_pattern) {
+       my $img_pattern = $r->dir_config('GalleryImgFile')      unless ($img_pattern) {
                $img_pattern = '\.(jpe?g|png|tiff?|ppm)$'
        }
 
@@ -1833,7 +1832,7 @@ Pattern matching the files you want Apache::Gallery to view in the index
 as normal files. All other filetypes will still be served by Apache::Gallery
 but are not visible in the index.
 
-The default is '\.(mpe?g|avi|mov|asf|wmv|doc|mp3|ogg|pdf|rtf|wav|dlt|txt|html?|csv|eps)$'
+The default is '\.(mpe?g|avi|mov|asf|wmv|doc|mp3|mp4|ogg|pdf|rtf|wav|dlt|txt|html?|csv|eps)$'
 
 =item B<GalleryTTFDir>