]> git.donarmstrong.com Git - unscd.git/blobdiff - debian/rules
Add systemd notification support for startup error reporting
[unscd.git] / debian / rules
index e0ec0238673b5fa85c044c650b022e8645779349..e5e2a42358b9aec4a26b346c8a2a7f4828642e63 100755 (executable)
@@ -1,14 +1,14 @@
 #!/usr/bin/make -f
 
 %:
-       dh $@
+       dh $@ --with systemd
 
 override_dh_auto_clean:
        rm -f nscd
        dh_auto_clean
 
 override_dh_auto_build:
-       gcc $(CFLAGS) $(LDFLAGS) -o nscd nscd.c
+       gcc $(CFLAGS) $(LDFLAGS) -o nscd nscd.c -lsystemd
        help2man --name 'nscd which does not hang' \
                --include debian/help2man \
                --no-info \
@@ -20,3 +20,6 @@ override_dh_auto_install:
        install -t debian/unscd/usr/sbin/ nscd
        install -d debian/unscd/etc/
        install -m644 -t debian/unscd/etc/ debian/nscd.conf
+
+override_dh_systemd_start:
+       dh_systemd_start --restart-after-upgrade --no-stop-on-upgrade