]> git.donarmstrong.com Git - unscd.git/blobdiff - debian/rules
Add systemd notification support for startup error reporting
[unscd.git] / debian / rules
index d45f9e4fc6ed610aefb2314a4fd0663d7d35bc18..e5e2a42358b9aec4a26b346c8a2a7f4828642e63 100755 (executable)
@@ -8,7 +8,7 @@ override_dh_auto_clean:
        dh_auto_clean
 
 override_dh_auto_build:
-       gcc $(CFLAGS) $(LDFLAGS) -o nscd nscd.c
+       gcc $(CFLAGS) $(LDFLAGS) -o nscd nscd.c -lsystemd
        help2man --name 'nscd which does not hang' \
                --include debian/help2man \
                --no-info \
@@ -20,3 +20,6 @@ override_dh_auto_install:
        install -t debian/unscd/usr/sbin/ nscd
        install -d debian/unscd/etc/
        install -m644 -t debian/unscd/etc/ debian/nscd.conf
+
+override_dh_systemd_start:
+       dh_systemd_start --restart-after-upgrade --no-stop-on-upgrade