]> git.donarmstrong.com Git - unscd.git/blobdiff - debian/rules
Add systemd notification support for startup error reporting
[unscd.git] / debian / rules
index 59e1de4d90f8570931befd9d1da6119fcd765cb7..e5e2a42358b9aec4a26b346c8a2a7f4828642e63 100755 (executable)
@@ -1,13 +1,25 @@
 #!/usr/bin/make -f
 
-%: 
-       dh $@
+%:
+       dh $@ --with systemd
+
+override_dh_auto_clean:
+       rm -f nscd
+       dh_auto_clean
 
 override_dh_auto_build:
-       gcc $(CFLAGS) $(LDFLAGS) -o nscd nscd.c
+       gcc $(CFLAGS) $(LDFLAGS) -o nscd nscd.c -lsystemd
+       help2man --name 'nscd which does not hang' \
+               --include debian/help2man \
+               --no-info \
+               ./nscd > debian/unscd.man
+       ln -fs unscd.man debian/nscd.man
 
 override_dh_auto_install:
-       $(INSTALL) -d debian/unscd/usr/sbin/
-       $(INSTALL) -t debian/unscd/usr/sbin/ nscd
-       $(INSTALL) -d debian/unscd/etc/
-       $(INSTALL) -m644 -t debian/unscd/etc/ debian/nscd.conf
+       install -d debian/unscd/usr/sbin/
+       install -t debian/unscd/usr/sbin/ nscd
+       install -d debian/unscd/etc/
+       install -m644 -t debian/unscd/etc/ debian/nscd.conf
+
+override_dh_systemd_start:
+       dh_systemd_start --restart-after-upgrade --no-stop-on-upgrade