]> git.donarmstrong.com Git - unscd.git/blobdiff - debian/rules
add manpage using help2man for unscd
[unscd.git] / debian / rules
index ca4fcbdb40bf57e2d17f5ad36c14defc57b15754..e0ec0238673b5fa85c044c650b022e8645779349 100755 (executable)
@@ -3,8 +3,17 @@
 %:
        dh $@
 
+override_dh_auto_clean:
+       rm -f nscd
+       dh_auto_clean
+
 override_dh_auto_build:
        gcc $(CFLAGS) $(LDFLAGS) -o nscd nscd.c
+       help2man --name 'nscd which does not hang' \
+               --include debian/help2man \
+               --no-info \
+               ./nscd > debian/unscd.man
+       ln -fs unscd.man debian/nscd.man
 
 override_dh_auto_install:
        install -d debian/unscd/usr/sbin/