]> git.donarmstrong.com Git - unscd.git/blobdiff - debian/rules
Add systemd unit file (Closes: #795621)
[unscd.git] / debian / rules
index ca4fcbdb40bf57e2d17f5ad36c14defc57b15754..d45f9e4fc6ed610aefb2314a4fd0663d7d35bc18 100755 (executable)
@@ -1,10 +1,19 @@
 #!/usr/bin/make -f
 
 %:
-       dh $@
+       dh $@ --with systemd
+
+override_dh_auto_clean:
+       rm -f nscd
+       dh_auto_clean
 
 override_dh_auto_build:
        gcc $(CFLAGS) $(LDFLAGS) -o nscd nscd.c
+       help2man --name 'nscd which does not hang' \
+               --include debian/help2man \
+               --no-info \
+               ./nscd > debian/unscd.man
+       ln -fs unscd.man debian/nscd.man
 
 override_dh_auto_install:
        install -d debian/unscd/usr/sbin/